Managing Enterprise-wide Deployment of IBM Explorer for z/OS or CICS Explorer

- Get an overview of the options for deploying Explorer software
- Review the advantages and disadvantages of each technique
- Learn how to customize your Explorer installation

David Nice
First Edition (January 2014)

This edition applies to IBM Explorer for z/OS Version 2.1 and IBM CICS Explorer Version 5.1.1.

Note: Before using this information and the product it supports, read the information in “Notices” on page v.
## Contents

**Notices** .......................................................... v
**Trademarks** ............................................................. vi

**Preface** .............................................................. vii
**Authors** .............................................................. vii
**Now you can become a published author, too!** ....................... viii
**Comments welcome** ................................................... viii
**Stay connected to IBM Redbooks** ....................................... viii

**Chapter 1.  Deployment considerations.** ............................ 1
1.1 Getting started ................................................... 2
1.2 Managing Explorer artifacts ..................................... 2
1.3 Installation area directory ....................................... 3
1.4 Configuration area directory ..................................... 3
1.5 Workspace directory .............................................. 4
1.6 Remote system connections ...................................... 4
1.7 Using z/OS Explorer as an integration platform ................. 5
1.8 Keeping your users up-to-date ................................... 6

**Chapter 2.  Using IBM Installation Manager** ......................... 7
2.1 Benefits ............................................................ 8
2.2 Drawbacks .......................................................... 8
2.3 Installing software ................................................ 8
2.4 Silent or unattended installation ................................ 8
2.5 Installing additional plug-ins and tools ......................... 9
2.6 Keeping up-to-date ............................................... 10
2.7 Rehosting Installation Manager repositories within your network ................................................. 10

**Chapter 3.  Using the Eclipse Update Manager** ....................... 11
3.1 Benefits ............................................................ 12
3.2 Drawbacks .......................................................... 12
3.3 Installing Explorer software ..................................... 12
3.4 Installing additional plug-ins and tools ......................... 12
3.5 Keeping up-to-date ............................................... 12
3.6 Rehosting p2 update sites on your network ...................... 13

**Chapter 4.  Using Java Web Start** ................................... 15
4.1 Benefits ............................................................ 16
4.2 Drawbacks .......................................................... 16
4.3 Implementation for CICS Explorer ................................ 16
4.4 Installing more plug-ins and tools ................................ 17
4.5 Managing customizations ......................................... 17
4.6 Keeping up-to-date ............................................... 18

**Chapter 5.  Using a network drive for installation** .................. 19
5.1 Benefits ............................................................ 20
5.2 Drawback ........................................................... 20
5.3 Setting up a shared version of CICS Explorer ................... 20
5.4 Installing other plug-ins and tools ................................ 20
Notices

This information was developed for products and services offered in the U.S.A.

IBM may not offer the products, services, or features discussed in this document in other countries. Consult your local IBM representative for information on the products and services currently available in your area. Any reference to an IBM product, program, or service is not intended to state or imply that only that IBM product, program, or service may be used. Any functionally equivalent product, program, or service that does not infringe any IBM intellectual property right may be used instead. However, it is the user's responsibility to evaluate and verify the operation of any non-IBM product, program, or service.

IBM may have patents or pending patent applications covering subject matter described in this document. The furnishing of this document does not grant you any license to these patents. You can send license inquiries, in writing, to:

IBM Director of Licensing, IBM Corporation, North Castle Drive, Armonk, NY 10504-1785 U.S.A.

The following paragraph does not apply to the United Kingdom or any other country where such provisions are inconsistent with local law: INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES THIS PUBLICATION "AS IS" WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF NON-INFRINGEMENT, MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. Some states do not allow disclaimer of express or implied warranties in certain transactions, therefore, this statement may not apply to you.

This information could include technical inaccuracies or typographical errors. Changes are periodically made to the information herein; these changes will be incorporated in new editions of the publication. IBM may make improvements and/or changes in the product(s) and/or the program(s) described in this publication at any time without notice.

Any references in this information to non-IBM websites are provided for convenience only and do not in any manner serve as an endorsement of those websites. The materials at those websites are not part of the materials for this IBM product and use of those websites is at your own risk.

IBM may use or distribute any of the information you supply in any way it believes appropriate without incurring any obligation to you.

Any performance data contained herein was determined in a controlled environment. Therefore, the results obtained in other operating environments may vary significantly. Some measurements may have been made on development-level systems and there is no guarantee that these measurements will be the same on generally available systems. Furthermore, some measurements may have been estimated through extrapolation. Actual results may vary. Users of this document should verify the applicable data for their specific environment.

Information concerning non-IBM products was obtained from the suppliers of those products, their published announcements or other publicly available sources. IBM has not tested those products and cannot confirm the accuracy of performance, compatibility or any other claims related to non-IBM products. Questions on the capabilities of non-IBM products should be addressed to the suppliers of those products.

This information contains examples of data and reports used in daily business operations. To illustrate them as completely as possible, the examples include the names of individuals, companies, brands, and products. All of these names are fictitious and any similarity to the names and addresses used by an actual business enterprise is entirely coincidental.

COPYRIGHT LICENSE:

This information contains sample application programs in source language, which illustrate programming techniques on various operating platforms. You may copy, modify, and distribute these sample programs in any form without payment to IBM, for the purposes of developing, using, marketing or distributing application programs conforming to the application programming interface for the operating platform for which the sample programs are written. These examples have not been thoroughly tested under all conditions. IBM, therefore, cannot guarantee or imply reliability, serviceability, or function of these programs.
## Trademarks

IBM, the IBM logo, and ibm.com are trademarks or registered trademarks of International Business Machines Corporation in the United States, other countries, or both. These and other IBM trademarked terms are marked on their first occurrence in this information with the appropriate symbol (® or ™), indicating US registered or common law trademarks owned by IBM at the time this information was published. Such trademarks may also be registered or common law trademarks in other countries. A current list of IBM trademarks is available on the Web at [http://www.ibm.com/legal/copytrade.shtml](http://www.ibm.com/legal/copytrade.shtml)

The following terms are trademarks of the International Business Machines Corporation in the United States, other countries, or both:

<table>
<thead>
<tr>
<th>Term</th>
<th>Trademark</th>
</tr>
</thead>
<tbody>
<tr>
<td>CICS®</td>
<td>IBM®</td>
</tr>
<tr>
<td>CICS Explorer®</td>
<td>IMS™</td>
</tr>
<tr>
<td>CICSPlex®</td>
<td>Rational®</td>
</tr>
<tr>
<td>DB2®</td>
<td>Redbooks®</td>
</tr>
<tr>
<td>developerWorks®</td>
<td>Redpaper™</td>
</tr>
</tbody>
</table>

The following terms are trademarks of other companies:

Linux is a trademark of Linus Torvalds in the United States, other countries, or both.

Microsoft, Windows, and the Windows logo are trademarks of Microsoft Corporation in the United States, other countries, or both.

Java, and all Java-based trademarks and logos are trademarks or registered trademarks of Oracle and/or its affiliates.

UNIX is a registered trademark of The Open Group in the United States and other countries.

Other company, product, or service names may be trademarks or service marks of others.
Preface

This IBM® Redpaper™ publication describes the set of features that IBM clients use to simplify deployment of the IBM Explorer products in their operating environments. This enables them to give different levels of control to the system administrator, provide different types of experiences for their users, and require different levels of technical knowledge to implement.

Before describing the different mechanisms available for deployment and the unique features of each, the author introduces some of the factors that are involved in deployment. He concludes with a comparison chart of the available technologies so that you can determine which is the most appropriate for your situation.

This paper is likely to interest the people in your organization who are responsible for planning, managing, and maintaining deployments of IBM z/OS® Explorer and IBM CICS® Explorer software.

Authors

This Redpaper publication was produced by a specialist working at IBM Hursley, Hursley Park, United Kingdom.

David Nice is an IBM CICS Explorer® developer in the UK. He has nine years of experience in a variety of job roles with IBM, including writing documentation, maintaining source control tools, and developing Eclipse GUI applications. Dave holds a degree in Acoustical Engineering from The University of Southampton.

Thanks to the following people for their contributions to this project:

ITSO GCS Team
International Technical Support Organization, Raleigh Center

Kathryn Briscoe, Geoff Pirie, Steven Horsman, Nick Bishop, Greg Lubel, Stew Francis, Isabel Arnold, Kevin Bowkett, Andy Bates
IBM Hursley Park
Now you can become a published author, too!

Here’s an opportunity to spotlight your skills, grow your career, and become a published author—all at the same time! Join an ITSO residency project and help write a book in your area of expertise, while honing your experience using leading-edge technologies. Your efforts will help to increase product acceptance and customer satisfaction, as you expand your network of technical contacts and relationships. Residencies run from two to six weeks in length, and you can participate either in person or as a remote resident working from your home base.

Find out more about the residency program, browse the residency index, and apply online at:

ibm.com/redbooks/residencies.html

Comments welcome

Your comments are important to us!

We want our papers to be as helpful as possible. Send us your comments about this paper or other IBM Redbooks® publications in one of the following ways:

► Use the online Contact us review Redbooks form:
  ibm.com/redbooks

► Send your comments in an email message to:
  redbooks@us.ibm.com

► Mail your comments to:
  IBM Corporation
  International Technical Support Organization
  Dept. HYTD Mail Station P099
  2455 South Road
  Poughkeepsie, NY 12601-5400

Stay connected to IBM Redbooks

► Find us on Facebook:
  http://www.facebook.com/IBMRedbooks

► Follow us on Twitter:
  http://twitter.com/ibmredbooks

► Look for us on LinkedIn:
  http://www.linkedin.com/groups?home=&gid=2130806

► Explore new Redbooks publications, residencies, and workshops with the IBM Redbooks weekly newsletter:

► Stay current on recent Redbooks publications with RSS Feeds:
  http://www.redbooks.ibm.com/rss.html
Deployment considerations

IBM Explorer for z/OS (z/OS Explorer) and CICS Explorer run on Linux and Microsoft Windows platforms. They are available as separately licensed components at no charge for use with IBM z/OS enterprise operating system, IBM CICS Transaction Server for z/OS, and other CICS products. For details about licensing and entitlement for use, check the Software license agreements search web page:


IBM z/OS Explorer helps manage connections to any number of z/OS mainframe systems, so you can create, edit, administer, and delete artifacts, including data sets, z/OS UNIX files, and z/OS jobs.

To minimize the number of separate tools and products that are required to be installed on a user's system, z/OS Explorer acts as an integration platform for installing tools to manage a range of z/OS subsystems, such as CICS, IBM DB2®, IBM WebSphere® MQ, IBM IMS™, and other software.

CICS Explorer is built on top of z/OS Explorer as a simple, easy to use management tool for one or more CICS systems. It provides functions to view and manage CICS Transaction Server regions and CICSpexes, as well as a platform for the integration of CICS tools. CICS Explorer also facilitates developing and deploying OSGi applications in a CICS Java virtual machine server.

Using standard Eclipse technology means that the Explorer products benefit from strong integration with other Eclipse-based products from IBM and other vendors. But it also means that Explorer must remain within the parameters and standards of the Eclipse platform to assure interoperability.

Most of the techniques and concepts described in this paper are applicable to the CICS Explorer SDK installed into Eclipse (see Appendix D, “Managing the Explorer SDK” on page 29) and the stand-alone Explorer products.

Appendix A, “Comparison of technologies” on page 23, provides a comparison table that summarizes the advantages and disadvantages of each deployment technique.
1.1 Getting started

Perhaps you downloaded z/OS Explorer or CICS Explorer already. There are two main technologies that are involved while installing and updating: IBM Installation Manager and Eclipse p2. Within either of these technologies, you can download the stand-alone product or a plug-in to extend another product that is already installed.

Over time, the set of supported scenarios and the available downloads evolve, of course. For z/OS Explorer 2.1 and CICS Explorer 5.1.1, which were released in June 2013, the following installation mechanisms are available:

For z/OS Explorer:
- The z/OS Explorer launchpad. If you are starting from scratch, this provides both the IBM Installation Manager software and z/OS Explorer, with the option to install plug-ins and tools.
- If you already have Installation Manager installed, you do not need to download anything. Add the repository URL listed on the z/OS Explorer download page by clicking File → Preferences within Installation Manager, and then clicking Install.

For CICS Explorer:
- The CICS Explorer p2 download. The .zip or .tar.gz file provides a copy of CICS Explorer that can be extended and updating by using the Eclipse p2 technology.
- To use Installation Manager, install z/OS Explorer by following the z/OS Explorer guidance, or install IBM Rational® Application Developer integrated development environment (IDE) software. Add the repository URL listed on the CICS Explorer download page by clicking File → Preferences within Installation Manager, and then click Install.
- To add CICS Explorer to an existing copy of a supported version of Eclipse, add the update site URL listed on the CICS Explorer download page by clicking Help → Install New Software within Eclipse, and then choose the features to install.

1.2 Managing Explorer artifacts

With a carefully thought-out deployment of Explorer, a system administrator can achieve a good balance of performance for the user and control over the software that is running within the enterprise. With planning, even some deeper aspects of the user experience, such as the connections available by default, can be controlled in most situations.

Note: Without due consideration of the appropriate deployment technique for your enterprise's situation, system administrators might get complaints from users and encounter difficulty in managing the Explorer products adequately.

There are many ways to deploy Explorer software, each with advantages and disadvantages:
- Using the standard p2 mechanism that is built into the Install New Software menu within the Eclipse Help
- Using IBM Installation Manager
- Using Java Web Start, provided by Oracle
- Hosting on a shared network
In the same way that an office productivity suite or a web browser is installed, the Explorer software must be run from the user's workstation (see Figure 1-1, where CMCI stands for CICS management client interface). Therefore, the installed files are stored on the user's workstation, updates must be applied on the user's workstation, and backups must be taken into account. There are techniques that you can use to retain control of the product code elsewhere, such as Java Web Start or by using a network share, but the product code always runs on the user's workstation.

By design, Eclipse-based applications are easily customizable so that you can offer your users an experience that is tailored for their job roles. To make this level of customization possible, some artifacts are stored on disk in addition to the Explorer product code. Understanding what is stored and how to control where it is stored is essential to managing rollouts, particularly when you are sharing an Explorer product installation among users.

1.3 Installation area directory

The installation area contains the executable code, plug-ins, and features. If the Explorer software is extended with other tools, their plug-ins and features are also installed in the installation area.

When you install the software, you choose the installation directory.

1.4 Configuration area directory

The configuration area contains some internal information about CICS Explorer: Which plug-ins and features are installed, some basic preferences (including which workspace was last used), and temporary data that is accessed by Explorer while it is in use.

By default, the configuration directory is stored within the installation directory.
1.5 Workspace directory

The workspace (or instance area) contains any files that are stored by the users, such as bundled projects and text files that they created in the Resource perspective. Some tools store files in the workspace (CICS Explorer plug-in's Configuration Manager job control language [JCL] templates, for example). Several preferences, such as the user's column customizations and available connections, are also stored in the workspace.

Users can have more than one workspace to use with the same Explorer product. For instance, the user might administer systems for two different clients and need to keep the connections and sets of bundles separate. Or the user might be developing applications for two different releases of CICS simultaneously.

Because the workspace directory contains most of the user's preferences and files, it is the most critical one to back up before upgrades and for disaster recovery.

1.6 Remote system connections

z/OS Explorer provides a connections framework to tools that extend it. The connections framework keeps track of connection details and related credentials. For instance, you might have an FTP connection that is defined within z/OS Explorer. If you have CICS Explorer installed also, you might have several connections to your IBM CICSPlex® System Manager (CICSPlex SM) web user interface (WUI) servers. These might all require the same credentials for connection, or they might require separate credentials.

Connection information is stored in the user's workspace. As a system administrator, you might need to frequently make sure that a set of CICS programmers all have the same set of, for example, 10 connections to production regions. Emailing all of your users to ask them to change the port number of a particular region is an inefficient and unreliable way of working. To help with this scenario, z/OS Explorer provides an export mechanism to record your set of connections as an XML file. Your users can then use this XML file to populate their set of connections.

When a user chooses to use an XML file of exported connections, they can choose to import the file or to load it. Importing the file creates local connections that the user can edit. Loading the file creates connections that the user cannot edit and that will synchronize with the original source.

**Note:** Using the Load Connections function, the system administrator gains central control of the set of connections available to users and can push updates to users' installations.

Explorer can use connections files stored both on disk, for example on a shared network drive, or hosted behind HTTP, for example, a web server or a CICS URIMAP resource definition.

Appendix B, “Using plugin_customization.ini to customize users’ workspaces” on page 25, explains how you might use the pluginCustomization feature to provide users with a set of connection preferences that are loaded from an HTTP server when they first use Explorer.
1.7 Using z/OS Explorer as an integration platform

The power of z/OS Explorer lies in your ability to extend it with tools to support your organization's work. Perhaps your team manages a CICS deployment, uses IBM CICS Deployment Assistant to help manage their CICS topology, and requires IBM Debug Tool for z/OS to debug CICS applications. Each of these tools provides a plug-in that is compatible with z/OS Explorer.

Depending on the deployment mechanism that you choose, you might need to preinstall the tools for the user, provide a silent installation script that automatically provisions the correct versions on the user's system, or make it simple for users to choose the set of tools most appropriate to their situations. IBM provides a repository and an update site, shown in Figure 1-2, that contains compatible versions of various tools, all accessible from one URL:

http://public.dhe.ibm.com/software/htp/zos/2/1/0/

Choosing the correct technology is nearly as important as sticking with it. Mixing installations of different types, such as Installation Manager and p2, or using Java Web Start but having users use p2 to install a tool, is not advisable and is likely to lead to problems for your users.
1.8 Keeping your users up-to-date

The IBM repository of compatible products is a single URL you can use in the Explorer products to provide access to a set of tools that are verified to work together in the Explorer environment. When a new fix or modification level update is released for a tool, IBM refreshes the repository. By using the repository or update site URLs, your users can keep up-to-date with the latest compatible versions of the installed tools.

If you need considerable control over the software versions that are available to your users, but you choose a technology where the user can install more tools, you can host the repositories that contain the IBM product code on your intranet. This enables you to test new versions of the tools and make them available to your team in a controlled manner.

The update happens in different ways, depending on the deployment mechanism that you choose. For some mechanisms, Explorer checks for updates when it starts and forces the user to wait while available updates install or a new version of Explorer downloads. For others, your desktop client team can push a trigger to initiate an automatic software update.
Chapter 2. Using IBM Installation Manager

IBM Installation Manager is an installation technology that is provided by IBM to manage the installation and upgrade of IBM products. Installation Manager also provides silent installation and upgrade if preferred and can be easily integrated into existing desktop management solutions that roll out software in your enterprise.

For compatible Eclipse applications, including the IBM Explorer products and many of the IBM Rational product suites, Installation Manager enables shell sharing (allowing access to all compatible products from one host product) and manages common components to reduce disk space use.

Installation Manager needs to keep track of the software that is present within an Explorer installation to manage dependencies and upgrades correctly. If you install Explorer by using IBM Installation Manager, you must make sure that, wherever possible thereafter, you use Installation Manager to extend and upgrade the installation.
2.1 Benefits

Using IBM Information Manager offers several benefits:

- The silent installation and upgrade capability makes Installation Manager easy to integrate into desktop management solutions.
- Installation Manager includes good shell-sharing capabilities.
- The architecture of IBM Installation Manager means that in many cases it is possible to upgrade all elements of the Explorer installation without requiring a reinstall.

2.2 Drawbacks

There are a couple of drawbacks to using Installation Manager:

- It requires a relatively heavyweight installation process.
- It is difficult to introduce customizations.

2.3 Installing software

The Installation Manager is a product that is installed onto your workstation. You add repositories into the Installation Manager (which can be local directories, compressed files, hosted within your local computer, on your intranet, or a URL provided by IBM) and install products from these repositories. Installation Manager prompts for additional information as required and installs the product. Products are assigned into Package Groups. Items within the same package group share some installation files and, therefore, must be compatible. The Installation Manager takes care of ensuring compatibility. In most cases, product upgrades are seamless.

2.4 Silent or unattended installation

IBM Installation Manager provides support for silent installations (installations that require no input from the user). The Installation Manager can be silently installed at the same time as the Explorer software.

Note: By using silent installation, you can push the Explorer software to a user's workstation by using your standard desktop management mechanism and forcing the application of updates. The users do not need to know how to use Installation Manager, so they are free to focus on their jobs.

The process to create a silent installation (Figure 2-1 on page 9) involves creating and editing a response file. The response file can add repositories; install, update, or remove packages; set up licenses; and trigger the user's workstation to reboot after installation. After creating the response file, distribute it to your users' work stations by using your standard desktop management mechanism, and then run it.
Figure 2-1   Using IBM Installation Manager for a silent installation procedure

For more information, see the IBM Installation Manager Information Center:

http://www.ibm.com/support/docview.wss?uid=swg27010911

2.5 Installing additional plug-ins and tools

Installation Manager maintains its own registry that tracks which software is installed into which Product Group and which versions of which files are on the disk. By tracking the Explorer software this way, the Installation Manager can manage product dependencies accurately and roll the installation back to a previous state, if necessary.

If you are accustomed to using Explorer without Installation Manager, you might be familiar with installing additional software either by using the drop-ins folder or by selecting Help and then clicking Install New Software (this is the Eclipse Update Manager facility, which manages extensions and updates by using the p2 provisioning engine that is built into Eclipse). If you use Installation Manager to install the Explorer software, try to also use Installation Manager to install more software or to update installed software. This is the best way to avoid problems with Installation Manager being unable to update your Explorer installation.

In situations where you must install a plug-in that is not available in Installation Manager format, it is possible to use the Eclipse Update Manager. However, choose that option only as a last resort. If installing the plug-in by using Eclipse alters files that are managed by Installation Manager, you might have problems keeping the software up-to-date in future.
2.6 Keeping up-to-date

Installation Manager installations are updated by the Installation Manager tool. You can trigger this by using the Update option in the Installation Manager tool or by a silent installation script.

The option to use silent installation scripts means that you can, for example, create a scheduled task to regularly check for, and install, available updates.

**Note:** It is important not to mix Installation Manager and Eclipse Update Manager. If you installed a product by using Installation Manager, it must be updated by using Installation Manager.

2.7 Rehosting Installation Manager repositories within your network

IBM provides a repository of compatible versions of a number of products on IBM servers. If you do not want your users to access the IBM repository for product installations or updates, you can download a copy of the required features from the IBM repository by using the IBM Packaging Utility.

The downloaded features are stored in a repository on your disk. You can rehost the repository on your network or pass it to your users as a compressed file, perhaps as part of your desktop management mechanism.

To use the IBM Packaging Utility, download it and install it. When you start the utility, you can choose to copy packages from a remote repository into one on your local disk, or to delete packages from a repository on disk. If you are rehosting the repositories internally, you might prefer to provide your users with Installation Manager by downloading it to avoid sharing the large launchpad .zip file around your internal network. You can download the utility from the Installation Manager and Packaging Utility web page:

Using the Eclipse Update Manager

Eclipse-based products contain a feature to manage software installation and upgrades called *Eclipse Update Manager*. The Update Manager uses the Eclipse p2 provisioning tool to manage installation and updates to Eclipse features from update sites. By clicking **Help → Install New Software** and using the menu that is built into IBM Explorer, you can add external websites, host update sites on your intranet, use folders, or use local .zip files that contain software and select components to install into Explorer.
3.1 Benefits

Using the Eclipse Update Manager offers these benefits:

- It manages dependencies and version requirements. This prevents incompatible software from being installed.
- You can use local update sites hosted on your network or distribute update sites to your users as archive files. This gives the system administrator some control over when updates happen and which code is in use.

3.2 Drawbacks

Using Eclipse Update Manager involves a few drawbacks:

- IBM Explorer checks for updates only at startup (and updates can be canceled) or when the user triggers a check.
- Silent updates cannot be set up easily.
- Eclipse Update Manager cannot upgrade some elements of the installation. For example, the Java Runtime Environment (JRE) that runs Explorer and some parts of the Eclipse system cannot be upgraded. Because of this, upgrades to newer versions of the Explorer software sometimes require a full reinstallation of Explorer when you use the Eclipse Update Manager.

3.3 Installing Explorer software

For an Eclipse Update Manager installation, CICS Explorer is supplied in a .zip file on Microsoft Windows platforms or a tar.gz file on Linux systems. To install CICS Explorer, decompress the file to a suitable location on the workstation.

3.4 Installing additional plug-ins and tools

IBM CICS Explorer is configured to use the IBM Explorer for z/OS update site. By clicking Help → Install New Software and choosing to work with this update site, you can quickly install various compatible IBM tools and products. Alternatively, you can add an update site that is provided to you by a vendor.

If you prefer not to use the IBM Explorer for z/OS update site, you can manage your available repositories by clicking Windows → Preferences.

3.5 Keeping up to date

By clicking Help → Check for Updates, you can trigger CICS Explorer to find and install available updates. CICS Explorer looks for updates in all enabled update sites.

By clicking Window → Preferences, you can set a schedule to check regularly for updates, or to check each time CICS Explorer is started.
Appendix B, “Using plugin_customization.ini to customize users’ workspaces” on page 25, explains how you can use the pluginCustomization technique to set preferences for users the first time that they use Explorer.

For information about a set of preferences that influence the auto-update behavior, see the “Configuring the UI Policy” section of the Eclipse documentation:


### 3.6 Rehosting p2 update sites on your network

If you do not want users to access the IBM update site for plug-in installations or updates, you can download a copy of the update site by using the Eclipse p2 mirroring tools that are built into IBM CICS Explorer.

To mirror a repository, follow these steps:

1. Identify the URL of the repository, either the one listed on the CICS Explorer download page or the one provided in the CICS Explorer.
2. Specify where you want to store the repository, for example: c:\temp\updatesite
3. Run CICS Explorer with the following additional command-line arguments:
   

   This starts CICS Explorer but with the p2 mirror application rather than the standard CICS Explorer GUI, which then mirrors the `-source` argument into the `-destination` argument.

   Run the command again to mirror the metadata also. There are two parts to a p2 repository: **artifacts** and **metadata**.

   Replace
   
   org.eclipse.equinox.p2.artifact.repository.mirrorApplication

   with
   
   org.eclipse.equinox.p2.metadata.repository.mirrorApplication

   For more information, see the “Mirroring repositories with p2” section of the Eclipse documentation:

Using Java Web Start

Java Web Start is a deployment technology that is owned by Oracle and delivered as part of the Java Runtime Environment (JRE). It provides a simple one-click experience for your user to get started by downloading IBM CICS Explorer from a web server hosted on your internal network.

**Note:** If the version on your web server changes, Web Start automatically downloads the newer version of CICS Explorer and replaces the copy that is cached on the user's workstation.

The CICS Explorer team provides sample code to demonstrate how you can use Java Web Start. You can get it from the “Deploy CICS Explorer using Java Web Start” entry of the WebSphere and CICS Support blog on the IBM developerWorks® website:

http://ibm.co/liWPzbw
4.1 Benefits

Using Java Web Start provides the following benefits:

- Web Start provides good control over the version of CICS Explorer that is in use.
- Installation is simple for users, and CICS Explorer startup times are fast after the application is cached.

4.2 Drawbacks

Using Java Web Start involves the following drawbacks:

- For system administrators, setting up the software is quite involved. Technical support is available from IBM for CICS Explorer but not for the Java Web Start technology.
- The initial download and any installation of updates take place when the user first starts CICS Explorer. They cannot be scheduled to occur at another time.
- Web Start is supported only on Microsoft Windows. CICS Explorer launches by using whichever Java runtime environment (JRE) is already installed on the user's workstation.

4.3 Implementation for CICS Explorer

Setting up Java Web Start requires the following steps to be completed in this order:

1. Prepare CICS Explorer as you want your users to receive it, with any plug-ins already installed and connection files imported.
2. Compress it into a Java archive (JAR) file and sign it with an encryption key.
3. Put the archive onto a web server, along with other files edited to meet your enterprise's requirements.

Full details of the process are available in the WebSphere and CIS Support Blog post titled “Deploy CICS Explorer using Java Web Start”:


Users access the file from a correctly configured browser or use the `javaws <url>` command to start CICS Explorer.

Java Web Start downloads the files from the web server and decompresses a copy of CICS Explorer into a temporary directory on the user's workstation. CICS Explorer starts by using the system JRE. See Figure 4-1 on page 17.

The user then continues to use CICS Explorer.

**Note:** When the administrator updates the version on the server, Java Web Start automatically downloads the updated version and replaces the earlier version.
4.4 Installing more plug-ins and tools

When the system administrator updates the version on the server, the user's earlier copy of Explorer is replaced with a new one. Because of this, users can make only limited modifications to their environments. Changes that they make that are stored in the workspace are persistent, but changes to the installation area are lost (for instance, using the Help menu to update or install plug-ins).

The system administrator must install the correct set of plug-ins and tools in the CICS Explorer before following the deployment steps. Each user receives a copy of CICS Explorer set up in the same way.

4.5 Managing customizations

Based on the elements outlined in Chapter 1, “Deployment considerations” on page 1, there are two areas to consider when you are customizing Java Web Start installations:

- The installation area (which also contains the configuration area)
- The workspace directory

With Web Start installations, the installation area is downloaded from the server and extracted onto the user's workstation. You can customize the installation area during preparation of the package. For example, you can install plug-ins or add a `connections.pref` file in the `CICS_Explorer` directory.
Each time that a new version of the package is downloaded to the user's workstation, the installation area refreshes. Customizations to the installation area made by the user are lost.

Conversely, although the content of the workspace cannot be preset by the system administrator, it can contain the user's customizations. The workspace is not reset when the CICS Explorer package updates. This means that a user's column customizations, new perspectives, and connections are kept intact.

To provide the user with a set of customizations when they first install the software, use the method of presetting Preference defaults that is described in Appendix B, “Using plugin_customization.ini to customize users' workspaces” on page 25.

4.6 Keeping up-to-date

Java Web Start automatically contacts the server to check for updates when an application is started by using the Java Web Start framework. If a newer version of the software is available on the server, it is downloaded and replaces the previous version.

The system administrator decides which version of CICS Explorer to use.
Using a network drive for installation

The simplest way to share an IBM CICS Explorer installation between multiple users is using a network drive. By following guidelines that are explained in this chapter, the system administrator prepares and configures the required version of CICS Explorer with any required plug-ins installed and then puts it onto a network drive.

Users access CICS Explorer directly from the network drive. CICS Explorer is set up so that the configuration area and workspaces are stored on users’ local workstations. The users can the develop OSGi bundles or access their own connections.
5.1 Benefits

Using a network drive offers these benefits:

- A shared network drive is simple to set up and simple to administer.
- The system administrator has control over the version of the software.

5.2 Drawback

CICS Explorer can be slow to start when hosted on a shared network drive. The startup speed depends on the speed of the connection.

5.3 Setting up a shared version of CICS Explorer

When you deploy CICS Explorer by using a shared network drive for multiple users, the main consideration is to ensure that Eclipse does not attempt to store user data within the shared part of the installation. The simplest way to do this is to make the installation read-only.

The Eclipse website provides documentation that describes the steps that are required to set up a multiuser installation:


**Note:** For further customizations, such as adding a connection provider or altering the default columns for a view, you can use the plugin_customization.ini technique that is described in Appendix B, “Using plugin_customization.ini to customize users’ workspaces” on page 25, to set default preferences for the workstations.

5.4 Installing other plug-ins and tools

At first glance, distributing plug-ins as part of a CICS Explorer shared network drive installation looks simple. You expect just to install the plug-ins before you put the package on the network drive. However, by starting CICS Explorer to install the required plug-ins, you will inadvertently seed some of the configuration, including the recently used workspace list.

Instead, use the p2 director tool that is provided with Eclipse and CICS Explorer. This process is described in Appendix C, “Using the p2 director to install plug-ins and tools” on page 27.

5.5 Keeping up to date

To update the version of CICS Explorer that is available, the system administrator updates the version that is stored on the network drive. It is safest to re-create a fresh installation with all of the required components at the correct level to avoid starting the CICS Explorer instance and initializing the configuration with unintended preferences, such as the recently used workspace list.
5.6 Using Installation Manager installs from a network drive

To install z/OS Explorer and additional tools and use them from a network drive, you must choose one workstation to be the master and then perform the installation from this workstation. The Installation Manager executable files and the Installation Manager registry are stored on that workstation.

During the installation, when you are prompted for the location for IBM z/OS Explorer and the Installation Manager shared resources, choose a location within your shared drive. From there, continue to follow the standard Eclipse process for a normal shared installation.

So that the supporting files can be found, your client workstations that run z/OS Explorer must map the same network drive to the same drive letter as on the master when z/OS Explorer was originally installed. To apply updates, you need to make the z/OS Explorer directory writeable and then use the master workstation to run Installation Manager and update the installation before you make it read-only again.

You might find it easier to avoid using Installation Manager on a shared network drive. Appendix D, “Managing the Explorer SDK” on page 29, explains how you can install the z/OS Explorer SDK into Eclipse to achieve a similar result without using IBM Installation Manager.


Comparison of technologies

Table A-1 provides an overview of some of the key decision factors in choosing one technology over another.

<table>
<thead>
<tr>
<th></th>
<th>IBM Installation Manager</th>
<th>Eclipse p2</th>
<th>Java Web Start</th>
<th>Network drive</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ease of client setup</td>
<td>Medium</td>
<td>Easy</td>
<td>Easy</td>
<td>Easy</td>
</tr>
<tr>
<td>Ease of server setup</td>
<td>Medium</td>
<td>N/A</td>
<td>Difficult</td>
<td>Medium</td>
</tr>
<tr>
<td>Client installation speed</td>
<td>Slow</td>
<td>Fast</td>
<td>N/A</td>
<td>N/A</td>
</tr>
<tr>
<td>Client load speed</td>
<td>Fast</td>
<td>Fast</td>
<td>Medium</td>
<td>Slow</td>
</tr>
<tr>
<td>Ease of customization for</td>
<td>Hard</td>
<td>Medium</td>
<td>Easy</td>
<td>Easy</td>
</tr>
<tr>
<td>administrators</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Ease of customization for users</td>
<td>Easy</td>
<td>Easy</td>
<td>Difficult</td>
<td>Medium</td>
</tr>
<tr>
<td>Level of control over version in</td>
<td>Medium</td>
<td>Low</td>
<td>High</td>
<td>High</td>
</tr>
<tr>
<td>use</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Ease of rehosting repositories</td>
<td>Easy</td>
<td>Medium</td>
<td>N/A</td>
<td>N/A</td>
</tr>
<tr>
<td>internally</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Compatibility with vendor Eclipse</td>
<td>Medium</td>
<td>Good</td>
<td>Good</td>
<td>Good</td>
</tr>
<tr>
<td>plug-ins</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Compatibility with IBM products</td>
<td>Good</td>
<td>Poor</td>
<td>Poor</td>
<td>Poor</td>
</tr>
</tbody>
</table>
Using plugin_customization.ini to customize users’ workspaces

Many of the changes that you make to your IBM Explorer environment are persisted between sessions by using the Eclipse Preferences framework. Eclipse provides a feature called pluginCustomization that you can use to suggest default values for these preferences.

You can use this technique to provide defaults for users with a fresh installation. For example, you can specify a different set of default columns to be available in a CICS resource view or have a remote connection provider added.

The following steps are involved in rolling out default preferences in this way:
1. Modify your local CICS Explorer and Export preferences.
2. Specify the preferences that you want to apply, and put them into a plugin_customization.ini file.
3. Roll out the plugin_customization.ini file to your users in their CICS_Explorer directories.

This example shows you how to customize the default columns that are available in the CICS Region view and add a remote connection provider.

To begin, start CICS Explorer with a new workspace. Load a remote connection provider from a URL, and customize the set of available columns in the CICS Regions view.

Export the preferences by clicking File → Export → Preferences. Open the exported file, which contains general Eclipse preferences and Explorer-specific preferences. The pair of lines that relate to the CICS Region view and the loaded connection provider and column customizations look like Example B-1 on page 26.
Example B-1  Snippet of exported preferences

/instance/com.ibm.cics.core.connections/connections/CONNECTION_SOURCES/13784619493
45-0/LOCATION=http://myserver/connections.pref
/instance/com.ibm.cics.core.ui/CICSRGN.columnNames=regionName,jobName,MVSSystemID,
taskCount

Both preferences start with /instance/, which indicates the scope that the preference was exported from. The instance scope means that they were stored in the instance area or workspace. You need to remove the scope as Example B-2 shows before you add them to the plugin_customization.ini file.

Example B-2  Snippet of preferences ready for inclusion in a plugin_customization.ini file

com.ibm.cics.core.connections/connections/CONNECTION_SOURCES/pluginCust-2013090611
31/LOCATION=http://myserver/connections.pref
com.ibm.cics.core.ui/CICSRGN.columnNames=regionName,jobName,MVSSystemID,taskCount

Notice that you also need to replace the randomly generated number in the connection provider preference with a string to ensure that there can be no clashes.

After appending these to the plugin_customization.ini file provided in the CICS_Explorer directory, starting Explorer with a new workspace sets these preferences by default. If a workspace is used that already has the preference set (for instance, the user set the CICS Regions view), that preference is not overwritten.

Preference names and details are not considered part of the API, so they might change between releases of CICS Explorer or Eclipse.
Using the p2 director to install plug-ins and tools

If you are not using IBM Installation Manager to manage your IBM Explorer installations, your users normally start the Explorer client and use the Help menu options to install new software. If you are configuring an Explorer instance to share with multiple users, avoid starting the Explorer client before distributing Explorer to your users. If you start the client, some preferences are set in the installation area, including the recent workspaces. In most cases, you will not want to distribute a client that has these initial preferences set, because the recent workspace list is specific to the computer that you are working on, not your users’ workstations.

Instead, use the Eclipse p2 director to install any additional plug-ins and tools that your users require.

First, establish the feature IDs that need to be installed. Use the GUI in a separate copy of Explorer. Click Help → Install New Software, and select the repository that you want to install from. Choose the software features that you want to install, and click Next. Make a note of the top-level feature IDs of the features that you choose. The choice is outlined in red in the example in Figure C-1 on page 28.
Now, run the separate copy of CICS Explorer by using a command similar to the one that is shown in Example C-1. Enter the command on one continuous line. (New lines appear in the following example merely for clarity.)

**Example C-1  Command to run a separate copy of CICS Explorer**

```
/path/to/CICS_Explorer_host/cicsexplorer
-application org.eclipse.equinox.p2.director
-repository http://public.dhe.ibm.com/software/htp/zos/2/1/0/
-installIU com.ibm.cics.pa.feature.feature.group
-destination /path/to/CICS_Explorer_for_distribution/
```

This command starts the p2 director application (rather than the CICS Explorer application). Specify the following details:

- The repository that contains the updated site code (the one that you chose in the GUI)
- The name of the features to install (separate by commas if more than one)
- The copy of CICS Explorer where you want to install the plug-in

For more information, see *Installing software using the p2 director application* on the Eclipse website:

Managing the Explorer SDK

Before IBM CICS Explorer Version 5.1.1, CICS Explorer was provided in two forms:

- CICS Explorer software for system administration and working with bundles for Event Bindings
- CICS Explorer SDK, which can be installed into an existing Eclipse instance, which supports developing OSGi applications for deployment within CICS Transaction Server (TS), developing IBM WebSphere Liberty web applications, and developing plug-ins that extend CICS Explorer functions

From CICS Explorer 5.1.1 onward, the SDK and associated base Eclipse function are part of the CICS Explorer software. Therefore, the SDK is no longer required separately. Both CICS Explorer and the SDK provide equivalent functions.

However, in some situations, it might be useful to use the SDK. For instance, by installing IBM z/OS Explorer into Eclipse, you can more easily distribute z/OS Explorer by using Java Web Start or a network share than by using IBM Installation Manager. To install z/OS Explorer into Eclipse, click Help → Install New Software to add the IBM repository of compatible plug-ins and choose the z/OS Explorer feature. You can find the URL for the IBM repository of compatible plug-ins on either the IBM Explorer for z/OS or CICS Explorer download page:


http://www.ibm.com/support/docview.wss?rs=1083&uid=swg24033579
Related publications

The publications that are listed in this section are particularly suitable for more detailed information about the topics in this paper.

IBM Redbooks

The following IBM Redbooks publications provide additional information about the topic in this document. Some publications cited in this list might be available in softcopy only.

- *IBM CICS Explorer*, SG24-7778-01
- *Extend the CICS Explorer: A Better Way to Manage Your CICS*, SG24-7819-00

You can search for, view, download, or order these documents and other Redbooks, Redpapers, Web Docs, drafts, and additional materials on the following website:

[ibm.com/redbooks](http://ibm.com/redbooks)

Online resources

These websites are also relevant as further information sources:

- IBM Explorer for z/OS
- IBM Explorer for z/OS V2.1 is announced
  [https://www.ibm.com/developerworks/community/forums/html/topic?id=c3076c01-72f4-4168-84e4-2c48e7dd9702](https://www.ibm.com/developerworks/community/forums/html/topic?id=c3076c01-72f4-4168-84e4-2c48e7dd9702)
- IBM Explorer for z/OS Version 2.1 provides extensible workstation access to key IBM z/OS functions
- Demonstrations of IBM Explorer for z/OS
  [http://www.youtube.com/playlist?list=PL7FC83818E652E82F](http://www.youtube.com/playlist?list=PL7FC83818E652E82F)
- CICS Explorer
- CICS Explorer downloads
- Software license agreements search
- IBM Installation Manager Information Center
- Installation Manager and Packaging Utility download links
WebSphere and CICS Support Blog: Deploy CICS Explorer by using Java Web Start

Eclipse documentation - Previous Release - Configuring the UI Policy

Eclipse documentation - Previous Release - Eclipse multi-user installs

Eclipse documentation - Previous Release - Installing software using the p2 director application

Eclipse documentation - Previous Release - Mirroring repositories with p2

Help from IBM

IBM Support and downloads
ibm.com/support

IBM Global Services
ibm.com/services
Managing Enterprise-wide Deployment of IBM Explorer for z/OS or CICS Explorer

Get an overview of the options for deploying Explorer software

Review the advantages and disadvantages of each technique

Learn how to customize your Explorer installation

This IBM Redpaper publication describes the set of features that IBM clients use to simplify deployment of the IBM Explorer products in their operating environments. This enables them to give different levels of control to the system administrator, provide different types of experience for their users, and require different levels of technical knowledge to implement.

Before describing the different mechanisms available for deployment and the unique features of each, the author introduces some of the factors that are involved in deployment. He concludes with a comparison chart of the available technologies so that you can determine which is the most appropriate for your situation.

This paper is likely to interest the people in your organization who are responsible for planning, managing, and maintaining deployments of IBM z/OS Explorer and IBM CICS Explorer software.