Customization and Deployment of WebSphere Service Registry and Repository Business Space Widgets

This IBM® Redpaper™ publication describes how you can customize IBM Business Space powered by IBM WebSphere® to provide a business-orientated view onto IBM WebSphere Service Registry and Repository for a number of user roles. It describes functionality available in WebSphere Service Registry and Repository V7.0 Fix Pack 2 (V7.0.0.2) and the WebSphere Service Registry and Repository Feature Pack 1. It includes the following sections:

- Introduction to IBM Business Space powered by WebSphere
- Introduction to WebSphere Service Registry and Repository Business Space widgets
- Introduction to WebSphere Service Registry and Repository Business Space templates
- Business Space customization overview
- Search widget customization overview
- Collection widget customization overview
- Customizing Business Space scenario
- Exporting templates and WebSphere Service Registry and Repository configuration
- Loading the configuration into Studio
- Using the sample templates and configuration in Business Space

This paper assumes that you have knowledge of, and have installed, WebSphere Service Registry and Repository and Business Space. It also assumes that you have the WebSphere Service Registry and Repository Feature Pack 1 Business Space widgets installed into Business Space.
Introduction to IBM Business Space powered by WebSphere

This section provides an introduction to Business Space powered by WebSphere, what it does, and the concepts it uses to present a user interface. For more details about Business Space powered by WebSphere, see Building IBM Business Process Management Solutions Using WebSphere V7 and Business Space, SG24-7861.

What is Business Space powered by WebSphere

Business Space powered by WebSphere is a general user interface framework for aggregating content and delivering it through a browser. In this Redpaper, Business Space is used to mean IBM Business Space powered by WebSphere.

A business space is a collection of related web content that provides you with insight into your business.

You can have many business spaces present on a Business Space run time, and each space has within it a number of tabbed pages. Each space is set up to provide pages relevant to a particular role or business function.

Business Space concepts

This section describes the concepts and terminology of Business Space.

Business Space

As mentioned, a business space is a collection of related web content that might include collections of pages that comprise a business process, application, or collaborative user experience. For example, a WebSphere Service Registry and Repository business space allows you to work with items in WebSphere Service Registry and Repository.

Business Space can display the contents of one business space at a time. This space is the open space.

The open space consists of a banner area and a page area. The top of the banner contains menus, which provide options that affect the open business space or options for navigating to another space. Figure 1 shows an example of the menus, banner area, and page for an open space.

![Welcome to Business Space](image)

Figure 1  Welcome to Business Space

Below the menus, the banner area displays the name of the open space and tabs for the pages in the space.

Page

The page area is below the banner on a open space. The tab for the open page is highlighted. If you are the business space owner or an editor, you can edit a page to add or remove...
widgets or change where the widgets are displayed on the page, or how they display their data.

**Template**

The *templates* included with Business Space are examples of how you can use Business Space to accomplish your business goals. They provide predefined space layouts to achieve a particular business goal.

Each product that supports Business Space provides its own set of templates. These get added to the available templates when the product is installed in the same profile as the WebSphere Application Server.

For more information, see “Introduction to WebSphere Service Registry and Repository Business Space templates” on page 7.

**Widget**

*Widgets* are the plugable user interface components that you use to define the functionality of your business spaces. Widgets consist of an XML descriptor with optional JavaScript and HTML resources.

You can combine widgets to interact with each other to perform related tasks. A page usually contains a combination of widgets.

**Widget wiring**

Business Space allows you to define *wires* between your widgets so that an event occurring in one widget affects the behavior of another widget. Each widget defines a set of events that it can send and a set of events that it can receive. The source widget is the widget that sends out the event, and the target widget is the widget that receives the event. When a target widget receives an event, it performs an action based on the payload of the incoming event.

For example, you can define a wire between the Service Registry Collection widget and the Service Registry Detail widget, so that when a user selects an entity from the listing in the collection widget, its details are displayed in the details widget.

Business Space also attempts to automatically wire your widgets. When you drop a new widget on to your page, Business Space checks if any of the already existing widgets emits an event that matches one of the events the new widget can receive. If there is a match, Business Space wires those two widgets together, with the pre-existing widget as the source widget and the new widget as the target. It also wires events emitted by the dropped widget to other widgets which consume those events.

**Users and security**

The four main roles that any user can have in Business Space are superuser, owner, editor and viewer.

**Superuser**

The superuser has administrative privileges that allows this user to see all spaces and pages. Furthermore, the superuser is the only user with the ability to manage templates.

**Owner**

An owner of a space is initially the person who created it. The owner can create pages in that space and assign viewer and editor privileges to these pages. Furthermore, the owner can delete or transfer ownership and share or export the space.
**Editor**
An editor can add and share pages in a space. Furthermore, the editor can add widgets to pages and customize these widgets. A user is assigned the editor privileges by either the owner of that space or the administrator.

**Viewer**
A viewer can access the pages of a space and resize widgets. The viewer cannot add pages or share them. A viewer can use the widgets on a page.

**Introduction to WebSphere Service Registry and Repository Business Space widgets**

This section presents an overview of the WebSphere Service Registry and Repository widgets for Business Space.

**Service Registry Search widget**

The Service Registry Search widget is used to search for items in the service registry. The type of item to search for can be filtered by using a pull-down menu. The widget provides an Auto-Suggest feature. When you enter text into the search field, you are given a list of matching suggestions. The Search widget is shown in Figure 2.

![Service Registry Search widget](image)

*Figure 2  The Service Registry Search widget*

**Service Registry Collection widget**

The Service Registry Collection widget shows collections of items in the service registry. The widget has a View menu that can be used to select the collection to display; it has the following options:

- The last 100 most recently changed items
- All the items created by the current user
- The last 100 most recently changed items that were created by the current user
- The results of the last search

The Collection widget provides certain functionality that is not available in the web UI, such as showing the life-cycle state of an entity and any classifications on an entity, in a column. The Collection widget is shown in Figure 3 on page 5.
The Search and Service Reuse widgets send events that the Collection widget can receive to populate its contents. (See “Service Reuse widget” on page 7.) The Collection widget also sends events that can be received by the Detail widget. For example, if you click a row in the Collection widget, the Detail widget will change to show the item in the row that was selected, assuming the widgets are wired together.

**Service Registry Detail widget**

The Service Registry Detail widget shows the details of an item in the service registry. It shows the properties, classifications, and relationships of an item. The Detail widget allows editing of metadata on an entity, properties, classifications and relationships, and the loading of documents for relationships with a document target. The Detail widget is shown in Figure 4 on page 6.
Customization and Deployment of WebSphere Service Registry and Repository Business Space Widgets

Service Registry Actions widget

The Service Registry Actions widget provides links to key service registry tasks. Click the Work with my Business Capabilities link to populate the Collection widget with Business Capabilities created by the current user. Click the Propose a Business Capability link to launch the Propose a Business Capability dialog box, from which you can create a new Business Application, Process, or Service, and provide a charter document. The Actions widget is shown in Figure 5.
**Service Reuse widget**

The Service Reuse widget provides a report of current service reuse levels in the registry, using the number of service level agreements consuming service level definitions. You can click a slice of the pie chart to populate the Collection widget with a list of the business capabilities represented by the slice. You can restrict the type of business capability that is reported on by using the View pull-down menu. The Service Reuse widget is shown in Figure 6.

![Service Reuse widget](image)

*Figure 6  The Service Reuse widget*

**Introduction to WebSphere Service Registry and Repository Business Space templates**

WebSphere Service Registry and Repository provides two Business Space templates, one of which uses the WebSphere Service Registry and Repository Business Space widgets. This template is called Service Registry. It provides two pages:

- The Overview page contains all the WebSphere Service Registry and Repository widgets.
- The Search page contains the Search, Collection and Detail widgets.

The Service Registry template is shown in Figure 7 on page 8.
Business Space customization overview

This section presents an overview of the various ways you can customize the WebSphere Service Registry and Repository widget and Business Space itself.

Widget customization for WebSphere Service Registry and Repository widgets

This section describes the WebSphere Service Registry and Repository widgets that can be customized, and how the customizations are stored in WebSphere Service Registry and Repository.

Service Registry widget display settings

Figure 8 on page 9 shows how the WebSphere Service Registry and Repository (WSRR) widget display settings are stored in WebSphere Service Registry and Repository.
All Service Registry widgets in a Business Space server query a single WebSphere Service Registry and Repository server. Configuration performed at the time the widget is installed specifies which WebSphere Service Registry and Repository server to use; by default, this server is the WebSphere Service Registry and Repository server upon which the Business Space is running. A Business Space endpoint defines the location of the WebSphere Service Registry and Repository server. The Service Registry widgets make use of two Business Space endpoints: one locates the WSRR REST API and one locates the WSRR Atom API.

When you change the display settings for a Service Registry widget, those changes are stored in the WebSphere Service Registry and Repository profile on the WebSphere Service Registry and Repository server that the Service Registry widgets are using. A new WebSphere Service Registry and Repository configuration type of Business Space Configuration was added in WebSphere Service Registry and Repository V7.0.0.2 to store Service Registry widget configuration.

Many Business Space Configurations can be stored in WebSphere Service Registry and Repository, but only one is used by all the Service Registry widgets in a space. The WSRR Business Space Configuration name specifies which Business Space Configuration in WebSphere Service Registry and Repository is used, and is set in the WSRR Business Space Configuration Settings dialog box. If no WSRR Business Space Configuration name is specified, the WSRR widgets use their own defaults.

If the current space does not have a WSRR Business Space Configuration name set, when you first edit the display settings for any WebSphere Service Registry and Repository widget, the WSRR Business Space Configuration Settings dialog box opens.

The WSRR Business Space Configuration Settings dialog box can be opened at any time by using the icon at the bottom of any WSRR Widget display settings panel, as shown in Figure 9 on page 10.
WSRR Business Space Configuration Settings dialog box

The WSRR Business Space Configuration Settings dialog box is where you specify the WSRR Business Space Configuration name, which contains all the display settings for the WebSphere Service Registry and Repository widgets in the space. Figure 10 shows the dialog box.

A WSRR Business Space Configuration name is set by selecting an entry from the WSRR Business Space Configuration pull-down menu. The dialog box can be used to create a new, empty WSRR Business Space Configuration, or create a new one from an existing configuration.

Customizable Service Registry widgets

In WebSphere Service Registry and Repository Feature Pack 1, you can specify display settings for the Search and Collection widgets. These display settings are described in “Search widget customization overview” on page 11 and “Collection widget customization overview” on page 13.

Templates and sharing spaces

Templates in Business Space are used to define a set of pages and widgets that are geared towards certain scenarios. They enable users to quickly define their own business spaces with potentially minor adjustments to the template they choose.

Business Space comes with several predefined templates, but administrators can create and share new templates in Business Space. The Service Registry widgets come with a Service Registry template. Templates are created from an already existing space.

In Business Space, you have the capability to share a space or a page with a set of users. As the owner of a space or the super-user, you can assign users either a viewer role or an editor role for your space or page. By default, the permissions you set on a space are inherited by all its pages. If a user is an editor for your space, they are an editor for all pages within that space.
WebSphere Service Registry and Repository users and security

By default, all authenticated users (all users who can log into Business Space successfully) can load a WebSphere Service Registry and Repository Configuration, therefore, all users are able to use WebSphere Service Registry and Repository Business Space Configurations with WebSphere Service Registry and Repository widgets.

The space editor, owner, or superuser, must be a WebSphere Service Registry and Repository administrator to save WebSphere Service Registry and Repository widget display settings onto the WebSphere Service Registry and Repository server. Only these administrators can save WebSphere Service Registry and Repository Configuration, therefore an ordinary business user is not able to save any edits they make to the WebSphere Service Registry and Repository widget display settings.

Business Space themes

You can change both the Business Space login page and the look and feel of a certain space by supplying a custom style. Figure 11 shows the JKHLE style created for this Redpaper.

Search widget customization overview

The Service Registry Search widget can be customized by editing its display settings. The display settings menu for a widget is accessed from Business Space. To edit the display settings, perform the following steps:

1. From the space, click Edit Page (as shown in Figure 12).

2. On the Search widget, click the down arrow to open the widget options menu and select Edit Settings (as shown in Figure 13 on page 12).
The Service Registry Search Display Settings dialog box opens, as shown in Figure 14.

The following aspects of the Search widget can be customized by using the dialog box:

- Enable or disable the Auto-Suggest pop-up.
- Alter the number of milliseconds between when you enter text into the search box and when the widget submits a request to build a list of suggestions.
- Set which types are to be available for searching from a list of all Business Models in WebSphere Service Registry and Repository.
- Set the default type to search on, in the Search widget types list (All Listed Types, or one of the types available for searching).
- Set the order of types in the Search widget types list.
Collection widget customization overview

The Service Registry Collection widget can be customized by editing its display settings. The Collection widget display settings dialog box is accessed in the same way as the Search widget display settings. The Service Registry Collection Display Settings dialog box is shown in Figure 15.

The dialog box (Figure 15) has two sections:

- The types navigator on the left lists all business models in WebSphere Service Registry and Repository and an entry for general settings.
- The details panel on the right shows details of whichever item has been clicked in the types navigator.

The following aspects of the Collection widget can be customized using the dialog box:

- The default collection for the instance of the Collection widget, from My Recent Items, All Recent Items, All My Items, and Search Results.
- For each business model in WebSphere Service Registry and Repository and any collection with mixed types, determine the following information:
  - Whether to display a description for the business model in the collection
  - Whether to inherit Collection settings from the immediate super class in the business model system

Note: When you load a new business model into WebSphere Service Registry and Repository, the Search widget does not show them as searchable types. If you edit the Search widget display settings, new business models are listed at the end of the type list and are initially unselected.
– Which properties from the business model to display as columns in the view
– How many columns to show
– The default sort column and default sort order (ascending or descending)

When you load a new business model into WebSphere Service Registry and Repository, the Collection widget initially defaults to showing three columns of name, type and state for the business model. If you edit the display settings for the Collection widget, new business models appear in the type list and you can edit their display settings.

Customizing Business Space scenario

This section shows how to customize the WebSphere Service Registry and Repository Business Space widgets in the scenario.

Introduction to the scenario

*JKHL Enterprises* (JKHLE) is a fictitious supply company facing the typical challenges that arise when striving to reach the potential benefits of SOA solutions. JKHLE is an example that also appears in other IBM materials.

JKHL Enterprises want to customize a space in Business Space for Bob their Business Analyst. The space should display non-technical terms and show business-oriented information about items in WebSphere Service Registry and Repository. The default settings that are included with the WebSphere Service Registry and Repository widgets are carefully customized for a business user; JKHL Enterprises wants to make minor modifications to the WebSphere Service Registry and Repository widget display settings.

JKHL Enterprises wants to retain control of the customization so that business users can use the space but not change it. Changes are made by a Business Space administrator when updates are required. Ian, the WebSphere Service Registry and Repository administrator for JKHL Enterprises, is responsible for administering Business Space.

To make the customizations, Ian starts with the Service Registry Business Space template, creates an instance, and then sets the WebSphere Service Registry and Repository widget display settings. Finally he shares the new space to business users.

Create an instance of the Service Registry template

To create an instance of the Service Registry template, Ian logs into Business Space, and then performs the following steps:

1. Click Manage Spaces.
2. In the Space Manager dialog box, click Create Space.
3. In the Create Space dialog box, shown in Figure 16 on page 15, enter WSRR Business in the Space Name field. Select Service Registry in the Create a new space using a template pull-down menu.
4. Click Save.
Figure 16  The Create Space dialog box

5. The created space is shown in the Space Manager dialog box. Click **WSRR Business** to enter the space.

**Business Space configuration settings**

To set the WebSphere Service Registry and Repository Business Space configuration to use for the WebSphere Service Registry and Repository Business Space, Ian performs the following steps from the WSRR Business Space:

1. Click **Edit Page**.
2. On the Search widget, click the **down arrow** to open the widget options menu and click **Edit Settings**.

   The WSRR Business Space Configuration Settings dialog box opens (Figure 17) because the WSRR Business Space Configuration name is not set in the space.

Figure 17  The WSRR Business Space Configuration Settings dialog box

3. Click **Create a new Business Space Configuration**.

   The Create a new Business Space Configuration panel opens, as shown in Figure 18 on page 16.

4. In the WSRR Business Space Configuration Name field, enter **Business**. Clear the **Copy from existing configuration** check box.
5. Click **Create**.

6. The WSRR Business Space Configuration field is set to Business, as shown in Figure 19. Click **Save and Close**.

7. Click **Finish Editing**.

The WSRR Business Space Configuration for the space is now set to Business and a configuration item has been created in WebSphere Service Registry and Repository. The widgets reload their default configuration and the Service Registry Search Display Settings dialog box opens. Click **OK** to dismiss the dialog box.
Search widget

The JKHL Enterprises business analyst, Bob, has the following requirements:

- He needs to search WebSphere Service Registry and Repository for business capabilities during the planning for a new business service, to find any candidates for reuse.
- He needs a view of capability versions and any documents of understanding (DOUs) that might be in place.
- He needs to search for the organizations defined in WebSphere Service Registry and Repository. Bob would like to initially search on business capabilities, and prefers capability version and its sub-types to be at the bottom of the search types list.

To customize the WebSphere Service Registry and Repository Search widget to allow searching only on the identified types, Ian performs the following steps from the WSRR Business space:

1. Click **Edit Page**.
2. On the Search widget, click the **down arrow** to open the widget options menu and click **Edit Settings**.
3. Ensure that only the following types are selected:
   - Business Capability
   - Business Application
   - Business Process
   - Business Service
   - Capability Version
   - Application Version
   - Process Version
   - Service Version
   - DOU
   - Organization
4. Select **Business Capability** in the Default filter pull-down menu.
5. Click **Show only visible types**.
6. Click the **up arrow** to the left of DOU. The DOU row moves up one row. Click the **up arrow** next to DOU three more times, so that it is below the Business Service entry.

   **Hint:** You may also drag the rows in the collection types to reorder them.

7. Move the Organization row to just below the DOU row.
   
The completed settings are shown in Figure 20 on page 18.
8. Click **OK**.
9. Click **Finish Editing**.

The Service Registry Search widget is now configured to search for the types relevant to Bob, with the business capability type as the default. The customized search widget is shown in Figure 21.
Collection widget

The JKHL Enterprises business analyst, Bob, needs to view business capabilities in WebSphere Service Registry and Repository to understand their state and what they provide. He also needs a view onto capability versions and any DOUs that might be in place.

To begin customizing the Collection widget, Ian performs the following steps from the WSRR Business space:

1. Click **Edit Page**.
2. On the Collection widget, click the **down arrow** to open the widget options menu, and then click **Edit Settings**.

   The Service Registry Collection Display Settings dialog box opens, as shown in Figure 22.

![Service Registry Collection Display Settings panel](image-url)

**Figure 22** The Service Registry Collection Display Settings panel

**General settings and business capabilities**

The business capability collection should show the type of the business capability, however the subtypes (application, process and service) do not need the type column, because the collection will never have more than one type. Therefore, you cannot inherit the settings from the parent business capability for business application, process, and service types.

To customize the Collection widget to display the required default view and useful columns for business capability sub-types, Ian performs the following steps:

1. In the navigator, click **General Settings**.
2. Select **My Recent Items** in the Default View pull-down menu.
3. In the types navigator, click Asset, to display the Asset settings in the details pane, shown in Figure 23.

![Asset Collection widget display settings](image)

Figure 23  Asset Collection widget display settings

4. Ensure that the **Display description in collection** check box is selected.

5. In the types navigator, expand the **Asset** node.

6. Expand the **Business Capability** node.

7. Click **Business Application**.

   The Business Application settings is displayed in the details pane, as shown in Figure 24 on page 21.
8. Clear the Inherit settings from Business Capability check box.
9. Select Name in the Column 1 pull-down menu.
10. Select State in the Column 2 pull-down menu.
11. Click X in Column 3 to delete Column 3.
12. Ensure that the Display description in collection check box is selected.
13. Click the sort order indicator (up or down arrow) in Column 1 until it points down, as shown in Figure 25 on page 22.
14. In the types navigator, click **Business Process**.
15. Repeat steps 8 on page 21 - 13 on page 21.
16. In the types navigator, click **Business Service**.
17. Repeat steps 8 on page 21 - 13 on page 21.

**Capability versions**

To customize the WebSphere Service Registry and Repository Collection widget to display useful columns for capability version sub-types, Ian performs the following steps:

1. In the types navigator, expand **Capability Version**.
2. Click **Application Version** to display the Application Version settings in the details pane.
3. Clear the **Inherit settings from Capability Version** check box.
4. Select **Name** in the Column 1 pull-down menu.
5. Select **State** in the Column 2 pull-down menu.
6. Select **Version** in the Column 3 pull-down menu.
7. Select **Owner Email** in the Column 4 pull-down menu.
8. Select the **Display description in collection** check box.
9. Click the sort order indicator (up or down arrow) in Column 1 until it points down, as shown in Figure 26 on page 23.
10. In the navigator, click **Process Version**.

11. Repeat steps 3 on page 22 - 9 on page 22.

12. In the navigator, click **Service Version**.

13. Repeat steps 3 on page 22 - 9 on page 22.

**DOU and Organization**

Finally, to customize the WebSphere Service Registry and Repository Collection widget for DOU and Organization types, Ian performs the following steps:

1. In the types navigator, click **DOU**. This will display the DOU settings in the details pane.

2. Clear the **Inherit settings from Asset** check box.

3. Select **Name** in the Column 1 pull-down menu.

4. Select **State** in the Column 2 pull-down menu.

5. Click X in Column 3 to delete Column 3.

6. Check **Display description in collection**.

7. Click the sort order indicator (up or down arrow) in Column 1 until it points down, as shown in Figure 27 on page 24.
8. In the navigator, click **Organization** to display the Organization settings in the details pane.

9. Select **Name** in the Column 1 pull-down menu.

10. Select **Contact** in the Column 2 pull-down menu.

11. Select **Contact Email** in the Column 3 pull-down menu.

12. Click **X** in Column 4 to delete Column 4.

13. Check **Display description in collection**.

14. Click the sort order indicator (up or down arrow) in Column 1 until it points down, as shown in Figure 28 on page 25.
Save display settings

To save the display settings perform the following steps:

1. In the Service Registry Collection Display Settings dialog box, click **OK**.
2. In the space, click **Finish Editing**.

The Collection widget reloads the current collection using the new columns.

To see the customized collection view for a business service, perform the following steps from the WSRR Business space:

1. In the Search widget, select **Business Service** from the types pull-down menu.
2. Click **Search**.

The Collection widget shows all business services in WebSphere Service Registry and Repository. The customized collection view for a business service is shown in Figure 29.
Business Space theme for JKHLE

JKHL Enterprises decides to customize the Business Space theme to place the company's logo on-screen and change the colors. See the additional materials accompanying this paper for the .zip file (which you must extract) that contains JKHLE style. To load the style into Business Space, perform the following steps:

1. Log in to the WebSphere Application Server Integrated Solutions Console.
2. Expand Servers → Server Types, click WebSphere Application Servers, and then click the server hosting Business Space.
5. Define a new environment variable BSPACE_STYLE_EXT_DIR. The value must be the path up to and including the JKHLEStyle folder.
6. Click Save to save the changes.
7. Restart the application server.

See Building IBM Business Process Management Solutions Using WebSphere V7 and Business Space, SG24-7861 for further details about creating a custom style.

To change the WebSphere Service Registry and Repository Business space to use the JKHLE style, perform the following steps from the WSRR Business space:

1. Click Actions.
2. Click Edit Space Settings.
3. In the Space Style section, click JHKL Enterprises, as shown in Figure 30.

4. Click Save.

Note: A good practice is to clear the web browser cache after loading or modifying a Business Space style.
Sharing the space

To share the space to Bob and other business users, Ian follows instructions in *Building IBM Business Process Management Solutions Using WebSphere V7 and Business Space*, SG24-7861, section 2.2.4.

Exporting templates and WebSphere Service Registry and Repository configuration

To preserve its customized space, the JKHL Enterprises company must make a copy of the WebSphere Service Registry and Repository Business Space. The company must create a template in Business Space, export it and then export the Business Space Configuration from WebSphere Service Registry and Repository.

JKHLE company is using WebSphere Service Registry and Repository Studio to manage the company's WebSphere Service Registry and Repository configurations, so JKHLE must also load the Business Space configuration into Studio.

Creating a template from a space in Business Space

To create a template from an existing space, perform the following actions:

1. From Business Space, click Manage Spaces.
2. In the WSRR Business row, click Actions.
3. From the Actions menu, click Save as Template, as shown in Figure 31 on page 28.
Exporting the template in Business Space

To export a template from Business Space, perform the following actions:

1. From Business Space, click **Actions**.
2. Click **Manage Templates**, as shown in Figure 33.
3. From the Template Manager dialog box, in the WSRR Business row, click **Actions**.
4. Click **Export...**, as shown in Figure 34.

![Figure 34 The Business Space Template Manager actions menu](image)

5. Save the **template.zip** file to your local file system.
6. Click **Done**.

**Exporting the configuration in WSRR**

To export the WSRR Business Space Configuration, use the web UI. Log on to WebSphere Service Registry and Repository, select the **Configuration** perspective, and then perform the following steps:

1. Click **Active Profile → Business Space Configurations**.
2. In the Business Space Configurations collection, select **Business**. See Figure 35.
3. Click **Export**.

![Figure 35 Exporting the Business configuration](image)

4. Save the **Business.xml** file to your local file system.

**Note:** The format of WSRR Business Space Configuration items is not actually XML, but a highly compressed JSON format. They are not intended for local editing.

**Loading the configuration into Studio**

The JKHL Enterprises company is using WebSphere Service Registry and Repository Studio to manage its WebSphere Service Registry and Repository configuration. When Studio publishes a profile to WebSphere Service Registry and Repository, only the configuration files in the Studio profile are loaded into WebSphere Service Registry and Repository and activated. Any business space configuration files altered in WebSphere Service Registry and Repository are archived, or if Studio is publishing the currently active profile again, these files are removed.
Therefore, when the business space configuration is complete, the JKHLE company must load it into Studio, into the company's WebSphere Service Registry and Repository v7 configuration project.

To create a configuration project, perform the following steps in Studio:

1. Switch to the WSRR Configuration perspective by clicking **Window → Open Perspective → Other**.
2. In the Open Perspective dialog box, click **WSRR Configuration**.
3. Click **OK**.
4. Click **File → New → WSRR Configuration Project**.
   The Create a WSRR Configuration Project dialog box opens, as shown in Figure 36.

5. Click **Governance Enablement Profile - WSRR v7.0**.
6. In the Configuration Project name field, enter **JKHLE** .
7. Click **Finish**.

To import the business space configuration into the Studio project, perform the following steps from the WSRR Configuration perspective:

1. Switch to the Navigator view. If the Navigator view is not shown, click **Window → Show View → Other**, expand **General** and click **Navigator**, click **OK**.
2. Expand **JKHLE → Configuration Profile Files**.
3. If the BSPACE_CONFIG folder does not exist, you must create one by performing the following steps:
   a. Right-click **Configuration Profile Files** and select **New → Other**.
   b. In the New dialog box, expand **General** and click **Folder**. Click **Next**.
c. Ensure **Configuration Profile Files** is selected under the configuration project.
d. In the New Folder dialog box, enter BSPACE_CONFIG in the Folder name field.
e. Click **Finish**. The BSPACE_CONFIG folder is created below the Configuration Profile Files folder.

4. Right-click **BSPACE_CONFIG** and click **Import**.

5. In the Import dialog box, expand **General** and click **File System**.

6. Click **Next**.

7. In the From directory field, click **Browse**, as shown in Figure 37 to find the file:
   a. In the Import from directory dialog box, locate the directory on your file system where the Business.xml file is stored.
   b. Click **OK**.

![Image](image.png)

**Figure 37   Importing the Business.xml file into Studio**

8. Select the check box next to **Business.xml** file name.

9. Click **Finish**.

10. Switch to the WSRR Configuration Project Explorer.

11. In your configuration project, right-click **JKHLE** and click **Refresh**.

12. Expand **Configuration Profile Files** → **Business Space Configurations**. The Business configuration is listed, as shown in Figure 38 on page 32.
Using the sample templates and configuration in Business Space

The additional materials for this Redpaper contain sample templates and WebSphere Service Registry and Repository business space configurations. To access the materials, see “Additional material” on page 39.

About the sample template and configuration

The sample Business Space template is contained in the \Business_space directory. The WebSphere Service Registry and Repository business space configuration file is contained in the \WSRR_configuration directory.

The Business Space template has a WSRR Business Space Configuration name set to reference the correct business space configuration. Table 1 lists the correct name to use when loading the WebSphere Service Registry and Repository configuration item.

<table>
<thead>
<tr>
<th>Template file name</th>
<th>WSRR Configuration file name</th>
<th>WSRR Configuration name</th>
</tr>
</thead>
<tbody>
<tr>
<td>WSRR Business.zip</td>
<td>Business.xml</td>
<td>Business</td>
</tr>
</tbody>
</table>

The WebSphere Service Registry and Repository Business template is described in “Customizing Business Space scenario” on page 14. The template customizes the WebSphere Service Registry and Repository widgets to display non-technical terms and show business-oriented information about items in WebSphere Service Registry and Repository, suitable for a business analyst.
Loading the Business configuration into WebSphere Service Registry and Repository

You can load the WSRR Business Space Configuration by using the web UI. Log on to WebSphere Service Registry and Repository, select the Configuration perspective, and then perform the following steps:

1. Click Active Profile → Business Space Configurations.
2. In the Business Space Configurations collection, click Load Business Space Configuration.
3. Click Browse to locate the WSRR_Configuration directory. Select the Business.xml file.
4. In the Preparing to Load the Configuration item dialog box, enter Business in the Provide the Business Space Configurations configuration item name field.
5. Click OK.

WebSphere Service Registry and Repository confirms that the load succeeded, and the configuration is listed in the collection view, as shown in Figure 39.

![Figure 39 The Business configuration item loaded](image)

Loading the Business configuration into WebSphere Service Registry and Repository by using Studio

To load the WSRR Business Space Configuration using Studio, first create a Configuration Project. Follow the instructions in “Loading the configuration into Studio” on page 29 to create a project and load the Business.xml configuration file into Studio.

**Note:** At the time of writing, a problem prevented the business space configuration from being loaded into WebSphere Service Registry and Repository with the profile. For more information about this problem, and a forthcoming service fix, go to:

http://www.ibm.com/support/docview.wss?uid=swg1IZ83435

Studio can directly export a profile into WebSphere Service Registry and Repository.
To export a profile, first configure Studio to connect to WebSphere Service Registry and Repository, by performing the following steps from Studio:

1. Click **Window → Preferences**.
2. In the Preferences dialog box, click **WebSphere Service Registry and Repository (WSRR)**.
3. Click **Add**.
4. In the Add WSRR Location dialog box, enter **WSRR** in the Alias name field.
5. Specify the protocol, host, and port where the WebSphere Service Registry and Repository web UI is located.
6. If security is not enabled, skip this step and go to 7 on page 35.
   If security is enabled, perform the following steps:
   a. Select the **Security is enabled on WSRR Server** checkbox.
   b. Enter the user name and password in the User ID and Password fields.
   c. Click **Test Connection**. Studio connects to WebSphere Service Registry and Repository.
      Studio might prompt you to accept the WebSphere self-signed certificate, as shown in Figure 40. Click **Accept**.

![Signer certificate not found](image1)

**Figure 40** Studio prompt to accept the WebSphere self-signed certificate

Studio displays a success message if the test connection is successful (Figure 41).

![Test Connection](image2)

**Figure 41** Studio connection test successful message

d. Click **OK**. The completed page is shown in Figure 42 on page 35.
7. In the Add WSRR Location dialog box, click **Administrative Properties**.

8. In the SOAP Port field, enter the SOAP port on which the WebSphere server is running. To determine this information, perform the following steps:
   a. Log on to the WebSphere Administrative Console.
   b. Click **Servers** → **Server Types** → **WebSphere application servers**.
   c. Click **server1**, or the name of the WebSphere Service Registry and Repository server.
   d. On the Application server detail panel, expand **Ports**. The value of the Port Name SOAP_CONNECTOR_ADDRESS is the value to enter in the SOAP Port field in Studio. Figure 43 shows the SOAP port for our server is 8882.

   ![Figure 43](image)

   **Figure 43** The WebSphere Administration Console showing the server SOAP port

9. Enter the user name and password of a WebSphere administrator in the Administrator user ID and Administrator password fields. These credentials are the user name and password that you used to log on to the WebSphere Administrative Console. If the values are the same as the user name and password that you entered in the General Properties tab, select the **Use credentials specified in General Properties** check box.
10. Click **Test Administrative Connection**.

   Studio displays a success message if the test connection is successful (Figure 44).

   ![Test administrative connection](image1)

   **Figure 44**  Studio administrative connection test successful message

11. Click **OK**. The completed page is shown in Figure 45.

   ![Add WSRR location](image2)

   **Figure 45**  The completed Administrative Properties page

12. Click **Finish**.

   To export a profile directly to WebSphere Service Registry and Repository, perform the following steps in Studio from the WSRR Configuration perspective:

1. Click **JKHLE**.
2. Click **File → Export**.
3. In the Export dialog box, expand **WebSphere Service Registry and Repository (WSRR)** and click **WSRR Configuration Profile**.
4. Click **Next**.
5. On the Export WSRR Configuration Profile page (shown in Figure 46 on page 37), use the following settings:
   a. Ensure that **JKHLE** is selected in the Configuration Project field.
   b. Select **Target WSRR Server**.
   c. Select **WSRR** in the Target WSRR server field. This step selects the WebSphere Service Registry and Repository server to export to.
d. Select the **Activate Profile** check box so that the profile will be active after it is exported into WebSphere Service Registry and Repository.

![Export dialog box](https://example.com)

**Figure 46** The Export dialog box

6. Click **Finish**.

Studio exports the profile and loads it into WebSphere Service Registry and Repository. During this process, Studio displays various progress messages in the Export dialog box, as shown in Figure 47.

![Export progress messages](https://example.com)

**Figure 47** Export progress messages

When the export is complete, Studio closes the Export dialog box.

To verify that the profile is loaded and activated, perform the following steps:

1. Log on to the WebSphere Service Registry and Repository web UI,
2. Switch to the **Configuration** perspective and
3. Click **Manage Profiles** → **Configuration Profiles**. The JKHLE profile status is Active, as shown in Figure 48 on page 38.
Loading the Business template into Business Space

To load the Business Space template, log on to Business Space and perform the following steps:

1. From Business Space, click Actions.
2. Click Manage Templates.
3. From the Template Manager dialog box, click Import Template.
4. From the Import Template dialog box, click Browse to locate the business_space directory. Select WSRR Business.zip.
5. In the Import Template dialog box, click OK.
   The Template Manager dialog box refreshes and lists the imported WebSphere Service Registry and Repository Business template.
6. Click Done. The WebSphere Service Registry and Repository Business template can now be used to create spaces.

Creating a WebSphere Service Registry and Repository Business space

To create a space by using the WebSphere Service Registry and Repository Business space template in Business Space, perform the following steps:

1. Click Manage Spaces.
2. In the Space Manager dialog box, click Create Space.
3. In the Create Space dialog box (Figure 16 on page 15), provide the following information:
   a. Enter WSRR Business in the Space Name field.
   b. Select WSRR Business in the Create a new space using a template field.
4. Click Save.
   The created space is shown in the Space Manager dialog box.
5. Click WSRR Business to enter the space. The new space is set to use WSRR Business as the WSRR Business Space Configuration name.

The JKHLE Business Space style

The JKHL Enterprises style for Business Space is located in the Theme directory in the JKHLEStyle.zip file. To use the theme, see “Business Space theme for JKHLE” on page 26.

See the Business Space Information Center for information about how to load a style:
Additional material

This section refers to additional material that can be downloaded from the Internet:

- The material that is associated with this paper is available in softcopy on the Internet from the IBM Redbooks® web server at the following location:
  
  ftp://www.redbooks.ibm.com/redbooks/REDP4689

- Alternatively, you can go to the IBM Redbooks website:
  
  ibm.com/redbooks

  Select Additional materials → Access additional materials, and open the directory that corresponds with the IBM Redpaper form number, REDP4689.

The author who wrote this paper

This paper was produced at the International Technical Support Organization, Raleigh Center.

David Seager is a User Interface Developer for the WebSphere Service Registry and Repository development team based at the IBM Hursley Development Lab in the U.K. He has 13 years of experience in middleware development at IBM. David holds a Masters degree in Software Engineering from Oxford University and a Masters degree in Physics from Oxford University. His areas of expertise include WebSphere Application Server, AJAX, JavaScript, Java and web UI design. David contributed to the IBM Redbooks publication CICS Transaction Gateway V5 The WebSphere Connector for CICS, SG24-6133. David is an IBM developerWorks® contributing author and has written several IBM developerWorks articles in his areas of expertise.

Thanks to the following people for their contributions to this project:

David Bell
IBM U.K., WebSphere Service Registry and Repository - Integration Test Technical Lead

Michael Ellis
IBM Canada, Software Services for WebSphere

Ian Heritage
IBM U.K., Worldwide WebSphere Technical Sales Support & Competitive Analysis - SOA Governance

Laura Olson
IBM U.S.A., Product Manager - WebSphere Service Registry and Repository and Service Federation Management

Martin Smithson
IBM U.K., Architect - WebSphere Service Registry & Repository

Gary Thornton
IBM U.K., User Experience Architect, WebSphere Service Registry and Repository

Martin Keen
IBM U.S.A., Redbooks Project Leader
Now you can become a published author, too!

Here’s an opportunity to spotlight your skills, grow your career, and become a published author - all at the same time! Join an ITSO residency project and help write a book in your area of expertise, while honing your experience using leading-edge technologies. Your efforts will help to increase product acceptance and customer satisfaction, as you expand your network of technical contacts and relationships. Residencies run from two to six weeks in length, and you can participate either in person or as a remote resident working from your home base.

Find out more about the residency program, browse the residency index, and apply online at: ibm.com/redbooks/residencies.html

Stay connected to IBM Redbooks

► Find us on Facebook:
  http://www.facebook.com/IBMRedbooks
► Follow us on twitter:
  http://twitter.com/ibmredbooks
► Look for us on LinkedIn:
  http://www.linkedin.com/groups?home=&gid=2130806
► Explore new Redbooks publications, residencies, and workshops with the IBM Redbooks weekly newsletter:
► Stay current on recent Redbooks publications with RSS Feeds:
  http://www.redbooks.ibm.com/rss.html
Notices

This information was developed for products and services offered in the U.S.A.

IBM may not offer the products, services, or features discussed in this document in other countries. Consult your local IBM representative for information on the products and services currently available in your area. Any reference to an IBM product, program, or service is not intended to state or imply that only that IBM product, program, or service may be used. Any functionally equivalent product, program, or service that does not infringe any IBM intellectual property right may be used instead. However, it is the user's responsibility to evaluate and verify the operation of any non-IBM product, program, or service.

IBM may have patents or pending patent applications covering subject matter described in this document. The furnishing of this document does not give you any license to these patents. You can send license inquiries, in writing, to:
IBM Director of Licensing, IBM Corporation, North Castle Drive, Armonk, NY 10504-1785 U.S.A.

The following paragraph does not apply to the United Kingdom or any other country where such provisions are inconsistent with local law: INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES THIS PUBLICATION "AS IS" WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF NON-INFRINGEMENT, MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. Some states do not allow disclaimer of express or implied warranties in certain transactions, therefore, this statement may not apply to you.

This information could include technical inaccuracies or typographical errors. Changes are periodically made to the information herein; these changes will be incorporated in new editions of the publication. IBM may make improvements and/or changes in the product(s) and/or the program(s) described in this publication at any time without notice.

Any references in this information to non-IBM Web sites are provided for convenience only and do not in any manner serve as an endorsement of those Web sites. The materials at those Web sites are not part of the materials for this IBM product and use of those Web sites is at your own risk.

IBM may use or distribute any of the information you supply in any way it believes appropriate without incurring any obligation to you.

Information concerning non-IBM products was obtained from the suppliers of those products, their published announcements or other publicly available sources. IBM has not tested those products and cannot confirm the accuracy of performance, compatibility or any other claims related to non-IBM products. Questions on the capabilities of non-IBM products should be addressed to the suppliers of those products.

This information contains examples of data and reports used in daily business operations. To illustrate them as completely as possible, the examples include the names of individuals, companies, brands, and products. All of these names are fictitious and any similarity to the names and addresses used by an actual business enterprise is entirely coincidental.

COPYRIGHT LICENSE:

This information contains sample application programs in source language, which illustrate programming techniques on various operating platforms. You may copy, modify, and distribute these sample programs in any form without payment to IBM, for the purposes of developing, using, marketing or distributing application programs conforming to the application programming interface for the operating platform for which the sample programs are written. These examples have not been thoroughly tested under all conditions. IBM, therefore, cannot guarantee or imply reliability, serviceability, or function of these programs.