Implementing IBM Maximo for Service Providers

Learn best practices for implementing IBM Maximo for Service Providers

Experiment with real life scenarios

Understand the product components

ibm.com/redbooks
Implementing IBM Maximo for Service Providers

November 2010
Note: Before using this information and the product it supports, read the information in “Notices” on page xvii.

First Edition (November 2010)

This edition applies to IBM Maximo for Service Providers Version 7.1.

© Copyright International Business Machines Corporation 2010. All rights reserved.
Note to U.S. Government Users Restricted Rights -- Use, duplication or disclosure restricted by GSA ADP Schedule Contract with IBM Corp.
Contents

Figures .............................................................. vii
Tables ............................................................... xv
Notices .............................................................. xvii
Trademarks .......................................................... xviii
Preface ............................................................... xix
The team who wrote this book ...................................... xix
Now you can become a published author, too! ....................... xxii
Comments welcome ................................................ xxii
Stay connected to IBM Redbooks ................................... xxiii

Part 1. Introduction ................................................... 1

Chapter 1. IBM Maximo for Service Providers overview ............... 3
  1.1 Product overview ............................................... 4
  1.2 Key benefits ...................................................... 4
  1.3 Applications in IBM Maximo for Service Providers ............... 5
  1.4 Challenges and business drivers that the product addresses ........ 8
  1.5 Target organizations and audiences ................................ 8

Chapter 2. Architecture and components ............................ 9
  2.1 Architecture ...................................................... 10
  2.2 Components ...................................................... 12
    2.2.1 New applications ........................................... 13
    2.2.2 Extended applications .................................... 20
    2.2.3 Rewritten application ..................................... 23

Chapter 3. Initial configuration ..................................... 25
  3.1 Organization (SP) .............................................. 26
  3.2 Customer (SP) .................................................. 29
    3.2.1 Creating customers and associating person to new customer .... 29
  3.3 Customer Objects (SP) ......................................... 32
  3.4 Security Groups (SP) .......................................... 34
  3.5 Domains (SP) ................................................... 36
  3.6 Locations (SP) .................................................. 39
    3.6.1 Creating a location and associating it with a customer ........ 40
  3.7 Service Address (SP) .......................................... 41
    3.7.1 Creating a service address associated with a customer location ... 42
3.8 Assets (SP) application .................................................. 44
  3.8.1 Assets tab ............................................................. 45
  3.8.2 Specifications tab ................................................. 47
3.9 Configuration Item ....................................................... 48
  3.9.1 Configuration Item tab ............................................. 48
3.10 Associating classifications and customers ....................... 49
3.11 Associating CI with a classification ............................... 53
3.12 Associating service items and customers ....................... 54
3.13 Service level agreement ............................................ 55
  3.13.1 Conditions tab ..................................................... 58
3.14 Creating customer agreements ..................................... 59
  3.14.1 Pricing rules ....................................................... 62
3.15 Creating a response plan ........................................... 66
3.16 Creating and configuring escalations ............................ 70
3.17 Bulletin Board (SP) .................................................... 72

Part 2. Use cases and scenarios ........................................... 75

Chapter 4. Service Desk scenario ......................................... 77
  4.1 Business requirements .............................................. 78
  4.2 Applications involved .............................................. 79
  4.3 Scenario benefits ................................................... 79
  4.4 Implementation ...................................................... 79
    4.4.1 Implementation steps ......................................... 80
    4.4.2 Pre-configuration .............................................. 81
    4.4.3 Service Desk process .......................................... 89

Chapter 5. Assets and locations scenario ............................. 99
  5.1 Business requirements .............................................. 100
  5.2 Applications involved .............................................. 100
  5.3 Implementation ..................................................... 100
    5.3.1 Implementation steps ......................................... 100
    5.3.2 Pre-configuration .............................................. 101
    5.3.3 Setting up a location ......................................... 101
    5.3.4 Moving the assets ............................................. 102

Chapter 6. Billing scenario .................................................. 107
  6.1 Business requirement ................................................ 108
  6.2 Applications involved in this scenario .......................... 109
  6.3 Step-by-step implementation ...................................... 110
    6.3.1 Creating a customer ........................................... 110
    6.3.2 Creating a customer agreement with a price schedule .... 110
    6.3.3 Creating a response plan ..................................... 115
    6.3.4 Creating a service request ................................... 116
6.3.5 Creating a customer billing .................................................. 119

Chapter 7. Customer agreement scenario ...................................... 123
7.1 Business requirements .......................................................... 124
7.2 Applications involved ............................................................. 124
7.3 Step-by-step implementation. .................................................. 124
  7.3.1 Creating a customer agreement with price schedules ............ 124
  7.3.2 Creating the work order for non-emergency repairs .............. 129
  7.3.3 Creating the work order for emergency repairs ..................... 133
  7.3.4 Creating the customer billing and bill review ....................... 134

Chapter 8. Migration Manager scenario ....................................... 137
8.1 Business requirements .......................................................... 138
8.2 Applications involved ........................................................... 138
8.3 Introduction ........................................................................ 138
8.4 Benefits ............................................................................. 139
8.5 Migration Manager components for IBM Maximo for Service Providers 140
  8.5.1 Migration Manager .......................................................... 140
  8.5.2 Migration Groups. ........................................................... 141
  8.5.3 Object structures ............................................................. 141
8.6 Step-by-step implementation. .................................................. 145
  8.6.1 Prerequisites .................................................................. 145
  8.6.2 Working in the source environment ................................... 145
  8.6.3 Working in the target environment ................................... 153

Chapter 9. Preventive maintenance scenario ................................ 157
9.1 Business requirements ........................................................... 158
9.2 Applications involved ............................................................. 158
9.3 Implementation .................................................................... 158
  9.3.1 Implementation steps ....................................................... 158
  9.3.2 Pre-configuration ............................................................ 159
9.4 The work order process .......................................................... 166

Chapter 10. Security groups scenario ........................................ 173
10.1 Business requirements .......................................................... 174
10.2 Applications involved ........................................................... 175
10.3 Step-by-step implementation. .................................................. 175
  10.3.1 Authorizing groups for customers on user’s person record .... 175
  10.3.2 Authorizing groups for customers in the user’s person customer access list ....................................................... 180
  10.3.3 The Authorizing Groups for Customers listed below option .... 185
  10.3.4 Authorizing groups for unrestricted customer level information 189
  10.3.5 Authorizing the group for all customer information ............. 192
### Chapter 11. Service level agreement (SLA) time zone scenario

11.1 Business requirements .................................................... 196  
11.2 Applications involved .................................................... 196  
11.3 Benefits ...................................................................... 197  
11.4 Implementation .............................................................. 197  
  11.4.1 Implementation steps ................................................. 197  
  11.4.2 Pre-configuration ...................................................... 198  
  11.4.3 Applying SLA to a non severity-1 service request ............. 203

### Chapter 12. Pricing scenario

12.1 Business needs ............................................................... 212  
12.2 Use case ...................................................................... 213  
12.3 Implementation of pricing rules ........................................... 213

### Chapter 13. Service Desk tickets and solutions restricted by Service Provider customers scenario

13.1 Business requirement .......................................................... 236  
13.2 Integrating IBM Tivoli Service Request Manager with IBM Maximo for Service Providers .............................................................. 236  
  13.2.1 Scenario and products involved in the integration .......... 236  
  13.2.2 Benefits of this integration .......................................... 236  
  13.2.3 Installing IBM Maximo for Service Providers on top of IBM Tivoli Service Request Manager ........................................ 237  
13.3 Step-by-step implementation ............................................. 238  
  13.3.1 Initial customization for this scenario ......................... 238  
  13.3.2 Operating the system .................................................. 248

### Related publications

IBM Redbooks ................................................................. 257  
Online resources ............................................................... 257  
How to get Redbooks .......................................................... 258  
Help from IBM ................................................................. 258

### Index ................................................................. 259
Figures

2-1 Customer application main tab ...................................................... 13
2-2 Customer Agreement application main tab ...................................... 14
2-3 Price Schedules tab in Customer Agreement application .................. 15
2-4 Service Address application main tab ............................................. 16
2-5 Customer Billing application main tab ............................................. 17
2-6 Bill Review application main tab ................................................... 17
2-7 Sales Order application main tab ................................................... 18
2-8 Response Plan application main tab ................................................. 19
2-9 Customer Objects application ....................................................... 20
2-10 SLA application main tab ........................................................... 24
3-1 Work Order Options, Edit Rules ...................................................... 26
3-2 SLA Options ................................................................................. 27
3-3 Service Options .............................................................................. 28
3-4 Billing Options .............................................................................. 28
3-5 Customers (SP) ............................................................................... 30
3-6 Change Status ............................................................................... 31
3-7 People (SP) application ................................................................. 32
3-8 Create Default Conditions ............................................................... 33
3-9 SR objects (part of the window is cut for readability) ......................... 33
3-10 System Message ............................................................................ 34
3-11 Security Groups (SP) application .................................................. 34
3-12 New tab, Customers ....................................................................... 35
3-13 Security Groups (SP) application: options ...................................... 35
3-14 Individual Customer Authorization ................................................ 36
3-15 Domains (SP) ................................................................................. 37
3-16 Customer REDBOOKCUS_A .......................................................... 37
3-17 Customer REDBOOKCUS_B .......................................................... 38
3-18 Work order for REDBOOKCUS_A .................................................. 38
3-19 Work order for customer REDBOOKCUS_B .................................... 39
3-20 Locations (SP) application: 1 ......................................................... 40
3-21 Locations (SP) application: 2 ......................................................... 40
3-22 Associate system with location ...................................................... 41
3-23 New service address ...................................................................... 43
3-24 Set the value for Service Address field to 6 .................................... 43
3-25 Service Address tab ...................................................................... 44
3-26 Assets application ......................................................................... 45
3-27 Customer associations ................................................................... 46
3-28 Customer associations ................................................................... 46
option .......................................................... 181
10-11 Associating customer to a person's record ................. 182
10-12 Security Groups Users tab ................................ 182
10-13 Adding users to a given security group ...................... 182
10-14 Customer field in the Customer table ....................... 183
10-15 Customer Agreements CA03 and CA04 are successfully retrieved ..... 184
10-16 Error message informing user record cannot be found ....... 184
10-17 Authorize Group for customers listed below option in the Security Group application .................................................. 185
10-18 Security Groups (SP) ......................................... 185
10-19 Security Groups (SP) ......................................... 186
10-20 Adding customers to the security group's Individual Customer Authorization table .................................................. 186
10-21 Associating customers with the location ...................... 186
10-22 Associating an asset to a location and to a customer: before saving the record enter a Location ........................................ 187
10-23 Only assets associated with the customers are shown ......... 188
10-24 USER04 cannot to see those assets .......................... 189
10-25 Authorize Group only for unrestricted Customer level information .......................................................... 190
10-26 Users tab in the Security Group application ................. 190
10-27 Associating users to the security group ....................... 190
10-28 Work Order Tracking main tab and Customer field .......... 191
10-29 Record cannot be found message ............................ 192
10-30 Authorize Group for all Customers information option ........ 192
11-1 Organization SLA Options configuration ...................... 198
11-2 Non severity 1 SLA Selection of Calculation Calendar section ........ 201
11-3 Condition Tab, SLA Criteria section of the SLA .............. 203
11-4 Service Request Reported By ................................ 203
11-5 Service Request Affected Person ............................. 204
11-6 Service request asset, location, and customer ............... 204
11-7 Target dates after applying SLA for calendar and shift ....... 204
11-8 Person with 09X06-D shift applied ........................... 205
11-9 Re-apply SLA system message ............................... 205
11-10 Target dates after applying SLA for calendar CALRB01 and shift 09X06-D ...................................................... 206
11-11 Person without a calendar and shift associated to it .......... 206
11-12 Target dates after applying SLA for calendar CALRB01 and shift 12X05-D ...................................................... 207
11-13 Asset without calendar and shift applied ..................... 207
11-14 Target dates after applying SLA for calendar CALRB01 and shift 12X05-N ...................................................... 208
11-15 SRRB01 with a 1 Internal Priority ............................ 208
11-16 SLARB02 Applied to SRRB01 ............................... 208
<table>
<thead>
<tr>
<th>Section</th>
<th>Title</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>11-17</td>
<td>Target dates after applying SLA for a severity 1 issue</td>
<td>209</td>
</tr>
<tr>
<td>12-1</td>
<td>Meters</td>
<td>214</td>
</tr>
<tr>
<td>12-2</td>
<td>Locations</td>
<td>215</td>
</tr>
<tr>
<td>12-3</td>
<td>Assets (SP)</td>
<td>215</td>
</tr>
<tr>
<td>12-4</td>
<td>Asset Meters</td>
<td>216</td>
</tr>
<tr>
<td>12-5</td>
<td>Classifications List</td>
<td>217</td>
</tr>
<tr>
<td>12-6</td>
<td>IT Issue Classification</td>
<td>218</td>
</tr>
<tr>
<td>12-7</td>
<td>Use With PLUSPGBTRANS</td>
<td>218</td>
</tr>
<tr>
<td>12-8</td>
<td>Use With PLUSPSALESORDER</td>
<td>219</td>
</tr>
<tr>
<td>12-9</td>
<td>Customer agreement</td>
<td>220</td>
</tr>
<tr>
<td>12-10</td>
<td>Revise Agreement</td>
<td>220</td>
</tr>
<tr>
<td>12-11</td>
<td>Revise Agreement Dialog</td>
<td>221</td>
</tr>
<tr>
<td>12-12</td>
<td>Price Schedules Tab</td>
<td>221</td>
</tr>
<tr>
<td>12-13</td>
<td>Price Schedules</td>
<td>222</td>
</tr>
<tr>
<td>12-14</td>
<td>Classify</td>
<td>222</td>
</tr>
<tr>
<td>12-15</td>
<td>Classification</td>
<td>223</td>
</tr>
<tr>
<td>12-16</td>
<td>Assets Under Management 1 to 60 assets</td>
<td>223</td>
</tr>
<tr>
<td>12-17</td>
<td>Assets Under Management 61 to 120 assets</td>
<td>224</td>
</tr>
<tr>
<td>12-18</td>
<td>Price Schedule S2</td>
<td>224</td>
</tr>
<tr>
<td>12-19</td>
<td>IT Issue \ Hardware Issue \ Printer Hardware Issue</td>
<td>225</td>
</tr>
<tr>
<td>12-20</td>
<td>IT \ Computer Equipment \ Printer</td>
<td>225</td>
</tr>
<tr>
<td>12-21</td>
<td>Printer Unit Price</td>
<td>226</td>
</tr>
<tr>
<td>12-22</td>
<td>Classify</td>
<td>227</td>
</tr>
<tr>
<td>12-23</td>
<td>Printouts</td>
<td>228</td>
</tr>
<tr>
<td>12-24</td>
<td>Sales Orders (SP)</td>
<td>229</td>
</tr>
<tr>
<td>12-25</td>
<td>Apply customer agreement</td>
<td>230</td>
</tr>
<tr>
<td>12-26</td>
<td>System Message</td>
<td>230</td>
</tr>
<tr>
<td>12-27</td>
<td>Fees and Charges</td>
<td>231</td>
</tr>
<tr>
<td>12-28</td>
<td>Fees and Charges</td>
<td>232</td>
</tr>
<tr>
<td>12-29</td>
<td>Select / Deselect Price Schedule</td>
<td>232</td>
</tr>
<tr>
<td>12-30</td>
<td>Select / Deselect Price Schedule</td>
<td>233</td>
</tr>
<tr>
<td>13-1</td>
<td>Installation folder</td>
<td>237</td>
</tr>
<tr>
<td>13-2</td>
<td>Installing IBM Maximo for Service Providers from the Tivoli Service</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Request Manager installer</td>
<td></td>
</tr>
<tr>
<td>13-3</td>
<td>Install Service Provider Common Components for Service Request Manager</td>
<td></td>
</tr>
<tr>
<td>13-4</td>
<td>Install Service Provider Support for Service Request Manager</td>
<td></td>
</tr>
<tr>
<td>13-5</td>
<td>The list with 42 objects</td>
<td>239</td>
</tr>
<tr>
<td>13-6</td>
<td>Activate the customer</td>
<td>240</td>
</tr>
<tr>
<td>13-7</td>
<td>On the tab list you can easily see both customers</td>
<td>240</td>
</tr>
<tr>
<td>13-8</td>
<td>Authorize Group for customers on User's Person record</td>
<td>241</td>
</tr>
<tr>
<td>13-9</td>
<td>Solution</td>
<td>241</td>
</tr>
<tr>
<td>13-10</td>
<td>Grant Listed Application button</td>
<td>242</td>
</tr>
</tbody>
</table>
13-11 For all 3 applications the options available will be granted access for that security group .......................................................... 242
13-12 Grant Listed Options .............................................................. 243
13-13 Authorize Group for customers option .................................... 243
13-14 Activate the user ................................................................. 244
13-15 People(SP) application ........................................................ 245
13-16 Users (SP) application ........................................................ 245
13-17 Associate a customer to a user .............................................. 246
13-18 Create a support user that will have access to the two customers ... 247
13-19 Setting time and active the cron task ...................................... 248
13-20 Cron task ........................................................................... 248
13-21 New Incident for CustomerSDA ............................................ 249
13-22 New Incident for CustomerSDB ............................................ 250
13-23 Solution active for CustomerSDB ........................................ 251
13-24 Solution applied to IncidentB .............................................. 251
13-25 Only IncidentA was found .................................................... 252
13-26 Only the Incident for CustomerSDB was found ...................... 253
13-27 This user can see the Solution .............................................. 254
13-28 No rows to display .............................................................. 255
13-29 Global Search .................................................................... 256
13-30 This user can see the Solution for Customer SDB .................. 256
Tables

3-1 New customer .................................................. 30
3-2 New location .................................................... 41
3-3 New service address ......................................... 42
4-1 Basic Configuration ........................................... 81
4-2 Predefined automatic notifications for the Service Request application . 88
8-1 The DMPLUSPSLA related objects .......................... 142
8-2 The DMPLUSPRP related objects ........................... 143
9-1 Basic configuration ............................................ 159
9-2 Job plan information ......................................... 160
9-3 Job plan tasks ................................................. 160
9-4 Crafts information ............................................ 160
9-5 Preventive maintenance information ....................... 162
9-6 Service Level Agreements .................................. 163
9-7 Customer agreement ......................................... 165
9-8 Price schedules .............................................. 165
9-9 Pricing rules .................................................. 165
10-1 Data restrictions .............................................. 174
11-1 Calendar configuration ..................................... 199
11-2 Shift configuration ........................................... 199
11-3 Shift patterns ................................................ 199
11-4 Person configuration ........................................ 200
11-5 Location configuration ..................................... 200
11-6 Asset configuration .......................................... 200
11-7 Non severity-1 SLA configuration: Part 1 ............... 201
11-8 Non severity 1 SLA configuration: Part 2 ............... 201
11-9 SLA commitments configuration .......................... 201
11-10 Non severity-1 issue SLA Calendar choice ............... 201
11-11 Severity 1 SLA configuration: Part 1 ..................... 202
11-12 Severity-1 SLA configuration: Part 2 ..................... 202
11-13 SLA Commitments configuration ........................ 202
11-14 SLA Criteria configuration ................................ 202
11-15 Service Request ............................................ 203
12-1 Total number of assets ..................................... 212
12-2 Price schedule for laser printer maintenance .......... 213
12-3 Price schedules ............................................. 219
Notices

This information was developed for products and services offered in the U.S.A.

IBM may not offer the products, services, or features discussed in this document in other countries. Consult your local IBM representative for information on the products and services currently available in your area. Any reference to an IBM product, program, or service is not intended to state or imply that only that IBM product, program, or service may be used. Any functionally equivalent product, program, or service that does not infringe any IBM intellectual property right may be used instead. However, it is the user's responsibility to evaluate and verify the operation of any non-IBM product, program, or service.

IBM may have patents or pending patent applications covering subject matter described in this document. The furnishing of this document does not give you any license to these patents. You can send license inquiries, in writing, to:
IBM Director of Licensing, IBM Corporation, North Castle Drive, Armonk, NY 10504-1785 U.S.A.

The following paragraph does not apply to the United Kingdom or any other country where such provisions are inconsistent with local law:
INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES THIS PUBLICATION "AS IS" WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF NON-INFRINGEMENT, MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. Some states do not allow disclaimer of express or implied warranties in certain transactions, therefore, this statement may not apply to you.

This information could include technical inaccuracies or typographical errors. Changes are periodically made to the information herein; these changes will be incorporated in new editions of the publication. IBM may make improvements and/or changes in the product(s) and/or the program(s) described in this publication at any time without notice.

Any references in this information to non-IBM Web sites are provided for convenience only and do not in any manner serve as an endorsement of those Web sites. The materials at those Web sites are not part of the materials for this IBM product and use of those Web sites is at your own risk.

IBM may use or distribute any of the information you supply in any way it believes appropriate without incurring any obligation to you.

Information concerning non-IBM products was obtained from the suppliers of those products, their published announcements or other publicly available sources. IBM has not tested those products and cannot confirm the accuracy of performance, compatibility or any other claims related to non-IBM products. Questions on the capabilities of non-IBM products should be addressed to the suppliers of those products.

This information contains examples of data and reports used in daily business operations. To illustrate them as completely as possible, the examples include the names of individuals, companies, brands, and products. All of these names are fictitious and any similarity to the names and addresses used by an actual business enterprise is entirely coincidental.

COPYRIGHT LICENSE:

This information contains sample application programs in source language, which illustrate programming techniques on various operating platforms. You may copy, modify, and distribute these sample programs in any form without payment to IBM, for the purposes of developing, using, marketing or distributing application programs conforming to the application programming interface for the operating platform for which the sample programs are written. These examples have not been thoroughly tested under all conditions. IBM, therefore, cannot guarantee or imply reliability, serviceability, or function of these programs.
Trademarks

IBM, the IBM logo, and ibm.com are trademarks or registered trademarks of International Business Machines Corporation in the United States, other countries, or both. These and other IBM trademarked terms are marked on their first occurrence in this information with the appropriate symbol (® or ™), indicating US registered or common law trademarks owned by IBM at the time this information was published. Such trademarks may also be registered or common law trademarks in other countries. A current list of IBM trademarks is available on the Web at http://www.ibm.com/legal/copytrade.shtml

The following terms are trademarks of the International Business Machines Corporation in the United States, other countries, or both:

- AIX®
- DB2®
- IBM®
- Maximo®
- Redbooks®
- Redpaper™
- Redbooks (logo) (®)
- Service Request Manager®
- Tivoli®
- WebSphere®

The following terms are trademarks of other companies:

ITIL is a registered trademark, and a registered community trademark of the Office of Government Commerce, and is registered in the U.S. Patent and Trademark Office.

Java, and all Java-based trademarks are trademarks of Sun Microsystems, Inc. in the United States, other countries, or both.

Microsoft, and the Windows logo are trademarks of Microsoft Corporation in the United States, other countries, or both.

Other company, product, or service names may be trademarks or service marks of others.
Preface

The IBM® Maximo® for Service Providers product is designed to support Service as a business. It helps lower total cost-of-ownership and increase profitability and customer satisfaction by managing clients’ assets either through third-party outsourcing or internally shared services model.

This IBM Redbooks® publication introduces IBM Maximo for Service Providers product and its components. We took a practical approach in this book, and presented the features and functions of the IBM Maximo for Service Providers product in the context of a number of real-life scenarios or usage patterns. These scenarios are commonly used at IBM customer sites to satisfy specific business requirements. For each scenario, we establish the business reason, benefits, and how to implement the scenario. There is also a section on initial product configuration that touches on several configuration points, such as creating the customers, security groups, and response plans.

This book is a reference guide for IT Specialists and IT Architects implementing IBM Maximo for Service Providers.

The team who wrote this book

This book was produced by a team of specialists from around the world:

**Bo Batty** is the Product Architect for the IBM Maximo for Service Providers and has many years of experience with the product. Bo works for the IBM Tivoli® Software Group and works out of Bedford, MA.

**Dashiel Lucena Gonzaga Borges** is a Quality Software Engineer working for IBM Brazil with IBM MAXIMO Transportation. He has a degree in Technology in Precision Mechanic. Dashiel has extensive experience on IBM Maximo Transportation and IBM Maximo for Service Providers products.

**Bruno Nogueira Costa** is a Staff Software Engineer in the Tivoli Group. He has been with IBM Brazil for six years. He works on integration tests for the Tivoli Service Request Manager product. Previously he worked on Tivoli Enterprise Asset Management Solutions. He graduated from UNESP/Fatec-SP in Data Processing and has a postgraduate degree in Software Engineering.
Juan Faustino has an Electronics and Telecommunication Engineer degree from PUC-MG. He has more than two years of experience with IBM Service Management Portfolio, specifically Tivoli Service Request Management, Tivoli Asset Management for IT, CCMDB, and Service Provider modules. His professional experience is concentrated on integrating these modules at customer sites. He works for Global Dominion, an IBM Business Partner, that offers sectorial solutions (health, education, and environment) and outsourcing.

Alfredo Anselmo Oliveira Ferreira is a Tivoli Maximo Specialist for the IBM Brazil IT Delivery department. He currently studies Computer Science at Mackenzie University in Sao Paulo and has experience with IBM Service Management, IBM Maximo for Service Providers, AIX®, WebSphere®, Application Server, and DB2®.

Hilton Bertelli Ferreira Filho is a Staff Software Engineer and team lead of the Service Provider Developer Team. He has over six years of experience in Java™ Enterprise development and over three years working on IBM Maximo Asset Management development at the IBM Brazil Software Laboratory. He has worked in IBM Maximo for Services Providers for V6.1.2 and all V7.x releases. He also worked for the Oil, Gas, and Nuclear industry solutions. He has a Bachelor degree in Computer Science from UNICAMP.

Dirceu Semighini Filho graduated in MPCE at UNESP/FATEC-SP and also has a Master of Science degree from the Escola Politécnica at the University of São Paulo. He is a Software Developer in the IBM Brazil Software Laboratory. He has over six years of experience in developing software with Java and over three years of developing Maximo add ons. He was involved in the development of Maximo for Service Providers, Mobile, Oil and Gas, Utilities, and Transportation.

Vasfi Gucer is a Project Leader at the International Technical Support Organization, Austin Center. He has been with the ITSO since January 1999. He has more than 12 years of experience in systems management, networking hardware, and software on mainframe and distributed platforms. He worked on various Tivoli client projects as a Systems Architect in the United States (US). He writes extensively and teaches IBM classes world wide on Tivoli software. Vasfi is also an IBM Certified Senior IT Specialist, Project Management Professional (PMP), and ITIL® Expert.

Murat Kipel is an IT Specialist at IBM Global Services in Istanbul, Turkey. He has worked with IBM since 2005. His areas of expertise are IBM Tivoli Service management products, including CCMDB, Tivoli Service Request Manager®, Tivoli Service Request Manager®, Maximo for Service Providers, and TADDM. He is an IBM Certified Deployment Professional for Tivoli Application Dependency and Discovery Manager V7.1 and an IBM Certified Deployment Professional for Tivoli Change and Configuration Management Database V7.1.1.
**Zaid El Labadi** is a functional and technical Consultant working for the Createch Group in Canada. He has a BSC in Computer Science. Zaid has over six years of experience with IBM Service Management products, such as Maximo for Asset Management and IBM Tivoli Service Request Manager. He is also a Certified IBM Trainer.

**Evelyn Tanigawa Murasaki** has a Bachelor's degree in Information Systems from Mackenzie University in Sao Paulo and a Masters degree in Software Engineering from Universidade de Sao Paulo. She has worked as a Quality Assurance Software Engineer for seven years and is Certified as a Software Tester by QAI. She spent the last four years working in the Brazil Software Lab on Tivoli brand for IBM Maximo for Service Providers product.

**Johnny Kubithegts Pedrozo** is an IT Specialist working for IBM Brazil. He has two years of experience working with IBM Tivoli Maximo, has a Bachelor Degree in Analyze and Develop Systems by Faculdade de Informática e Administração Paulista and Certifications in IBM Tivoli Maximo.

**Viviane Stelina Almeida Silva** is a Staff Software Engineer at IBM working as a Quality Assurance Team Lead to IBM Maximo for Transportation, which is a position she has held for the last three years. She worked on several projects for IBM Tivoli Maximo, such as Service Provider, Utilities, Calibration, Spatial, and Upgrade. Viviane also has 10 years of experience with IT and a Bachelor degree in Computer Sciences from the Catholic University of Santos.

**Matheus Massaru Carvalho da Silveira** works in the Brazil Lab Information Management Team as an SVT Manager. He has a Bachelors degree in Computer Science at PUC-SP and has a Masters degree in Project Management PMI Best Practices from SENAC-SP. His experience includes Maximo for Enterprise asset Manager, IBM Maximo for asset Configuration Management, IBM Maximo for Transportation, Maximo for Service Provider, IBM Maximo for Nuclear Power Utilities, and IBM Maximo for Life Sciences.

**Peterson Domingos Tamarindo** is a Tivoli Maximo Specialist working for IBM Brazil. He has a degree in Computer Science and has experience on IBM Service Management products and IBM Maximo for Service Providers.

Thanks to the following people for their contributions to this project:

Tamikia Barrow, Emma Jacobs, Leslie Parham, Wade Wallace, and KaTrina Love-Abram
International Technical Support Organization

Danilo Rezende de Araujo, Keith Kellett, Julio Cesar de Ramos Madeira, Diego Duarte Moreira, Patricia Regina dos Santos e Silva, Cristina Zabeu
IBM Brazil
Now you can become a published author, too!

Here's an opportunity to spotlight your skills, grow your career, and become a published author - all at the same time! Join an ITSO residency project and help write a book in your area of expertise, while honing your experience using leading-edge technologies. Your efforts will help to increase product acceptance and customer satisfaction, as you expand your network of technical contacts and relationships. Residencies run from two to six weeks in length, and you can participate either in person or as a remote resident working from your home base.

Find out more about the residency program, browse the residency index, and apply online at:

ibm.com/redbooks/residencies.html

Comments welcome

Your comments are important to us!

We want our books to be as helpful as possible. Send us your comments about this book or other IBM Redbooks publications in one of the following ways:

▶ Use the online Contact us review Redbooks form found at:

ibm.com/redbooks

▶ Send your comments in an email to:

redbooks@us.ibm.com

▶ Mail your comments to:

IBM Corporation, International Technical Support Organization
Dept. HYTD Mail Station P099
2455 South Road
Poughkeepsie, NY 12601-5400
Stay connected to IBM Redbooks

➤ Find us on Facebook:
  http://www.facebook.com/IBMRedbooks

➤ Follow us on Twitter:
  http://twitter.com/ibmredbooks

➤ Look for us on LinkedIn:
  http://www.linkedin.com/groups?home=&gid=2130806

➤ Explore new Redbooks publications, residencies, and workshops with the IBM Redbooks weekly newsletter:

➤ Stay current on recent Redbooks publications with RSS Feeds:
  http://www.redbooks.ibm.com/rss.html
Part 1

Introduction

In this part, we introduce the IBM Maximo for Service Providers product and describe the product components.
IBM Maximo for Service Providers overview

In this chapter, we provide a description and overview of IBM Maximo for Service Providers.

The topics that we discuss in this chapter are:

- 1.1, “Product overview” on page 4
- 1.2, “Key benefits” on page 4
- 1.3, “Applications in IBM Maximo for Service Providers” on page 5
- 1.4, “Challenges and business drivers that the product addresses” on page 8
- 1.5, “Target organizations and audiences” on page 8
1.1 Product overview

IBM Maximo for Service Providers (or Maximo for Service Providers) meets the needs of clients who manage assets and services for their customers as a business or clients who manage assets and services within an enterprise and charge internally for these services.

Maximo for Service Providers supports the business model of an outsourcer that manages the assets of its customers (Customers can be external or divisions within an enterprise) and provides maintenance services for those assets. Using Maximo for Service Providers the Service Provider can manage customer agreements. These agreements specify the services that are provided to each customer, the price charged for managing these assets, and for the individual maintenance activities performed for the customer. As maintenance activities are recorded, prices are calculated based on the pricing rules of the customer agreement. At the end of the billing period, the Service Provider collects all of the billing transactions. The charges include charges that were calculated for discrete maintenance activities, charges for asset management based on the number and type of assets under management or the usage of assets, and any retainer fees and miscellaneous fees. The charges are placed in a batch for review. The individual transactions can be adjusted at this point. At the completion of the review process, Maximo for Service Providers sends the transactions to the Service Provider’s accounting system.

1.2 Key benefits

The key benefits that Maximo for Service Providers offers are:

► Reduction of overhead costs:
  – Improve efficiency of operations
  – Replace redundant, repetitive tasks with automated response plans
  – Add new customers easily without the additional overhead of installing another application instance

► Increased revenue through accurate pricing

► Key performance indicator (KPI) reporting on service management

► Improved cash flow by providing timely and accurate billing

► Customer pre-approval of the billing of completed work
Easy to configure and upgrade from release-to-release:

- Configure the user interface (UI), workflows, reports, KPIs, and dashboards dynamically
- Create new applications with drag-and-drop actions through built-in configuration tools
- Make changes through the built-in configuration tools upgrade
- Use the web interface immediately after upgrade

1.3 Applications in IBM Maximo for Service Providers

In this section, we present every major application that is included in IBM Maximo for Service Providers up to Version 7.1.1.2:

- Customer Management: Because customers are associated with locations, when a ticket or work order is created, the location that is entered on the ticket, sales order, or work order associates the customer with that ticket, sales order, or work order.

Customer Agreement: The customer agreement contains the customer billing address, the customer business address, the general terms and conditions of the agreement, which includes the start date, expiration date, billing frequency, and so forth. Customer agreements also contain the agreement price schedules, which contain the billing rules that are used to calculate prices on work orders, tickets, or sales orders. Customer agreements are revisable objects. After an agreement is approved, you cannot change. However, you can create a revision of the agreement. After the revision is approved, the approved revision replaces the prior revision.

Agreement Price Schedule: A customer agreement can contain any number of agreement price schedules, each of which contains a unique set of price calculation rules. Prices in IBM Maximo for Service Providers can be calculated as a markup of a cost, or a price can be selected based on an attribute on the work order, ticket, or sales order that is independent of the cost. Price schedules are part of a customer agreement. They contain a set of pricing rules, and they contain a set of conditions that specify when and under what conditions the price schedules are used, for example, a price schedule can specify that labor can be priced as a 20% mark up of the labor cost. Alternatively, a price schedule might state that class C application servers that are running critical applications are priced as $735 a month.

Service Address: The Service Address specifies the address where the work will be performed or where Material will be delivered. Service Addresses are associated with locations (or are inherited from an ancestor location). Similar to a customer, when a location is associated with a ticket, sales order, or work
Implementing IBM Maximo for Service Providers

- Customer Billing: The Billing application provides batch control functionality. A billing batch is created for each customer agreement according to the billing frequency that is specified in the Agreement. The batch consists of all of the work orders, Tickets, and sales orders that were completed during the billing period, as well as un-billed transactions from prior billing periods. The Billing application is used by a Service Provider to review, and to adjust, if necessary, any transactions in the batch. After the Service Provider reviews the batch contents, they can choose to allow their customers to review the batch before the batch is sent to the Service Provider's accounting system for invoicing. There is a separate application (Bill Review) that is intended to provide a secure and less detailed view of the batch for the customers' view.

- Billing Review: This application is used by the Service Provider's customers to review the work orders, tickets, and sales orders that are included in the batch. This view shows less detail to the customers than what is available to the Service Providers, for example, it shows the prices but not the costs of the Service Provider. If the customer has questions on any of these work items, they can be discussed with the Service Provider and answered prior to the bills being finalized.

- Sales Order: The Sales Order is used to create general pricing transactions that are not related to work completed or to specific costs transactions. Common uses include the billing of monthly maintenance fees, the billing for IT Asset Management, usage, performance, or the issuance of credits.

- Work Order: For the Service Provider product, it has been enhanced to include the customer and Service Address information and to calculate prices whenever planned or actual transactions are added to the work order. The ability to add miscellaneous fees and charges, for example a Trip Charge, is included. The enhancements also support the use of price quotes on a work order. There are two types of Quotes that are used in Service Provider: Fixed Price Quotes and Not to Exceed Price Quotes. The enhancements to the Work Order application are included in the Activities, Changes, and Releases applications.

- Service Level Agreement: Within the Service Provider solution, the Service Level Agreement was re-written to take advantage of the architectural similarities between SLA, Price Schedules, and Response Plans. In the process of the re-design, functional enhancements were added to improve its usability.

- People: For the Service Provider product, it was enhanced to include the customer, who is associated with that person. This association can be used by the Maximo Security process to restrict this person's access to information that is associated with other customers.
Locations: For the Service Provider product, it was enhanced to associate customers to a location. There can be more than one customer associated with a location, for example, there might be an owner and a user of a location, or a landlord and a tenant. The location can be associated with a Service Address, or the location can inherit the Service Address from an ancestor in the location hierarchy.

Response Plan: It is used to provide consistency in the service management process. It provides service agents with guidance and templates to outline the precise processes and resources applied to a given situation, for example, conditions can be defined to denote which person or which group is to be responsible for a ticket or when a given template is applied to a ticket. This responsibility assignment and this template can be applied automatically. In several cases, this automation eliminates the need to train the service agent to recognize who is responsible or when to apply a certain template and also removes a source of error from the process.

- Service Request: For the Service Provider product, the Service Request was enhanced to include the customer and Service Address information and to calculate prices whenever transactions are added to the Service Request. As with work orders, the ability to add miscellaneous fees and charges is included. The enhancements to the Service Requests application are included in the Incident and Problem applications.

- Security Groups: Security access in Maximo is controlled through Security Groups. By membership in Security Groups, users can be granted authority for applications (including read, save, new, and delete access), application actions, and data. Security Groups can contain a list of customers that are associated with the Security Group and that manage all other accesses to applications within the system.

Migration Manager: Migration is the process of promoting product configuration content from one product environment to another, for example, promoting new fields, domains, workflows, or window changes from the development environment to test and then through to production. Migration Manager can also promote non-configuration data, but data loading through the integration framework might be a better route to take, especially if the data is hierarchical. Migration Manager is a suite of three applications found as part of the System Configuration module of Tivoli Process Automation Engine and grouped into a sub-module called Migration.
1.4 Challenges and business drivers that the product addresses

IBM Maximo for Service Providers addresses the following challenges and business drivers:

Challenges:
- Highly customized system that is difficult to upgrade
- The need to place customer asset information on separate instances of Tivoli Process Automation Engine

Business drivers:
- Control costs
- Increase revenue
- Improve cash flow

1.5 Target organizations and audiences

Providers of outsourced maintenance and asset management services can use the IBM Maximo for Service Providers to solve their business problems. Companies that will benefit from IBM Maximo for Service Providers are:

- Facilities outsourcers
- IT outsourcers
- Fleet Maintenance outsourcers
- Plant Maintenance outsourcers
Architecture and components

This chapter contains a description of the architecture and components of Maximo for Service Provider V7.1.2. The topics that we discuss in this chapter are:

- 2.1, “Architecture” on page 10
- 2.2, “Components” on page 12
2.1 Architecture

IBM Maximo for Service Providers 7.1.2 is a set of applications and tools that work together to support service as a business. The product focus is to help the Service Provider companies to better maintain the assets of their customers. The Maximo for Service Providers product supports one or more customers and each customer can have one or more customer agreements.

It is critical for a Service Provider to be successful in two areas:

- A consistent response to any request from its customers. The consistent, repeatable delivery of services in response to any anticipated service request is a major factor in the efficiency and profitability of a Service Provider. Maximo for Service Providers helps the customers through its response plan. A response plan includes these tasks:
  - Automatically assigns the appropriate person or group to be responsible for handling each request
  - Selects the appropriate job plan or template to accomplish the requested work
  - Notifies the appropriate individuals about the work in process
  - Determines the next steps that are needed to solve the open requests

- Timely and accurate billing. Maximo for Service Providers maintains the agreements that exist between the Service Provider and each of its customers.

  The customer agreement specifies the maintenance services that will be performed so that each request for service can be validated to ensure that the customer is entitled to that service under the requested conditions. If the customer is not entitled to that service, the customer agreement helps the Service Provider to monitor which new services to offer to the customers, and, most importantly, it calculates the prices that will be charged for these services.

  Maximo for Service Providers calculates prices for billing in a variety of ways:
  - As maintenance activities are performed, Maximo for Service Providers calculates prices based on the cost of the labor, materials, services, and tools used. Additionally, Maximo for Service Providers can calculate pricing for the use of labor by using a published list price, pricing for service items, or material can be calculated using a published list price or a discount from that list price.
  - Maximo for Service Providers can specify a quoted price: either a fixed quote or a not to exceed quote. A fixed quote is used as the price, and a
not to exceed quote is used as the price if the calculated price exceeds the quote:

- Maximo for Service Providers calculates fees for managing assets by multiplying the number of assets under management by a unit price for each asset class. Assets are counted, and a price is calculated as the product of the unit price for the asset classification multiplied by the number of assets counted with that asset classification.

- Maximo for Service Providers calculates fees for asset usage by multiplying the usage units (GBs of storage, the number of pages printed, miles driven, square feet of space, and so forth) by a unit price. Asset usage is measured, and a price is calculated as a product of the unit price for the type of usage multiplied by the measured usage units.

- Maximo for Service Providers measures asset performance by key performance indicators (KPIs) and calculates a price from the level of performance that is measured.

- Maximo for Service Providers includes one-time charges for asset moves, adds, or changes that are calculated by using the specified price for the specific service requested.

**Pricing rules:** The pricing rules that are contained in the customer agreement govern all of the previous calculations.

Periodically, the billing process extracts the work orders, tickets, and sales orders containing these calculations and collects them into a batch. Each customer agreement has one batch. The Service Provider then reviews this batch, reviews the details of the bills, and adjusts the pricing, if necessary. The Service Provider's customers can also review limited details of the batch so that the customer can pre-approve the invoice. This step often speeds up payment of the invoice.

After the reviews are complete, Maximo for Service Providers forwards the billing batch to the Service Provider's accounting system so that a customer invoice can be prepared.

**Note:** The Maximo for Service Providers product provides integration to an external financial system using Maximo Enterprise Adapter (MEA). This integration is provided to specific requirements to the Service Provider's financial system. Either the transaction results are passed to the financial accounts receivable (AR) system to support matching the Enterprise Resource Planning (ERP) contract and order with the received funds or the transaction details are passed directly to the financial system to prepare a bill or sales order within the Service Provider's ERP system.
To get detailed information about the Maximo for Service Providers architecture, consult the information center for IBM Maximo Asset Management at:


### 2.2 Components

Maximo for Service Providers is an extension to Maximo Asset Management. It adds new applications to Maximo, extends the applications of Maximo by adding specific functionality to the applications, and also completely rewrites certain Maximo applications.

The following applications are new:

- Customer
- Customer Agreement
- Agreement Price Schedules
- Service Address
- Customer Billing
- Billing Review
- Sales Order
- Response Plan
- Customer Objects

The following applications were extended:

- Work Orders
- Service Request, Incident, and Problem
- Location
- Asset
- Configuration Item
- Deployed Assets
- Reconciliation
- Security Groups
- Classification and Attributes
- Domains
- Solutions
- Bulletin Boards
- Item Master and Service Items

The Service Level Agreement (SLA) application was rewritten.
2.2.1 New applications

In this section, we describe the new applications in Maximo for Service Providers.

Customer application

The Customer application manages information about the customer, for example, billing address, currency, contact persons, communications log, and so on. We show the primary tab of the Customer application in Figure 2-1. Customers own customer agreements or service level agreements (SLAs) and the agreement’s price schedules. Customers are associated with persons, locations, assets, and configuration items, and when a ticket or work order is created, the customer is copied to the ticket, sales order, or work order based on these relationships.

The relationship between a customer and any object is used by the security processes within Maximo for Service Providers to ensure that access to any customer information is controlled, and that only authorized users can view or update any information that is related to a customer.

Customer Agreement application

The Customer Agreement application contains the customer billing address, the customer business address, the general terms and conditions of the agreement, including the start date, expiration date, billing frequency, and so on. Figure 2-2 on page 14 shows the main tab of the Customer Agreement application.
Customer agreements own the agreement price schedules, which contain the business rules that are used to calculate prices on work orders, tickets, or sales orders. Customer agreements are revisable objects. After an agreement is approved, it cannot be changed, but a revision of the agreement can be created. After the revision is approved, the approved revision replaces the prior revision.

![Customer Agreement application main tab](image)

**Figure 2-2  Customer Agreement application main tab**

### Agreement Price Schedules application

A customer agreement can contain any number of Agreement Price Schedules, each of which contain price calculation rules. Prices in Maximo for Service Providers can be fixed prices, and they can be specified as a list price (electricians are $55 per hour, evening work is $75 per hour, or hydraulic pump priced at $2,308.56). Alternately, they can be calculated as a function of cost (for example a mark-up), or a price can be calculated as a function of list price (for example a discount, for materials and services), or a price can be selected based on an attribute on the work order, ticket, or sales order that is independent of cost. For example, a Price Schedule can specify that labor can be priced as a 20% mark up of the labor cost. Alternatively, a Price Schedule can say that support services for class C application servers that are running critical applications are priced as $735 a month. Price Schedules are owned by customer agreements. They contain a set of pricing rules, and they contain a set of conditions that specify when and under what conditions the Price Schedules are used. Figure 2-3 on page 15 shows the Price Schedules main tab.
The Service Address application is where the physical address where the work will be performed is specified, or where material will be delivered. Figure 2-4 on page 16 shows the Service Address application main tab. Service Addresses are associated with locations (or are inherited from an ancestor location). When a location is associated with a ticket or work order the service address information is added to the ticket, sales order, or work order. The address columns are added to the ticket and work order objects, and the content is copied from the service address table to the ticket or work order. This is done so that the address can be modified on the ticket or work order without modifying the master address. A common method is used to find the ancestor location with an address, if the location on the work order does not have a service address specified. There are also business rules that address the use case of changing the location on a ticket or work order after the service address has been modified.
Customer Billing application

The Billing application provides batch control functionality, and the main tab of this application is shown in Figure 2-5 on page 17. A bill batch is created for each customer agreement according to the billing frequency specified in the agreement. The batch consists of all the work orders, tickets, and sales orders that were completed during the billing period (and un-billed transactions from prior billing periods). The Billing application is used by the Service Provider to review (and to adjust, if necessary) any transactions in the batch. After the Service Provider has reviewed the batch they can allow their customer to review the batch before the batch is sent on to the Service Provider's accounting system for invoicing. There is a separate application, the Bill Review application, that is intended to provide a secure, and less detailed view of the batch for the customers view.
Billing Review application
This application is used by the Service Provider's customers to review the work orders, tickets, and sales orders that are included in the batch. Figure 2-6 shows the main tab of this application. If the customer has questions about any of these work items, they can be discussed with the Service Provider and answered prior to the bill being finalized.

Sales Order application
Using the Sales Order application, you can create pricing transactions that are not related to work that is done or to specific costs transactions. Figure 2-7 on
page 18 shows the main tab of this application. Common uses include billing of monthly maintenance fees, billing for IT Asset Management, usage, or performance, or issuing credits. As with the work order and ticket application, it includes customer and service address information, billing status, and billing history.

![Sales Orders (SP)](image)

**Figure 2-7  Sales Order application main tab**

**Response Plan application**

Figure 2-8 on page 19 shows the main tab of this application. The Response Plan application provides consistency in the service management process by removing the need for service agents or maintenance supervisors to decide what processing takes place for a given situation, for example, if the conditions can be defined for when a given template is applied to a ticket, this template can be applied automatically by the response plan. This process eliminates the need to train the service agent to recognize when to apply a certain template and also removes a source of error from the process. Response plans can be associated with one or more customers or they can be global.
Chapter 2. Architecture and components

The Response Plan uses a rules engine to determine:

- The Person or Group responsible for the work order or ticket
- The Vendor to whom work must be assigned
- The Job Plan to be used for a work order
- The Ticket Template to be used for a ticket
- The Solution to be used for the ticket
- The Supervisor for the ticket or work order
- The Lead for the work order
- The Work Group for the work order
- The Crew to be assigned to the work order
- Notifications to be performed for the ticket or work order
- Additional Actions to be performed to complete the repair or service delivery

Customer Objects application
The Customer Objects application is used in conjunction with the database configuration tools that allow a maximo administrative user to add tables and relationships to the Maximo Database. Using the Customer Objects application, you can specify the security access rules for any table that is related to the customer object. Figure 2-9 on page 20 shows the main tab of this application.
Maximo for Service Providers do extend Maximo Asset Management applications by adding new functionalities that are specific to Service Provider business rules. These applications and the added functionality are explained in the next section.

Work order, Activities, Changes, and Releases applications
These applications were enhanced to include the customer and service address information, billing status, and billing history. Prices are calculated whenever planned or actual transactions are added to the work order. The ability to add miscellaneous fees and charges (for example a trip charge) is included. The enhancements also support the use of price quotes on a work order. There are two types of quotes used in Service Provider: Fixed Price Quotes and Not to Exceed Price Quotes.

Service Request, Incidents, and Problems applications
The ticket applications were enhanced to include the customer, service address information, billing status, and billing history. Prices are calculated whenever
planned or actual transactions are added to the incident. As with work orders, the ability to add miscellaneous fees and charges is included.

**Locations application**
The Locations application was enhanced to provide a relationship between locations, customer, and service address. The method to locate the service address from the location's ancestor is the same method that is used to locate the service address to be copied to the work order or ticket. The relationship between customer and locations is a many relationship: One location can be associated with many customers (one of which is primary) and a customer can be associated with many locations.

**Asset application**
The Asset application was enhanced to provide a relationship between asset and customer. This is a many-to-many relationship with a customer:

- One asset can be associated with many customers (one of which is primary) and a customer can be associated with many assets.

**Configuration Item application**
This application was enhanced to provide a relationship between the configuration item to the customer. This is a many-to-many relationship:

- One configuration item can be associated with many customers (one of which is primary) and a customer can be associated with many Configuration Items.

**Deployed Assets application**
The Deployed Assets were extended to include a customer identifier. Deployed assets are created as a result of using asset discovery tools, for example, IBM Tivoli Configuration Manager, Microsoft® SMS, Centennial Discovery, and so on. IBM Tivoli Integration Composer imports the collected data into the deployed assets module. Customer is not a piece of discovered data but is set to the same value for all records imported in a specific discovery session. The deployed assets are reconciled by comparing them to the assets that represent the authorized assets. The reconciliation process compares what's there with what should be there.

**Reconciliation application**
There are several applications that manage the process of reconciling the deployed assets with the assets, which includes Reconciliation Tasks, Reconciliation Rules, Reconciliation Links, and Reconciliation Results. These applications were extended so that they include the customer, which allows the reconciliation process to be tailored for an individual customer if IT Assets are managed in a multi-customer environment.
Security Groups application
In Maximo for Service Providers, this application provides a simple method of specifying the authority to access customer information by users who are members of the group. Generally these authority rules are set up differently for users who work for the Service Provider and for those users who work for the Service Provider’s customers. The following access options are provided:

- Authorize Group for all customers including customer level information not related to a customer.
- Authorize Group only for customer level information not related to a customer.
- Authorize Group for person’s customer or vendor, but not for customer level information not related to a customer.
- Authorize Group for customers in person’s customer access list and for customer level information not related to a customer.
- Authorize Group for customers listed on the security group and for customer level information not related to a customer.

Classifications and Attributes applications
Classification structures categorize information and assign attributes related to a classification, for example, if a seal is classified as an oil seal, it can have the attributes of material, insider diameter, outside diameter, and width. A mechanical seal, on the other hand, can have attributes of alignment type, body material, and shaft diameter. Similarly, desk top computers have disk size, processor speed, and memory size as attributes, but computer operating systems have a version number.

Maximo for Service Providers adds a customer link to both the classification structure and the attribute, for example, this makes it possible for a Service Provider to allow one customer to track just the version number for their operating system assets, and to allow another customer to track the version number and patch level for operating systems.

Domains application
The Synonym, ALN, and Numeric domains were extended to allow a domain value to be customer specific. Filtering and validation of domain entries is based on the customer (or primary customer) on the object to which the domain value is being added.

Solutions application
Solutions were extended so that they can be global or customer specific. Filtering and validation of solution is based on the customer on the object to which the solution is being associated.
Bulletin Boards application
Bulletin Board entries can be customer specific. A Customer sub tab was added to the Audience tab, and the user's security group filters bulletin board messages that are displayed on the Start Center and that are broadcast through email.

Item Master and Service Items applications
A customer association and also a List Sales Price were added to the item table. A supporting enhancement was made to the price schedule application to allow material or service items used on a work order to be priced as a discount from the list price, in addition to the existing functionality of marking up the Item's cost.

2.2.3 Rewritten application
The Maximo for Service Providers Service Level Agreement application was been written. This application is part of IBM Maximo for Asset Management, but it has a different behavior in Maximo for Service Providers.

SLA application
This application was re-written to take advantage of the architectural similarities between SLA, Price Schedules, and Response Plans. In the process of the re-design, functional enhancements were added to improve its usability, including the support of the SLA Hold functionality and the use of de-centralized calendars to support the use of SLAs by clients who operate in multiple time zones. In the Service Provider context, SLA can be associated with one or more customers, or they can be global. This application was optimized for performance by introducing an initial query that performs classification and customer matching. Figure 2-10 on page 24 shows the main tab of SLA.
Figure 2-10  SLA application main tab
Chapter 3. Initial configuration

In this chapter, we describe some of the initial configuration steps that are specific to the IBM Maximo for Service Providers product and describe how to set up Maximo for the Service Providers applications before starting to use the product.

We only discuss the configuration steps that are specific to IBM Maximo for Service Providers and not the steps that are part of your Tivoli’s process automation engine (previously called Maximo) configuration.

The topics that we discuss in this chapter are:

- 3.1, “Organization (SP)” on page 26
- 3.2, “Customer (SP)” on page 29
- 3.3, “Customer Objects (SP)” on page 32
- 3.4, “Security Groups (SP)” on page 34
- 3.5, “Domains (SP)” on page 36
- 3.6, “Locations (SP)” on page 39
- 3.7, “Service Address (SP)” on page 41
- 3.8, “Assets (SP) application” on page 44
- 3.9, “Configuration Item” on page 48
- 3.10, “Associating classifications and customers” on page 49
- 3.11, “Associating CI with a classification” on page 53
- 3.12, “Associating service items and customers” on page 54
- 3.13, “Service level agreement” on page 55
- 3.14, “Creating customer agreements” on page 59
3.1 Organization (SP)

You use the Organization (SP) application to set up organizations and sites and to set options that are related to applications and actions that are specific to applications.

Organization (SP) has the following options that are related to Maximo for Service Providers:

- **Work Order Options ➔ Edit Rules**
  
  See Figure 3-1 for this configuration option.

![Figure 3-1 Work Order Options, Edit Rules](image)

- **SLA Options ➔ Add SLA Hold functionality to the SLA application**
  
  This option is available only for Tivoli Service request Management, and it is read only for IBM Maximo for Asset Management and IBM Tivoli Asset Management for IT, as shown in Figure 3-2 on page 27.
Figure 3-2  SLA Options

▶ Service Options

Here you specify how to enter street address for a service address. See Figure 3-3 on page 28.
Figure 3-3 Service Options

- **Billing Options**

  Using this option, you specify the status at which Completed work can be added to Bill batch, as shown in Figure 3-4.

Figure 3-4 Billing Options
3.2 Customer (SP)

Use the Customers (SP) application to create, view, modify, and delete customer records. Customer records contain the following information about your customers:

- Business and billing addresses
- Billing details
- Internal contacts and customer contacts
- Associations with customer agreements and price schedules
- Associations with service level agreements (SLAs) and response plans
- Associations with parent or child customers.
- Customer logs

3.2.1 Creating customers and associating person to new customer

To create a customer and associate a person with the new customer:

1. If you have not already done so, sign in to the system as:
   - User: Wilson
   - Password: Wilson

2. Open the Customers (SP) application by selecting Go To → Service Provider → Customers (SP).

3. From the Toolbar menu, click the New Customer icon. The system displays a blank customer form that is ready for input, as shown in Figure 3-5 on page 30.
4. Enter the values shown in Table 3-1 for creating a new customer.

Table 3-1  New customer

<table>
<thead>
<tr>
<th>Field</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Customer</td>
<td>RedbookCus-A</td>
</tr>
<tr>
<td>Customer Description</td>
<td>RedBooks Inc. Customer A</td>
</tr>
<tr>
<td>Language Code</td>
<td>EN (English)</td>
</tr>
<tr>
<td>Customer Currency</td>
<td>USD</td>
</tr>
</tbody>
</table>

5. Activate the customer by changing the status to Active, as shown in Figure 3-6 on page 31.
6. Click the **Contact** tab, and click the **New** row on the contact section. You use the Contacts tab of the Customers (SP) application to add, view, modify, or delete contact people. Contacts work for the service provider, the customer, or a vendor of the customer. A contact must be an active person in the People (SP) application. When you add a contact, the telephone, email, and employer information for this contact are displayed.

7. Go to the People (SP) application using the Detail Menu icon on the Contact field. You are taken to the People (SP) application, as shown in Figure 3-7 on page 32.
8. Save the person record, and from the header, click **Return With Value**.

9. Click **Select Value** for the Customer Contact Type field, and select **Contract Type**. Save the record.

**Note:** You can have multiple people as contacts for a specific customer. You can also have internal people as a contact for customers (for example a person in your organization responsible for the contracts with this customer).

### 3.3 Customer Objects (SP)

Use the Customer Objects (SP) application to manage the conditions that determine access to customer-level information. You can create customer-level data object restrictions that are applied to customer objects based on the customer authorization settings in the Security Groups (SP) application.

Default conditions are standard customer objects and the restriction conditions for those objects that are used when you set up customer authorization for security groups in the Security Groups (SP) application. These objects and conditions are set up by default in the Customer Objects (SP) application, but you can modify or remove them, and you can add other objects and conditions.
To create these default conditions in Customer Object applications:

1. Go to **Security → Customer Object (SP) applications**.
2. From the Action menu, click **Create Default Conditions**, as shown in Figure 3-8.

![Figure 3-8 Create Default Conditions]

The IBM Maximo for Service Providers product lists the objects that are related to the service provider and can expand to the default restrictions. Figure 3-9 shows the SR Object (Service Request).

![Figure 3-9 SR objects (part of the window is cut for readability)]

3. If you added any customer objects or restriction conditions, in the message window that is displayed, Figure 3-10 on page 34, click **Yes** to keep those additions, or click **No** to remove them and keep only the default objects and conditions.
You set up security privileges by group. You use the Security Groups (SP) application to create groups, and then you specify group privileges and restrictions for applications and options. You can also use Customer Authorization (Person (SP) application) to restrict access to customer-level information. Figure 3-11 shows how to access the Security Groups (SP) application.

The Security Groups (SP) application has a new tab, called Customers, for Maximo for Service Providers, as shown in Figure 3-12 on page 35.
When you click the **Customers** tab, the options in Figure 3-13 are displayed.

![Security Groups (SP) application: options]

The options in Figure 3-13 determine the security level and the rules:

- **Authorize Group for All Customers?**
  Members of this group have access to all customers.

- **Authorize Group only for Unrestricted Customer level Information**
  Members of this Group do not have access to any customers, but have access to all customer level information not related to a customer.

- **Authorize Group for Customer on User's Person record**
  Members of this group have access to the customer who appears in their Customer Vendor field, and to all global classifications, but not to any customer level information that is not related to a customer.

- **Authorize Group for Customers in User's Person Customer Access List**
  Members of this Group have access to all customers who appear in their Customer Access List, and to all customer level information that is not related to a customer.

- **Authorize Group for Customers Listed Below**
  Members of this Group have access to all customers who appear in their Security Groups Access List, and to all customer level information that is not related to a customer.
You can add specific customers in the Individual Customer Authorization section of the Customer tab, as shown in Figure 3-14.

![Figure 3-14   Individual Customer Authorization](image)

**Note:** You can select only one security group option. If a second option is needed, use an additional Security Group. Selecting one option will copy the customer object conditions as data restrictions on the object level.

### 3.5 Domains (SP)

Some fields in the system are associated with select value lists from which users choose an appropriate value. These lists of defined values are known as domains (sometimes referred to as value lists). The system uses many domains in its applications.

As an administrator, you use the Domains application to add new domains or to modify existing ones to fit with your business practices.

Domains (SP) allows you to manage the value list and filter it based on the customer. It is possible to create a list of acceptable values for a field that can be global or a list of acceptable values that can be valid only for a customer. See Figure 3-15 on page 37.
The SYNONYM, ALN, and NUMERIC domains can be customer specific. A customer field was added to the domain detail window for each of these domains. The field identifies the customer for which the domain is valid.

Example: Work order Status domain (WOSTATUS) has two new synonyms for APPR status. These synonyms are customer specific: APPRCUSTA (for customer REDBOOKCUS_A) and APPRCUSTB (for customer REDBOOKCUS_B), as shown in Figure 3-16 and Figure 3-17 on page 38.
In this example, the user creates a work order for REDBOOKCUS_A and then wants to change the status. Figure 3-18 shows the status list that the user can choose from.

APPRCUSTB is not in the list because it is associated with another customer.

The work order for customer REDBOOKCUS_B’s status list looks like Figure 3-19 on page 39.
3.6 Locations (SP)

Use the Locations (SP) application to create and maintain locations for assets and locations where you provide services to customers. You can organize these locations into logical hierarchical or network systems.

You can associate locations with one or more of your service customers. A system process can match data on the combination of location and customer to apply a response plan, service level agreement, or agreement price schedule to work for that location.

Location (SP) has the following industry-specific (service provider) fields:

- Primary Customer
- Customer Charge Account
- Customer Cost Center

For readability purposes, we show the Locations (SP) in two Figures: Figure 3-20 on page 40 and Figure 3-21 on page 40.
3.6.1 Creating a location and associating it with a customer

To create a location and associate it with a customer:

1. Open the Locations (SP) application by clicking **Go To → Assets → Locations (SP)**.

2. From the Toolbar menu, click **New Location**. The system displays a blank location form that is ready for input.

3. Enter the information in Table 3-2 on page 41 for the new location.
Table 3-2  New location

<table>
<thead>
<tr>
<th>Field</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Location</td>
<td>REDBOOKLOC_A</td>
</tr>
<tr>
<td>Location Description</td>
<td>IBM Redbooks Location A</td>
</tr>
<tr>
<td>Type</td>
<td>OPERATING</td>
</tr>
</tbody>
</table>

4. From the Action menu, select the Associate system with location option, as shown in Figure 3-22.

![Figure 3-22  Associate system with location](image)

5. Click New Row, and in the System field, type heating. Click OK.

**Associating customers to locations:** You can associate multiple customers to one location; however, you can have only one primary customer.

### 3.7 Service Address (SP)

Use the Service Address (SP) application to create, view, modify, and delete service addresses for customers. A service address can represent one or more physical locations for a customer. It contains detailed location information that helps you to assign the correct resources when you provide service or support to a location.
Some applications have Service Address as a tab. These tabs are used to view or add service address information and to view information about the associated customer, customer agreement, price schedule, and billing status.

### 3.7.1 Creating a service address associated with a customer location

To create a service address that is associated with a customer location:

1. Open the Service Address (SP) application by selecting **Go To → Service Level → Service Address (SP)**.

2. From the Toolbar menu, click **New Service Address**. The system displays a blank service address form that is ready for input.

3. Enter the information in Table 3-3 for the new service address.

<table>
<thead>
<tr>
<th>Service Address</th>
<th>System Auto number (6)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Description</td>
<td>REDBOOKLOC_A location Service address</td>
</tr>
<tr>
<td>Street Address</td>
<td>11 king Street West</td>
</tr>
<tr>
<td>City</td>
<td>HOUSTON</td>
</tr>
<tr>
<td>State / Province</td>
<td>TX</td>
</tr>
<tr>
<td>Country</td>
<td>US</td>
</tr>
<tr>
<td>Time Zone</td>
<td>US/Eastern</td>
</tr>
</tbody>
</table>

Figure 3-23 on page 43 shows the new service address.
4. Save the record. Go to the Locations (SP) application, and search for REDBOOKLOC_A.

5. Set the value for Service Address field to 6, as shown in Figure 3-24.

The Service Address tab will look like Figure 3-25 on page 44.
3.8 Assets (SP) application

The Assets (SP) application organizes and records the data about assets that is used to provide services. Using the Assets application it is possible to associate an asset to a customer and to associate the asset with agreements and response plans, and so on.

To open the Assets (SP) application, use Go To Menu, as shown in Figure 3-26 on page 45.
3.8.1 Assets tab

Under the Assets tab on the Assets (SP) application, you can create a new asset and associate it with a customer. When you associate an asset to a customer you can keep the assets records restricted to the users who gave permission to access the data of a customer.

When the customer is associated with an asset, the customer must have a primary customer to identify agreements, classifications, classification attributes, SLAs, and response plans.

To create a primary customer, you must already have customers created in the Customer application (Menu 3.2, Customers). You can have more than one customer associated with an asset, but one customer can only be the primary customer, for example:

1. To add a primary customer to an Asset Router, click Show/Manager Customers under the Primary Customer field. A dialog Add/Modify Customer Associations opens, as shown in Figure 3-27 on page 46.
2. Click **Select Customer**. A dialog opens and shows all available customers in Active status. Select customer, and click **OK**. The dialog closes.

3. Click **View details** to expand details to customer associated, as shown in Figure 3-28.

![Figure 3-27 Customer associations](image)

![Figure 3-28 Customer associations](image)
The primary field is selected as default, when just one customer is associated.

4. In the Add/Modify Customer Associations dialog, click **New Row**. A new row is created.

5. Click **Select Value** to associate a new customer. When the dialog opens, select another customer.

6. Check field **Primary?** to customer B, and click **OK** to close dialog. Now, customer B is the primary customer in Asset Router, as shown in Figure 3-4, and will be identified in agreements, classifications, classification attributes, SLAs, and response plans.

![Figure 3-29  Asset tab](image)

**3.8.2 Specifications tab**

Under the Specifications tab, you associate a classification with an asset.

There are two types of classifications, global and customer-specific. Global classifications can be added to any asset, even if assets have no customers associated. An asset can use customer-specific classifications only, if the primary customer of the asset is associated with the classification. For Assets (SP), you can create an asset and associate it with a primary customer.

We show how to associate customers with classifications in 3.10, “ Associating classifications and customers” on page 49.
3.9 Configuration Item

A Configuration Item is a component of information technology infrastructure and can be managed individually. Figure 3-30 shows a list of these items.

![Configuration Item](image)

**Figure 3-30  Configuration Item**

In Configuration Item (SP), you can create Configuration Items, also referred to as CIs, and create relationships between them.

### 3.9.1 Configuration Item tab

In the Configuration Item tab you can add, view, modify or delete CIs. Remember that Configuration Items are identified by name or attributes.

You also must define a primary customer to CI. As an example, let us define a primary customer for CI DCMJ21:

1. Select a classification and a class description.
2. Click **Show Manage/Customers** under the primary customer field, as shown in Figure 3-31.

![Configuration Item tab](image)

**Figure 3-31  Configuration Item tab**

3. Click **Select Customer**, select RedbookCU-A as the customer, and click **OK**. A primary customer is now defined to a CI.

The Specifications table window has information to identify if an attribute is appropriate for the primary customer or the parent of the primary customer.

When you add a classification to a CI, the classification's attributes are copied to the Specification table window. If there is no customer defined for a classification, only global attributes are copied.

To better explain how this works, we will configure a classification and associate a customer with a Configuration Item.

### 3.10 Associating classifications and customers

Using the Classification application you can create classifications and determine a classification hierarchy. You can use Classification (SP) for matching customer agreements, SLAs, and response plans. See Figure 3-32 on page 50.
Classifications have two types: global and customer-specific. Global classifications are available to all, and customer-specific classifications are restricted to certain users based on the security profile of the users.

All classifications are global by default. When you associate it with a customer, it becomes customer-specific. To associate classifications and customers:

1. In the Classifications (SP) application, create a new classification, as shown in Figure 3-33 on page 51, and verify that the Global mark option is selected as default.
Global classifications can have children that are global, customer specific, or a mixture of both. Customer specific classifications can only have children that are customer specific.

2. To associate a classification with a customer, you deselect the field **Is Global?**, and click the **OK** button on the message window, as shown in Figure 3-34. When the Global field is not selected, the Customer field becomes editable.

3. Click **Show/Manage Customers**, as shown in Figure 3-35 on page 52.
4. Now, a classification is created that is customer-specific. It is also possible to associate children of classifications with a customer. Create a new classification, and add it as a child to the REDCLAS classification as REDCHILDREN classification, as shown in Figure 3-36.
In the Details window of the Children table, you can specify if this classification is Global or customer-specific as a classification parent. For REDCHILDREN specific, the customer as REDBOOKCU-A.

5. Now we have two customer-specific classifications. Go to the REDCHILDREN classification, and add a child with a different customer, as shown in Figure 3-37.

![Figure 3-37 Add a Children with a different customer](image)

When you add an asset to a child of a classification and associate customers with the children, the parent also has multiple customers. See Figure 3-38.

![Figure 3-38 Associate Customers with the Children](image)

### 3.11 Associating CI with a classification

In this section, we associate a classification with a CI:

1. Open the **Configuration Item (SP)**, and create a new Configuration Item, for example REDBOOK HD. Define a primary customer as REDBOOKCU-A and classification as REDCLASS.

2. Verify that only the specifications that are defined as GLOBAL are displayed under the Specifications table window, as shown in Figure 3-39 on page 54.
The Customer Match field identifies if the attribute is a global (GLOBAL), does not belong to the classification or primary customer (NO), or is associated with customer-specific attributes on the classification (YES).

If all attributes are NO, this indicates that the primary customer or its parent customer is not associated with the classification or that the CI has no primary customer and attribute on classification.

**3.12 Associating service items and customers**

The Service Items (SP) is used to create service item records and to view or manage a list of vendors for items that your company requisitions.

You can associate customers with service items and restrict the service items to the users who were given permission to access a particular customer’s data.

To associate service items and customers:

1. Go to **Service Items (SP)**, as shown in Figure 3-40 on page 55.
2. Click a new **Service Item**, and create a new service for your company as an example.

### 3.13 Service level agreement

A service level agreement is an agreement between a customer and a service provider. A service is a set of tasks that fulfill one or more business needs of the customer and a service level describes aspects of the service. You can apply valid SLAs to records from other applications. An escalation is a function that automatically monitors critical processes.

1. Open the **Service Level Agreement** application, as shown in Figure 3-41 on page 56.
2. To create a new service level agreement, go to **Service Level → Service Level Agreement (SP)**. Click **New SLA**. Enter SLARB1001 as the name of the SLA, fill in all required fields, including Type, Applies To, and Ranking.

3. Type identifies the type of SLA between service provider and the customer, This can be an internal SLA or between the service provider and the vendor. The Applies to Field identifies where this SLA can be applied, for example, it can be a ticket or a craft usage. Ranking is defined by a System Administrator to configure which SLA to be used when an SLA record has multiple valid SLAs. See Figure 4 on page 57.
4. Also add a new commitment under the Commitments table window. Add a commitment identifier (1072), with type (RESOLUTION), value (10), unit of measure (Days) and save the SLA, as shown in Figure 3-43.

5. An SLA can also have another SLA that can be associated using the Related SLAs tab. To associate another SLA, click **New Row**, and add a new row. Alternately, select **Select SLAs**, and select an existing SLA, as shown in Figure 3-44 on page 58.
3.13.1 Conditions tab

The Conditions tab is used to build Conditions (SQL expressions) that specify which records the SLA matches. An SLA is applied to a ticket or work order if the conditions defined in the SLA record match the conditions defined in the ticket or the work order record.

In this example, we use a ticket that matches the classification and internal priority that you specify in the SLA Criteria section of the Conditions tab:

1. Go to Service Level Agreements (SP), and open SLARB1001.
2. Click the Conditions tab, and in the Classification section, click Detail Menu.
3. Click Classify, and select Request for Service\IT\Hardware Configuration, as shown in Figure 3-45 on page 59.
4. Populate the Internal Priority field using the Select Value function. All available values are displayed in the dialog box. Select **LESS** and choose 4 as the internal priority, as shown in Figure 3-46.

5. To use this SLA, change status to **ACTIVE**. Click **Change Status** and change the status to **ACTIVE**.

### 3.14 Creating customer agreements

Using the Customer Agreements application you can create and maintain customer agreements between you and your customers, such as services you provide, locations and assets for which you provide services, information about billing, dates of the agreements, and price schedules for services and configuration items.

A customer agreement contains one or more price schedules. Price schedules define your pricing rules and the conditions. They can contain different rules for calculating prices for services.
To create customer agreements:

1. To create a customer agreement, go to **Service Provider → Customer Agreements (SP)**, as shown in Figure 3-47.

![Figure 3-47 Create a Customer Agreement](image)

2. When the application opens, click **New Agreement**. If the agreement field is empty, enter a value. Because it is a customer Agreement, you must add a customer in the Customer Section, as shown in Figure 3-48 on page 61.
3. Create a price schedule under the Price Schedules tab. Click **New Row**. You can edit the Schedule field or insert a new schedule. In the Applies to field, use the Select Value function to select the types available to apply in this schedule. For this example, select **INCIDENT**, and set ranking as **3**, as shown in Figure 3-49 on page 62.
3.14.1 Pricing rules

Under the Price Schedule Detail for Schedule that you just created, you can create pricing rules. These pricing rules are used when billing transactions are created for labor used on a ticket, for example, labor prices are calculated by the craft associated with the labor.

Adding Labor Pricing Rules

You can add labor pricing rules to a customer agreement price schedule in the Customer Agreements (SP) application. These values are used in billing transactions when a labor is used on a ticket or where price schedule is applied.

To create a new labor, click the Pricing Rules tab and Labor sub tab. Click New Row, as shown in Figure 3-50 on page 63.
Figure 3-50  Create a new labor

Here you can also create markups. You can create default markups percentages that are added to reported costs for internal and external crafts. If you do not have craft markups or prices, a default markup is used.

When you define a craft markup, specify whether the markup is for an internal or external craft. If it is internal, you must specify a markup percentage. If it is external, you must select if the markup is applied only to this craft from this vendor or to all vendors.

Craft prices are applied to reported hours for internal and external crafts for each craft or craft and skill you specify whether the price is for internal or external crafts.

Populate all of the fields, as shown in Figure 3-51 on page 64.
You add Materials Pricing Rules to create billing transactions for materials used on tickets or work orders. Default calculation percentages are used for stocked and non-stocked items. You can also specify a markup or a discount value to be applied for certain commodities.

Click the Materials sub tab, and click New Row. In the commodity group field, add ENGINES or the desired Commodity group. Also specify 15 as Calculation Percentage, and select the Markup option, as shown in Figure 3-52 on page 65.
Chapter 3. Initial configuration

Adding services pricing rules

Default calculation percentages are added to reported costs for service groups and services. A service calculation percentage overrides a service group calculation percentage. You specify whether the percentage value is applied as a markup to the item cost or a discount from the item list price.

You specify pricing rules in the Services sub tab. Click New Row to add a service pricing. To add a service group select FACILITY or the desired Service Group. For the Calculation Percentage, enter 10 and do not select the Markup option, as shown in Figure 3-53.

Adding tools and pricing rules

Tools also have the same rules as labor, materials, and services. You have a default markup if you do not create a specific tool markup.
Tool markups have two types: You can specify the markup percentage and a commodity group. The markup is applied only to commodities in this group. Commodities in other groups receive the default markup. Alternately, you can specify a commodity in a commodity group. The markup is applied only to this commodity.

To add a new tool, you must add a new row under Tools Mark Ups. Add a commodity group MOTORS, and specify the markup percentage as 10.00, as shown in Figure 3-54.

![Figure 3-54 Adding tools pricing rules](image)

### 3.15 Creating a response plan

Using the Response Plan application you can define who is responsible to handle the service request and apply it to a ticket, work order, or a sales order. Another type of person can be assigned to a work order or ticket, for example lead person, supervisor, or crew. It is also possible to select the correct job plan or template, notify individuals about the work process and specify actions that are needed to resolve the issue.

A response plan might be applied to a workflow process or a escalation process. To create a response plan:

1. To create a response plan go to Service Level and Response Plans (SP), as shown in Figure 3-55 on page 67.
2. At the Response Plans application, click **Add a New Response Plan**. Response plan RPRB200 applies to INCIDENT and ranking is 1, as shown in Figure 3-56.
3. In the Dates Table window, you can specify the range for which this response plan is valid and a date when a review or renewal is required. If you select a shift and calendar, the plan is applied only to the records where this calendar or shift are associated. See Figure 3-57.

![Figure 3-57 Response plans](image)

4. In the Conditions tab, define when the response plan is applicable to a ticket or work order or sales order. A response plan is applied when conditions defined to a ticket match the conditions defined to a response plan.

5. As conditions that can be match, you can define classifications, services, or service groups, CIs, locations, assets listed and refers to a ticket, work order, or sales order.

6. For response plan RPRB200, add a classification request for **Service\IT\Hdw Config**. Under the Conditions table window, click **Add First Row**, and create a new condition, such as Between Groups or Field Name Customer Agreement, as shown in Figure 3-58.

![Figure 3-58 Response plans](image)

7. Under the Actions Response Actions tab, click **New Row**. Select **Action Delegate Incident** or go to **Actions** application, and create a new action, as shown in Figure 3-59 on page 69.
8. Save the response plan, and active it. See Figure 3-60.
3.16 Creating and configuring escalations

Escalations monitor processes to help you meet the commitments in your SLA. The primary goal of Escalation Management is to ensure that critical tasks are completed on time.

When a Service Desk agent applies an SLA to a record, the system begins to poll for records that meet the criteria for the associated escalation, according to the frequency specified in the escalation’s Schedule field.

Escalations are restricted to the same SLA’s site, organization, or system Level. An escalation can be activated when a SLA is not in a DRAFT status.

After you change the status of an SLA to active, the system activates the escalation, if it contains an escalation point, action, or notification. If you create an escalation for an SLA that is in active status, you must activate the escalation using Escalation → Activate/Deactivate Escalation from the Select Action menu.

To create and configure escalations:

1. To create an escalation, go to the Service Level Agreement application, and select the SLA SLARB1001 from the list. Under the Commitments Table window, click New Row, and click Define Escalation, as shown in Figure 3-61.

2. Under Commitments, add a new type, RESOLUTION. Specify 10 as the Value and DAYS as the Unit of Measure.

3. Go to the Escalation Tab. You will see that an escalation was created and a condition added, as shown in Figure 3-62 on page 71.
4. In Escalation Points, you can define how many hours an assignment is in a person's inbox, measuring time until lapse (for example how many days until a contract expires), and a stand-alone condition without a time measurement. Also it is possible to create one or more actions for an escalation point, and associate one or more notifications with an escalation point. You must associate at least one action or notification with an escalation before you can activate the escalation, as shown in Figure 3-63.

5. You create notifications for the escalation using the Communication Templates. Under Notifications Sub tab, click **New Row**. In the Template Field Detail Menu, click **Select Value** to select a value or go to **Communication Templates** and create a new one. For this example, select template **Incident Unresolved**, as shown in Figure 3-64 on page 72.
3.17 Bulletin Board (SP)

Use the Bulletin Board (SP) application to:

- Create and view messages in an electronic board regarding critical problems and incidents
- Create a communication to broadcast information throughout the enterprise
- Create an email communication based on the Bulletin Board message content

The idea is to minimize the creation and duplication of tickets. You can also define a date and time when you want the message to be removed from the Bulletin Board. To create a Bulletin Board:

1. Go to Administration → Bulletin Board (SP). Click Bulletin Board. You will see a Message ID 1001. Enter a Post Date and an Expiration Date, as shown in Figure 3-65 on page 73.
You also can specify the user audience by organization, site, person, group, or customer. If no organization, site person, group, or customer is specified, the message is visible to all users.

2. Go to the Customers sub tab, and add a new row.

3. Select customer **REDOBOOKCU-A** and save, as shown in Figure 3-66.

4. To make this Bulletin Board available, set its status to Approved.
Use cases and scenarios

In this part, we describe several IBM Maximo for Service Providers scenarios that are most commonly used in real life implementations. For these scenarios, we defined a fictitious Service Provider company: RedBooks Inc. This company is providing service to several other companies. IBM Maximo for Service Providers is used to manage these services.
Service Desk scenario

In this chapter, we describe the implementation of a common Service Desk requirement, where we have the customer searching for solutions and opening service requests. The entire process contains several customer-specific features enabled by the Service Provider package, such as service request, solutions, response plan, and Service Level Agreement.

The topics that we discuss in this chapter are:

- 4.1, “Business requirements” on page 78
- 4.2, “Applications involved” on page 79
- 4.3, “Scenario benefits” on page 79
- 4.4, “Implementation” on page 79
4.1 Business requirements

The customer RedBookCus-A needs to implement an effective process to allow their employees to search for existing solutions for their common requests or issues. They must be able to open tickets if no solutions are found. Those tickets must be validated for a Service Desk Analyst and must go to the correct Resolution Group based on the classification. Also, a Service Level Agreement (SLA) must be applied on the ticket based on the Impact and Urgency of the request.

The customer needs to view the progress of the ticket and receive a notification when the ticket is closed. Figure 4-1 gives an overview of the process.

Figure 4-1 Process overview
4.2 Applications involved

The applications that we use in this chapter are:

- Solutions
- Search Solutions
- Create Service Request
- View Service Requests
- Service Request
- Response Plan
- Service Level Agreement (SP)
- Escalation

4.3 Scenario benefits

This scenario describes the best practices to give the customer the ability to search for tips or solutions for his day-to-day problems and a way to open requests if there is no solution that fits with his needs. It also describes the best practices to the Service Desk to attend and resolve the customer request.

The benefits of this scenario are:

- Provide the customer with an easy way to search or to request answers for his problems.
- Automate several actions that the Service Desk agent performs to save time and decrease the resolution time.
- Give the customer the ability to view the request life cycle and add comments or further information in it.
- Set a target date to have the resolution target based on its impact and urgency.
- Send automatic communications to the customer and resolver groups to have everybody aware of the request and its updates.

4.4 Implementation

In this section, we provide step-by-step procedures for implementing the Service Desk scenario.

In summary, the customer uses the Search Solutions application to try to find one solution for this issue or doubt. If the customer cannot find a solution, he opens a
service request using the Create Service Request application. This service request contains only basic information, such as description and customer data. The Service Desk Analyst needs to analyze it, fill out the important fields, and send the service request to the responsible owner group to resolve it. To make this work easier, the Service Desk Analyst can apply a response plan to the ticket. The Response Plan assigns the service request the correct owner group, sends a notification, and applies a SLA. After the owner group receives the service request, they work to resolve it, adding the solution details in the service request and changing its status to Resolved. The customer receives a notification when the process ends.

The first step needed is performing the configuration of the features that will be used. The second step is using the Service Desk applications to search for an existing solution, submit the customer request, and explain how the customer-specific features work over the entire process.

There are five important roles to implement and apply this scenario:

- Maximo Administrator: Responsible for the configuration.
- Solution Administrator: Responsible for managing the solutions.
- Customer User: Responsible for searching solutions and to opening Service Requests.
- Service Desk Analyst: Responsible for the Service Request validation.
- Resolver Analyst or Specialist: Responsible for the Service Request solution.

Over the next sections, we describe how each role performs the tasks they are responsible for.

### 4.4.1 Implementation steps

Follow these steps to complete the scenario:

- **Pre-configuration:**
  - Basic configuration (Customer, Classification, and so on).
  - Create a solution.
  - Set up a Service Level Agreement to be applied by the Response Plan.
  - Set up a Response Plan to be applied on the service request.
  - Enable the out-of-the-box Escalations to send notifications.

- **Service Desk Process:**
  - Search for a Solution.
  - Submit a Service Request.
  - View the Service Request updates.
– Validate the Service Request and Apply the Response Plan.
– Resolve the Service Request.

### 4.4.2 Pre-configuration

In this section, we provide pre-configuration steps for this scenario:

**Basic configuration**

**Responsible role:** Maximo Administrator

A basic configuration is required before setting up the features described in the next sections. Follow the instructions from Chapter 3, “Initial configuration” on page 25 to configure them. Make sure all the configurations are associated with the RedBookCus-A customer and the security user has access to this customer.

**Table 4-1 Basic Configuration**

<table>
<thead>
<tr>
<th>Object</th>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Customer</td>
<td>RedBookCus-A</td>
<td>RedBooks Inc. Customer A</td>
</tr>
<tr>
<td>Owner group</td>
<td>NETWORK</td>
<td>IT/Network Support</td>
</tr>
<tr>
<td>Classification</td>
<td>End User Issue \ Network</td>
<td>Network Issues</td>
</tr>
</tbody>
</table>

**Creating a solution**

**Responsible role:** Solution Manager

A solution is a predefined response to a commonly asked question or problem. You can allow customers to search and view solutions from a simplified knowledge base, called *Search Solutions*, to resolve their problems on their own. A solution can also be associated with a service request, incident, or problem ticket. The solution is accessible from other applications, if its status is ACTIVE and the Self-Service Access? option must be selected to be visible to self-service (customer) users.

As a Solution Administrator, you create solution records from the Solution application. To create a new solution, select Go To → Service Desk → Solutions, and then click New Solution.

Figure 4-2 on page 82 shows an example of a Solution.
The system sets the status of the record to DRAFT. The user name of the logged-in user is displayed in the Solution Author field and an automatic ID is generated in Solution field. Other important fields are:

- **Description**: A summary of the solution.
- **Classification**: A classification helps users narrow the search for an appropriate solution.
- **Type**: Enter a type (for example, FAQ) that you can use to group similar types of solutions. Users can filter a list of solutions by type to narrow the search for an appropriate solution.
- **Self-Service Access?**: Select it to display the solution to the customer users.
Customer: Associate the solution with the customer. In this case, the customer is REDBOOKCUS-A.

Symptom: Describe the customer question or problem.

Cause: If appropriate, describe the one or more causes of the problem.

Resolution: Answer the question or explain how to solve the problem.

User Comments: The users can send a feedback using this field.

Keywords: Users can search for solutions based on keywords added in this field. It can make the search function easier.

Change the solution status to ACTIVE by clicking Change Status. It allows other applications and customer users to gain access to the solution record.

Tip: Use Number of Hits, Times applied by Self Service, and User Comments information to evaluate if the solution is useful.

Setting up a Service Level Agreement
Responsible role: Maximo Administrator

The Service Level Agreement (SLA) used for this scenario is based on Internal Priority of the service request. It sets the target to finish as 24 hours for resolution and will be applied automatically by the Response Plan. It also sends a notification to the person group owner when the target finish time is reached.

To set up the SLA:
1. Create a new SLA.
2. Add a Commitment with the values:
   - Type: RESOLUTION
   - Value: 24
   - Unit of Measure: HOURS
3. In the Commitment row, click Define Escalation, as shown in Figure 4-3 on page 84.
The escalation tab is displayed and defaults the information in the Escalation and Escalation Points table windows from the SLA.

4. Change the schedule and condition values as needed, and make sure the Escalation Points table window is configured, as shown in Figure 4-4.

5. Add a Communication Template for this Escalation Point that must notify the person group owner.

6. Click the Conditions tab, and complete the SLA criteria with Internal Priority EQUALS 3.

7. Click Select Action → Associate Customer, and add REDBOOKCUS-A customer.

8. Click Change Status, and select ACTIVE. When the SLA is activated, the system automatically changes the status of the escalation to ACTIVE. If you change the SLA status to INACTIVE, the system displays a message asking whether you want to change the associated escalation to INACTIVE.

9. Click Save SLA.
Setting up a response plan
Responsible role: Maximo Administrator

A response plan automates the processing of a service request or a work order. In this section, the Response Plan is configured to automate certain actions that the Service Desk Analyst manually completes:

1. Assign an owner group, and change the service request status to QUEUED.
2. Send a notification to the owner of the person group assigned.
3. Apply a SLA.

A basic configuration of a Response Plan is in Chapter 3, “Initial configuration” on page 25. The following steps describe how to configure a Response Plan to make the three actions we just listed.

1. Create a new response plan.
2. In the Response Plan tab, complete the following fields:
   - Applies To: service request
   - Ranking: 10
   - Assign Owner Group: NETWORK

   Figure 4-5 on page 86 shows the Response Plan tab.
3. In the Conditions section, specify the classification to use as a condition to apply the Response Plan. In this case, the classification must be related to Network issues, such as End User Issue \ Network.

4. Save the record.

5. Click the **Response Actions** tab, click **New Row**, and Add the existing action:
   - **SR_APPLYSLA**: apply SLA to SR

There are several out-of-the-box actions you can use in your Response Plan. You also can create new actions, for example, to fill in Service Group field.

Also, add a Communication Template in the Notifications table window. It must be sent to the person group owner. This notification ensures that the owner group assigned is aware about the service request.

Figure 4-6 on page 87 shows the Response Actions tab with Apply SLA action and the notification that we previously mentioned.
6. Click **Select Action → Associate Customer** and add REDBOOKCUS-A customer. The Response Plan is available only for service requests from REDBOOKCUS-A customer.

7. Save the record again.

8. Click **Change Status → Active**.

**Service Desk escalations**

Responsible role: Maximo Administrator

There are several predefined escalations recommended by best practices. These escalations automate important actions, such as sending a notification to the user when the service request is resolved. By default, the predefined escalations are not active.

The Table 4-2 on page 88 shows three Escalations you must activate for this scenario. As an administrator, you can change the default behavior provided by the product, for example, the ESCSRCLS10 escalation, which triggers a notification 10 days after a service request is resolved, can be re-configured to a different number of days.
**Table 4-2  Predefined automatic notifications for the Service Request application**

<table>
<thead>
<tr>
<th>Escalation</th>
<th>Description</th>
<th>Automatic notification</th>
<th>Communication template</th>
</tr>
</thead>
<tbody>
<tr>
<td>ESCSRRES</td>
<td>Notify that service request is resolved</td>
<td>This communication is automatically sent to the Reported By and Affected Person users within one day after the SR status changes to RESOLVED.</td>
<td>CTSRRES</td>
</tr>
<tr>
<td>ESCSRCLS</td>
<td>Notify that service request is closed</td>
<td>This communication is automatically sent to the Reported By and Affected Person users within one day after the service request status changes to CLOSED.</td>
<td>CTSRCLS</td>
</tr>
<tr>
<td>ESCSRCLS10</td>
<td>Close service request in resolved state for 10 days or more</td>
<td>After a SR has been in RESOLVED status for 10 or more days, the SR is automatically changed to CLOSED status and this communication is sent to the Reported By and Affected Person users within one day after the SR is closed. The ESCSRCLS and ESCSRCLS10 escalations are coordinated so that only one notification is sent in case of a conflict.</td>
<td>CTSRCLS10</td>
</tr>
</tbody>
</table>
4.4.3 Service Desk process

After the applications involved in this scenario are configured, the customer can work with the solutions or open a service request, and the Service Desk Analyst and Resolver Specialist can attend and resolve the tickets using the best practices provided by the system.

Searching for a solution
Responsible role: You

The first need for the customer is finding an instruction or a solution for using the Search Solution application (Go To → Service Desk → Service Request → Search Solutions or click the Search Solution link available on the Start Center).

Search Solution application lists all the solutions available for the customer REDBOOKCUS-A. You can navigate through the View Solutions table window looking for a solution that might fit with your doubt or issue, or you can filter the results by using search solution fields. The better way to search a solution is typing a description in the Solution Description field or some keywords in the Keywords field. It is also possible to search a solution based on its classification.

Note: If you need to remove the classification, click Detail Menu → Clear Classification. The system clears the values in the Classification and Description fields.

Figure 4-7 shows an example of the Search Solution view.
Whether the solution is useful or not, you can rank it in the User Comments section, as shown in Figure 4-8.

![User Comments](image)

**Figure 4-8  Ranking a solution**

**Submitting a service request**

Responsible role: Customer User

If you do not find a solution for your issue, click the **Create Service Request** link. If the solution you found did not resolve your issue, click **No - Create a Service Request**.

The system creates a service request and enters your user name in the Reported By and Affected User fields. If you are reporting an issue on behalf of someone else, the Affected User field. Enter as much information as possible to help the service desk analyst validate your issue more quickly.

Typically, you enter information in these fields:

- Asset or Location
- Configuration Item
- Reported Priority
- Summary
- Details

Figure 4-9 on page 91 shows an example of a Service Request.
You also can attach documents or images useful for the Service Request. The easier way to attach print panels is using the Screen Capturer feature. When you click the Screen Capturer button, a new window is opened and allows you to take screenshots, crop the image, and save the image as an attachment. Figure 4-10 on page 92 shows the Screen Capturer window.
When you finish filling in the fields, click **Submit**. The system pops-up a message with the service request number. You can select options from the dialog box to view details of the service request, return to your start center, or create another service request.

**Viewing the service request updates**

Responsible role: Customer User

After you create a service request, you can check its status, view any communications or updates from the Service Desk Analyst / Resolver Specialist, and add information. To open the View Service Requests application, click **Go To** → **Service Desk** → **Service Request** → **View Service Request**, or click the **View Service Request** link available on the Start Center.

View all of your service requests that are open in the View Service Request table window and can filter them by using search fields. From this view, shown in Figure 4-11 on page 93, you can see the basic information of your service request, such as summary and status.
When you click the service request ID link, a new page is loaded with all of the details of your service request. From this page, you can:

- Add new attachments: Click Attach File, specify the file, and click OK.
- Add information: Click Add log Entry, type the summary and details, and click OK.
- View the updates from the Service Desk Analyst / Resolver Specialist: This information is displayed in the Log table window.

Figure 4-12 shows Attachments and Log table windows.
Validating the service request
Responsible role: Service Desk Analyst

The service requests can be monitored by the Service Desk Analyst using a Result set in the Start Center or List tab in the Service Request application. The security group of the Service Desk Analyst must have access to the customer (REDBOOKCUS-A) to be able to see the service requests. After the service request is submitted by the customer, the Service Desk Analyst must open it, complete the important fields, and apply the Response Plan. If the service request needs further information to be addressed and resolved, the customer can be contacted by phone, email, or by adding a communication in the Logs to the customer.

The most important fields that must be completed before applying the Response Plan and SLA are:

- Classification: Because this is not a required field, the customer can leave it blank or fill it in with an incorrect classification. It is important to have the correct classification because the Response Plan is based on its value to be applied. For our scenario, it must have End User Issue \ Network value.
- Internal Priority: This is a read only field, and is automatically populated based on Impact and Urgency values. The SLA is based on its value.

Note: The business rule for the Internal Priority is configured in the Priority Matrix application. For more information, refer to the information center website:


- Impact: The business impact or severity of the service request. For our scenario, type 3.
- Urgency: A reflection of the speed in which the service request is resolved. For our scenario, type 3.
- Site: Specifies the site of the customer.
- Customer: Identifies the customer. This value is based on the customer of the Affected Person. It must already be populated with REDBOOKCUS-A.

After you complete the fields in the bulleted list, click Select Action → Apply Response Plan. The system presents a message informing you that the status changed to QUEUED and the Response Plan was applied.
Notice that the Response Plan changed the following fields:

- Owner Group: The Network owner group has been assigned.
- Status: When an owner group is assigned, the workflow changes the status to QUEUED.
- SLA Applied?: This option indicates that a SLA was applied.
- Target Finish: The SLA set the target finish as 24 hours of resolution.
- Response Plan: Indicates the Response Plan ID applied.
- Communication Log: The notification configured in the response plan was sent and logged in this tab.

Figure 4-13 shows a service request with a response plan applied.

If an incorrect response plan was applied, it is possible to re-apply it. To do that, change the classification or whatever other condition field, and click Select Action → Apply Response Plan. To see the Response Plan history, click Response Plan detail menu → Show History.
Implementing IBM Maximo for Service Providers

Figure 4-14 shows the response plan history.

![Response Plan History](image)

**Working and resolving the service request**

**Responsible role: Resolver Specialist**

As the Service Desk Analyst, the Resolver Specialist can monitor the service requests assigned to its person group using the Start Center Result Set or the List tab in the Service Request application.

The following actions on the service request must be made by the Specialist who is working on it:

1. **Change the status to In Progress:** Use the *in Progress* status when you start working on the service request. To do this, click the **Change Status** or **Service Request in progress** icon, as shown in Figure 4-15.

![Changing the status to In Progress](image)

2. **Add a worklog:** The updates can be logged by adding new rows in the worklog tab. The worklog fields are:
   - **Type:** Select a type of log entry. For example, you can select WORK to log the work you are doing. The comments inserted by the Customer User in View Service Request application are logged as CLIENTNOTE type.
   - **Summary:** Short description of the work log entry.
   - **Details:** Long description of the work log. You can check the spelling of text that you enter by clicking **Long Description** next to the Summary field.
   - **Viewable?:** Specifies whether a Customer User can view this work log entry. It is usually selected when you need to request more information.
about the issue or to log your work progress. For internal communication or information that cannot be viewed by the customer, do not select this field.

Figure 4-16 shows an example of worklogs.

![Figure 4-16 Adding worklogs into the service request](image)

After the service request is saved, the only Viewable field is available to be changed in the Log tab. To change other fields of the work log or delete it, click **Select Action → Modify/Delete Work log**.

3. Resolve the service request: When the work on the service request is finished and the customer issue resolved, you must resolve the service request using the following steps:

   a. Enter the solution: In the Solution Details tab, you can select an existing solution that fits with this request or type a new one by filling in the Symptom, Cause, and Resolution fields. Select **Self-Service Access?** to leave the solution visible to the customer who opened the service request.

   b. Change the status to Resolved: Click **Change Status** or **Service Request Resolved**. The system send a notification to the reported by and affected person (ESCSRRES escalation) informing them that the service request was resolved.

The customer can add more information into the service request when its status is Resolved, for example, a feedback stating that the issue is still occurring. After 10 days (the period defined in the ESCRCLS10 escalation) the service request status will be changed to CLOSED and no more logs can be entered on it.

The Service Desk scenario is complete.
Assets and locations scenario

This chapter describes a business requirement where RedBookCustA must move your assets to another location inside the same customer. For this scenario, we use the Asset and Location applications.

In this chapter, the topics that we discuss are:

- 5.1, “Business requirements” on page 100
- 5.2, “Applications involved” on page 100
- 5.3, “Implementation” on page 100
5.1 Business requirements

The customer RedBookCus-A has two assets inside location A. The Service Provider company RedBooks Inc. moves these assets to location B, as requested by RedBookCus-A. In this chapter, we explain the steps required to accomplish this configuration for RedBookCus-A.

5.2 Applications involved

The applications that we use in this chapter are:

- Assets (SP)
- Locations (SP)

5.3 Implementation

We describe the steps required to implement this scenario. Using the assets (SP) and Locations (SP) applications.

The first step is to configure and create a relationship with assets and locations. After this is done, we can start to work with our assets.

5.3.1 Implementation steps

Execute the following steps to implement the scenario:

- Pre-configuration:
  - Basic configuration (customer, site)
  - Create a location
  - Create an asset
- Moving the assets:
  - Select the assets
  - Select the location
  - Apply the selected locations in Assets application and save the configuration
5.3.2 Pre-configuration

First a basic configuration is required for this scenario. Our Customer is RedBookCus-A and the Site name RedBook01.

Setting up an asset
As an asset Administrator, you can create a new asset from the asset application. To create a new asset, select Go To → Assets → Assets → New asset icon.

The system sets the asset’s status to NOT READY by default. You must enter the asset's name.

Other fields used are:

- Description: A summary of the solution.
- Parent: The asset's parent.
- Location: Location where the asset is located.
- Primary Customer: Associate asset with customer. Note that you can associate an asset with multiple customers, but only one will be the primary.
- Change the status to OPERATING using the Change Status icon.

5.3.3 Setting up a location

Location is the application used to set the location in asset. This helps the customer know where their assets are located.

To create a new location, select Go To → Assets → Location, and click New Location. See Figure 5-1 on page 102.
Implementing Maximo Service Provider

The system sets status field to OPERATING (read only). You cannot change this field.

Other fields used are:

- Location: The name or ID of the location
- Description: A description of the location
- Type: Operates when location is Working

Sub tab used are:

- Systems: System of the location
- Parent: Parent of the location
- Children: Children of the location

5.3.4 Moving the assets

After the applications involved in this scenario are configured, you can work with the assets. We show you how to move the assets.
Selecting the assets
To select the assets:

1. Open the Move Modify Assets application by selecting Go To → Assets → Assets (SP). Click Select Action → Move Modify Assets. See Figure 5-2.

Figure 5-2  Move/Modify Assets

Figure 5-3 on page 104 shows the Move Modify Assets View.
You must select the assets in the To Location field, and set the SHIPPING location for assets in location BPM3100. See Figure 5-4 on page 105.
Applying selected locations in assets and saving the record
After entering the SHIPPING location in To Location field, click Apply, and OK. See Figure 5-5 on page 106.
Implementing Maximo Service Provider

Figure 5-5   Load changes

**Figure 5-6 is displayed.**

**Figure 5-6   System message**

Now the asset is in the new location: SHIPPING.

In this scenario, we showed you how to move the asset from one location to another. Similarly we can move the parent or bin. We can also move multiple assets in one step.
Billing scenario

This chapter describes a typical scenario for the Maximo for Service Providers Billing system, using a service request. In this scenario case we use a fictitious company RedBooks Inc., which is a Service Provider company that is responsible for managing the IT assets of the Company A. RedBooks Inc. company has a subcontract with CompanyE for elevator maintenance.

The topics that we discuss in this chapter are:

- 6.1, “Business requirement” on page 108
- 6.2, “Applications involved in this scenario” on page 109
- 6.3, “Step-by-step implementation” on page 110
6.1 Business requirement

The RedBook Inc. has an agreement with CompanyA for maintaining the CompanyA’s head office building, which includes the elevator maintenance. The RedBooks Inc. does not do the elevator maintenance itself; instead, it subcontracts CompanyE for it.

The agreement between RedBooks Inc. and CompanyA specifies that the elevator repairs that are done at the São Paulo building of CompanyA has a markup of 30% over the service cost of elevator maintenance. The emergency repairs that are done at the São Paulo building of CompanyA has a markup of 100% over the service cost.

The RedBooks Inc. service desk gets a call from CompanyA reporting the problem with the elevator. A service request is created as a result of this call. This building elevator asset is configured as a high priority, which makes the service request to be reported as high priority.

RedBooks Inc. configured a response plan, called CUSARP1, for elevator maintenance at CompanyA's buildings that creates a work order based on the asset that is associated with the service request. The CUSARP1 specifies the work order vendor as CompanyE and applies a job plan for elevator maintenance. When the job plan is applied to the work order, a planned service is created on that work order. RedBooks Inc. has a workflow configured that creates and approves a purchase order (PO) for the service of this work order with a cost of $300.00, which is the value of the last price billed by CompanyE on the service of elevator maintenance, the workflow check if for the last purchase order on the elevator maintenance of CompanyE and it was in this financial period, so the workflow automatically approves this purchase order. The configured condition in the workflow automatically approves high priority purchase orders, if the total cost is more than $1000.00.

After approving the purchase order, the workflow changes the status of the work order to approved and sends an email to CompanyE, the workflow vendor, requesting a maintenance repair on the CompanyA elevator.

CompanyE receives an email with the work order details and sends a labor to fix the elevator. This email contains all of the details needed for the work order execution, including the service address, asset details, steps that for execution, and the tools that are needed to fix. Using this email informs CompanyE labor to go to the São Paulo building of CompanyA and execute the requested maintenance service.

After the elevator is fixed, CompanyE communicates to RedBooks Inc. that the service was executed and the work order can be marked as completed. All of the
details of the service execution is stored at the work order. RedBooks Inc. changes the status of the work order to completed and it is billed at the next CompanyA bill cycle.

The agreement between RedBooks Inc. and CompanyA established that the billing is monthly and contains all the services that are provided from RedBooks Inc. to CompanyA from the previous month, starting on the 2nd day of the last month and ending on the 1st day of the current month.

A bill batch is created for billing CompanyA at the 2nd day of each month. This batch contains all of the workorders, tickets, and sales order completed in the last month. This month's batch contains the work order for the elevator maintenance, which is billed at a price of $600.00.

CompanyA logs into the Maximo for Service Providers, accesses the Bill Review application, and reviews the billing details of what was billed. The information contained in the Bill Review(SP) application is related with the work order that is executed to fix the elevator, CompanyA agrees to pay $600.00 billed for the service and approves the bill review.

With CompanyA's bill review approval, the bill is ready to be submitted.

### 6.2 Applications involved in this scenario

The scenario described in this chapter uses the following Maximo for Service Providers applications:

- Customer (SP)
- Customer Agreement (SP)
- Price Schedule (SP)
- Service Request (SP)
- Response Plans (SP)
- Customer Billing (SP)
- Bill Review (SP)

We describe how to use each application in detail in this chapter.

Some of the Maximo Enterprise Asset Management applications are used to configure this scenario, which include:

- WorkFlow Designer
- Actions
- Purchase Requisitions
- Purchase Orders
- Receiving
These applications are not specific to Maximo for Service Providers and we do not discuss their use in this chapter. A detailed description of how to use this applications can be found at Maximo support web page:


6.3 Step-by-step implementation

In this section, we provide implementation steps for this scenario.

6.3.1 Creating a customer

In the Customer application, you can configure the CompanyA details. A description of how to create a customer is described in 3.2, “Customer (SP)” on page 29. You can access the Customer (SP) application by selecting Go To → Service Provider (SP) → Customer (SP).

6.3.2 Creating a customer agreement with a price schedule

The Customer Agreement application is where you can configure the agreement details. A description of how to create a customer agreement is in 3.14, “Creating customer agreements” on page 59. An image of the CompanyA agreement is shown in Figure 6-1 on page 111. This agreement is configured with a monthly billing cycle. The bill end day is set to 1, which makes the bill batch to select all work order, ticket, and sales order from the previous month, starting on day 2, until day 1 of the current month. You can access the Customer Agreement (SP) application by selecting Go To → Service Provider (SP) → Customer Agreement (SP).
The customer agreement was created using the data shown in Figure 6-1, with the following values:

- Agreement: RedBKCA-AG1
- Description: CompanyA Agreement
- Revision: 0
- Payment Terms: N30D
- Billing Cycle: MONTHLY
- Bill End Day: 1
- Customer: CompanyA
- Start Date: 19/06/10
- End Date: 19/06/11
- Status: Draft

**Note:** The customer agreement can be revised if you need to change the values in the price schedule of an approved customer agreement. When you create a new revision of a customer agreement, it has the status of Pending Revision. After changing this status to Approved, the previous revision status is changed to Revised.
Implementing IBM Maximo for Service Providers

In the Customer Agreement (SP) application, you insert the price schedule details. After creating the customer agreement, go to the Price Schedule tab, and click **New Row**.

The price schedule is part of the Customer Agreement (SP) application. In this scenario, we use a standard work order price schedule with a special price configuration for services. This scenario agreement contains two price schedules: one configured for high priority work orders and another configured for normal priority work orders. The difference between these two price schedules is in conditions and in price rules tabs. The data of the price schedule is shown in Figure 6-2.

![Price Schedule Detail for Schedule WOSCH ED](image)

**Figure 6-2  Price Schedule example**

This agreement contains two price schedules, one with high priority, which was configured as follows:

- **Price Schedule**: HIPRIO
- **Description**: High Priority Price Schedule
- **Applies To**: WORK ORDER
- **Ranking**: 4

**Tip:** The customer agreement can be applied to work order, tickets, and sales order only when it is in the Approved status.
At the Conditions section of the Conditions sub tab of the price schedule tab, the data was configured:

- Field Name: Reported Priority
- Condition: EQUALS
- Value: 2

At the Service sub tab, the price schedule tab was configured as shown in Figure 6-3 with this data:

- Default Calculation Percentage: 100.00
- Markup from Item Cost: true

**Note:** The Ranking field is used when applying a customer agreement to tickets, work orders, and sales orders. If more than one price schedule fit the conditions to be applied, the one with the lower ranking number is applied. If two or more of these price schedules have the same ranking value, the system select one of them.

The high priority price schedule has a condition configuration, shown in Figure 6-3, to match the high priority work orders. The conditions configuration is done at the Conditions sub tab of Price Schedule tab.

![Figure 6-3](image-url)  
**Figure 6-3** High priority condition configuration of a price schedule
The markup from item cost is configured in the Services sub tab of the Pricing Rules sub tab of the price schedule tab, as shown in Figure 6-4. The markup percentage is inserted at the Default Calculation Percentage field.

![Figure 6-4](image)

*Figure 6-4  Pricing rules configuration of Services in the high priority price schedule*

The second price schedule data was configured as follows:

- **Price Schedule:** WOSCHED
- **Description:** Normal Priority Price Schedule
- **Applies To:** WORK ORDER
- **Ranking:** 4

No conditions were configured for this price schedule. The configuration of the Pricing Rules sub tab is shown in Figure 6-5, and it was configured with the following data:

- **Default Calculation Percentage:** 30,00
- **Markup from Item Cost?:** true

![Figure 6-5](image)

*Figure 6-5  Pricing rules configuration of Services in WOSCHED price schedule*

After configuring the Price Schedule you must change the Customer Agreement status to approved, which you can do by selecting the **Change Status** option.
from the Select Action menu or clicking Change Status. A dialog is displayed, and you can change the customer agreement to Approved status.

6.3.3 Creating a response plan

Using the Response Plans (SP) application you can create a work order that is related to the opened service request. An example of how to create a response plan is in 3.15, “Creating a response plan” on page 66. You can access this application by clicking Go To → Service Provider (SP) → Response Plans (SP).

Note: We do not describe the configurations of actions used in the Response Plan (SP) application. For more information about Action application you can access:


The actions of this response plan contains actions for creating a work order and sets its vendor to CompanyE.

The response plan used in this use case is shown in Figure 6-6.

![Figure 6-6  Response plan example](image)

The values used in this response plan are:

- Response Plan: CUSARP1
- Description: Customer A high priority response plan
- Status: ACTIVE
- Applies To: SR
- Ranking: 3

Tip: To change the response plan status, you must choose the Change Status action on the Select Action menu, or select Change Status on the Toolbar menu.

After creating the response plan, you must associate it with a customer. This can be done by selecting the Associate Customer from the Select Action menu, as shown in Figure 6-7 on page 116.
To configure this response plan to be applied to high priority service requests, add a condition to it. Go to the Conditions section of the Conditions tab. This condition is similar to the one described in 6.3.2, “Creating a customer agreement with a price schedule” on page 110.

6.3.4 Creating a service request

The Service Request application is used by the service desk of RedBook Inc. to handle its clients’ calls. This application contains details about the service request, including, the person information that was reported with the service request, the summary and the service request details, asset, location, customer, the reported date, and the target date. In the Related Records tab, you can create tickets, work orders and solutions that are related to this service request. In the scenario described here, the response plan, applied to this service request, creates a work order related to the service request. The example
service request is shown in Figure 6-8 and Figure 6-9. You can access the Service Request (SP) application by selecting **Go To → Service Desk → Service Request (SP)**.

![Information table]

**Figure 6-8**  Service Request: Details, asset, location and customer details

![Affected Person table]

**Figure 6-9**  Service Request affected person and priority details
The service request was configured with the following data:

- Affected Person/Reported By: CUSA
- Name: CustomerA (CompanyA) São Paulo Building Manager
- Phone: 11111111
- Email: Customeraa@us.ibm.com
- Summary: Broken Elevator
- Details: The elevator of the CompanyA São Paulo Building has stopped. The client reported that the elevator was working properly yesterday, but today, when the employees of São Paulo building arrived at work, they noticed that the elevator was not working. The elevator was stopped at the 1st floor with the door open.
- Asset: CASPBELEV
- Location: CASPB
- Site: Bedford

After creating the service request, you must apply a response plan to it, which you can do by selecting **Apply Response Plan** from the Select Action menu, as shown in Figure 6-11 on page 119. A confirmation message is shown in the toolbar when the response plan is applied, as shown in Figure 6-10.

![Figure 6-10  Apply Response plan confirmation message](image)
6.3.5 Creating a customer billing

The Bill Batch (SP) application is used to calculate the prices of all completed tickets, work orders, and sales orders, related to a specific customer agreement. You can access the Bill Batch (SP) application by selecting Go To → Service Provider (SP) → Customer Billing (SP).

The bill batch was created with the following data:

- Bill Batch: CABB5
- Customer: REDBOOKCUS-A
- Agreement: RedBKCA-AG1
- Bill End Date: 01/07/2010

When the agreement is set, the date is automatically configured for the first day of the actual month, which in this case is 01/07/2010. After creating the customer billing and saving it, click Copy WO’s, Tickets and SO’s to copy all of the not yet billed, but completed work orders, tickets, and sales orders from the agreement. Each work order, ticket, and sales order is placed as a line in the Bill Batch
Lines, and their details are on the sub tabs of this section. At the Pre Tax Total field, there is the total value of each line in this customer billing. The customer billing details are shown in Figure 6-12. The Bill Price is editable for any necessary adjustments. After reviewing this billing, you change its status to PREBILL so this billing is shown in the Bill Review (SP) application.

In the Bill Review application, the customer can see the details of the billing, as shown in Figure 6-13 on page 121. The bill review application can be accessed by clicking Go To → Service Provider (SP) → Bill Review (SP).

The customer can review the billing and approve or dispute each line of the bill review. If the customer approves the lines of this billing, the billing is ready to be billed; otherwise, the customer can dispute the billing and this agreement and the disputed lines are not billed until the customer and the Service Provider achieve an agreement.
Figure 6-13  Bill Review details
Customer agreement scenario

This scenario describes the customer agreement between RedBooks Inc., the Service Provider and RedBookCus-A. RedBook Inc. provides building management services to RedBookCus-A. Pricing rules are applied to work orders containing items and services items. A customer billing is generated, containing this work order and its transactions.

In this chapter, the topics we discuss are:

- 7.1, “Business requirements” on page 124
- 7.2, “Applications involved” on page 124
7.1 Business requirements

RedBooks Inc. is providing building management services to RedbookCus-A. Redbooks Inc. has a published price list for items that are used in repairs. The agreement between RedBooks Inc. and RedbookCus-A specifies that items used in non-emergency repairs are priced with a 15% discount from list price. Items used in emergency repairs are billed at list price. This agreement also specifies that services periodically performed to maintain elevators at RedbookCus-A Center are charged at a 40% markup.

7.2 Applications involved

The following applications are used in this scenario:
- Customer Agreements (SP)
- Item Master (SP)
- Work Order Tracking (SP)
- Purchase Requisitions
- Purchase Orders
- Receiving
- Customer Billing (SP)
- Bill Review (SP)

7.3 Step-by-step implementation

In this section, we describe the step-by-step implementation of this scenario:

7.3.1 Creating a customer agreement with price schedules

You can access the Customer Agreement (SP) application by selecting Go To → Service Provider (SP) → Customer Agreement (SP).

A customer agreement is created using the following data, as shown in Figure 7-1 on page 125.
- Customer Agreement: CARBCUS-A.
- Description: RedbookCus-A Customer Agreement.
A price schedule is created (3.14.1, “Pricing rules” on page 62) using this data, as shown in Figure 7-2 on page 126:

- Schedule: PSWO’01
- Description: Price Schedule - Non-Emergency
- Applies To: WORK ORDER
- Ranking = 20
On the Conditions tab, enter Included Services, as shown in Figure 7-3:

- Services: NONEMERG Non-Emergency Repairs.
On the Pricing Rules tab, select the **Materials** tab, as shown in Figure 7-4 on page 127:

- Default Calculation Percentage for stocked items: -15.00
- Discount from List Price is selected

![Figure 7-4 Materials tab](image)

On the Pricing Rules tab, select the **Services** tab, as shown in Figure 7-5:

- Service Group: FACILITY Facilities Maintenance Services
- Service: ELEVATOR Elevators
- Calculation Percentage: 40.00
- Markup from Item Cost is selected

![Figure 7-5 Services tab](image)

Another price schedule is created, as shown in Figure 7-6 on page 128:

- Schedule: PSWO’02
- Description: Price Schedule - Emergency
- Applies To: WORK ORDER
- Ranking = 10
On the Conditions tab, enter Included services, as shown in Figure 7-7:

- Services: EMERG Emergency Repairs.

On the Pricing Rules tab, select the Materials tab, as shown in Figure 7-8 on page 129:

- Default Calculation Percentage for stocked items: 0.00
- Discount from List Price is checked
Change the status of the customer agreement to APPROVED.

### 7.3.2 Creating the work order for non-emergency repairs

You can access the Work Order Tracking (SP) application by selecting **Go To** → **Work Orders** → **Work Order Tracking (SP)**.

A work order is created with the following parameters:

- **Work Order:** RB’001
- **Description:** Work order for Non-Emergency repairs
- **Location:** RBCUS-A RedbookCus-A Location
- **Service Group:** FACILITY Facilities Maintenance Services
- **Service:** NONEMERG Non-emergency repairs

**Note:** Location RBCUS-A has a primary customer, REDBOOKCUS-A RedBook Customer A. When entering the location, the customer field is automatically populated.

The customer agreement CARBCUS-A with price schedule PSWO’01 - Price Schedule - Non Emergency is applied to the work order by clicking **Select Action - Apply Customer Agreement** or **Select Action - Select / Deselect Price Schedule**. A list of eligible price schedules for the customer mentioned on the work order is displayed. See Figure 7-9 on page 130.

When planning the items and services that will be used and done in this work order, line prices are calculated according to the pricing rules applied.

In Figure 7-9 on page 130, the item 29331 - Building Thermostat has:

- **Unit Cost:** 50.00 dollars.
- **List Sales Price:** 70.00 dollars.
- **Line Price** is calculated according to the pricing rule: Discount from List Price as -15.00 percentage, resulting in 59.50 dollars.
In Figure 7-10 on page 131, the service ELEV - Elevator Repair Service has:

- Unit Cost: 1,000.00 dollars.
- Line Price is calculated according to the pricing rule: Markup from Item Cost as 40.00 percentage, resulting in 1,400.00 dollars.
After planning all labors, items, services, and tools that are necessary in this work order, change the status to APPROVED. When executing the work order, select the reserved item, as displayed in Figure 7-11.
**Note:** The reorder process is done by going to the Inventory application, and selecting **Select Action → Reorder → Reorder Direct Issue Itms / Svcs.**

Running the reorder, a purchase requisition is generated containing the Service you planned.

After approving the purchase requisition by clicking **Select Action → Create PO**, the requisition is executed and the Purchase Order - PO is generated containing the information about the purchase requisition.

In the PO, enter the company and the subcontractor that executes the service. After entering all of the necessary information, approve the PO.

In the Receiving application, select the PO and receive the service.

For detailed information, refer to Chapter 6: Purchasing in the *Certification Study Guide Series: IBM Maximo Asset Management V7.1*, SG247761 IBM Redbooks publication.

The service is now displayed in the work order. See Figure 7-12.

![Figure 7-12   Work order in execution with a service item](image)
Now you can COMPLETE the work order by changing the status.

### 7.3.3 Creating the work order for emergency repairs

A similar process for non-emergency repairs is done for emergency repairs.

A work order is created with the following parameters:

- **Work Order:** RB’002.
- **Description:** Work Order for Emergency repairs.
- **Location:** RBCUS-A RedbookCus-A Location.
- **Service Group:** FACILITY Facilities Maintenance Services.
- **Service:** EMERG Emergency Repairs.

The customer agreement CARBCUS-A, with price schedule PSWO’02 - Price Schedule - Emergency, is applied to the work order by selecting **Select Action** → **Apply Customer Agreement** displayed in Figure 7-13.

![Select Action](image.png)

*Figure 7-13 Customer Agreement application: Select Action menu*

Another way to apply a customer agreement is to select **Select Action** → **Select/ Deselect Price Schedule**, as displayed in Figure 7-14 on page 134, and a list of eligible price schedules for the customer mentioned on the work order is displayed.
When planning items and other necessary things that will be used or done in this work order, line prices are calculated according to the pricing rules that are applied.

On the Plans tab, enter the item 29331 - Building Thermostat.

- Unit Cost: 50.00 dollars
- List Sales Price: 70.00 dollars
- Line Price is calculated according to the pricing rule: at List Price, resulting in 70.00 dollars

Approve the work order, and select this reserved item on Actuals tab / Materials tab. Execute all necessary work, and now you can COMPLETE the work order.

### 7.3.4 Creating the customer billing and bill review

You can access the Customer Billing (SP) application by selecting **Go To → Service Provider (SP) → Customer Billing (SP).**

The customer billing is created by entering the following values, as shown in Figure 7-15 on page 135:

- Bill Batch: BBRBCUS-A
- Description: RedbookCus-A Customer Billing
- Customer: REDBOOKCUS-A - RedBook Customer A
- Agreement: CARBCUS-A

**Note:** Bill End Date is automatically fulfilled because we entered the billing cycle as MONTHLY and marked End of Bill Cycle in the customer agreement.
To bring all the records to be billed by the Bill End Date, click **Copy WOs, Ticket and SOs**.

In this scenario, RB’001, work order for non-emergency repairs, and RB’002 work order for emergency repairs, are displayed in Bill Batch Lines, as displayed in Figure 7-16.

You can see each transaction contained in the bill line, by switching tab-by-tab: Labor, Materials, Services, Tools and Fees and Charges.

For each transaction the following information is displayed, as shown in Figure 7-17:

- Line Cost
- Line Price
- Bill Price

After reviewing all bill lines and transactions, you can send this billing to be reviewed by the customer, by changing its status to PREBILL for Customer.

Then, this customer billing will be available in the **Go To → Service Provider (SP) → Bill Review (SP)** application.
The customer, in this case RedbookCus-A, has the chance to Approve or Dispute each bill line.

**Note:** In general, the quantity of disputed bill lines is less than the approved ones. To optimize this process, the customer must dispute all lines he judges as necessary, and then click **Select Action → Advance all WAPPR Lines to APPR.** All lines waiting for approval can be changed to approved just by calling this action.

After reviewing the billing, the customer must change the status to REVIEWED by Customer.

This process can go back and forth between Redbooks Inc., the Service Provider, RedbookCus-A, and the customer until the customer billing reaches the status BILLED.
Migration Manager scenario

This chapter provides the necessary steps to migrate the Service Level Agreements (SLA) and Response Plan objects from the source environment to the target environment.

In this chapter, the topics that we discuss are:

- 8.1, “Business requirements” on page 138
- 8.2, “Applications involved” on page 138
- 8.3, “Introduction” on page 138
- 8.4, “Benefits” on page 139
- 8.6, “Step-by-step implementation” on page 145
8.1 Business requirements

Suppose you developed a series of Service Provider Service Level Agreements (SLA) and Response Plans. These objects were developed and tested in a development environment. After the tests are done, you must migrate them to the test environment for new tests. Later, it is necessary to have the tested SLAs and Response Plans objects migrated to the production environment so they can be used by the system users. Migration Manager is used in this kind of scenario.

8.2 Applications involved

The following applications are used in this chapter:

- Migration Manager
- Migration Groups
- Object Structure
- Response Plan (SP)
- SLA (SP)

8.3 Introduction

Introduced in IBM Maximo Enterprise Asset Management 7.1 release, Migration Manager is a suite of three applications found as part of the System Configuration module of Tivoli Process Automation Engine and grouped into a sub-module called Migration. It enables a structured set of steps to promote client's configurations from the source environment to the target one. See Figure 8-1 on page 139.
Migration Manager can be used to promote new fields, relationships, domains, workflows, escalations, window changes and many other configuration changes from the development environment to the test environment and then through to the production environment, for example.

8.4 Benefits

The correct use of this tool reduces the time spent during implementation of the IBM Maximo for Services Providers because it gives you the opportunity to migrate useful data that is needed in every environment that you install IBM Maximo for Services Providers. More than just copying the SLAs and Response Plans from one environment to the other, your data is validated. It means that all of the validation rules that are applied when you create or edit a SLA or response plan are executed too so to have all of the IBM Maximo for Services Providers rules guaranteed.
In IBM Maximo for Service Providers 7.1.1.2, migration objects and groups are added to the Migration Manager framework to accommodate the Service Provider SLAs and Response Plans applications. The migration groups for SLAs include the SLAs, Key Performance Indicators (KPIs), SLA Contracts, Commitments, Service Groups, and Conditions. The migration groups for response plans include the response plan, Service Groups, and Conditions. These groups can be duplicated and modified so that other objects are included in the migration.

8.5 Migration Manager components for IBM Maximo for Service Providers

In IBM Maximo for Service Providers 7.1.1.2, migration objects and groups are added to the Migration Manager framework to accommodate the Service Provider SLAs and Response Plans applications. The migration groups for SLAs include the SLAs, Key Performance Indicators (KPIs), SLA Contracts, Commitments, Service Groups, and Conditions. The migration groups for response plans include the response plan, Service Groups, and Conditions. These groups can be duplicated and modified so that other objects are included in the migration.

8.5.1 Migration Manager

To access the application used to manipulate the package definitions, select Go To → System Configuration → Migration → Migration Manager. In this application, there is a package definition called PLUSPSERVICEPROVIDER, as shown in Figure 8-2.

Figure 8-2  The Migration Manager application: Package Definition tab
To have full control over a package definition, we suggest you duplicate the existing PLUSPSERVICEPROVIDER, or create a new one using the existing migration group.

8.5.2 Migration Groups

Click **Go To → System Configuration → Migration → Migration Groups** to access the application created to manipulate migration groups. In this application, there is a group called PLUSPSERVICEPROVIDER. See Figure 8-3.

![Figure 8-3 The Migration Group application](image)

A migration group is a collection of migration objects. In the Migration Group tab of the application, inside the table Migration Objects are the DMPLUSPSLA and DMPLUSPRP objects. You can add or remove objects inside this table, for example, if you want to migrate only the SLA objects, you can remove the DMPLUSPRP and keep the DMPLUSPSLA migration object only.

8.5.3 Object structures

The Object Structures application is under **Go To → System Configuration → Migration → Object Structures**. This application is used to manipulate the structure of the migration objects. A migration object is a group of one or more related business objects that represent one or more database tables.

When you install IBM Maximo for Service Providers two objects structures are automatically created.
SLA object structure

Table 8-1 lists the DMPLUSPSLA, Figure 8-4, which is the object created to migrate the tables.

Table 8-1   The DMPLUSPSLA related objects

<table>
<thead>
<tr>
<th>Table</th>
<th>Parent Object</th>
<th>Relationship</th>
</tr>
</thead>
<tbody>
<tr>
<td>SLA</td>
<td></td>
<td></td>
</tr>
<tr>
<td>LONGDESCRIPTION</td>
<td>SLA</td>
<td>DMSLALONGDESC</td>
</tr>
<tr>
<td>PLUSPAPPLSERV</td>
<td>SLA</td>
<td>PLUSPAPPLSERV</td>
</tr>
<tr>
<td>PLUSPAPPLCOND</td>
<td>SLA</td>
<td>PLUSPAPPLCOND</td>
</tr>
<tr>
<td>SLACOMMITMENTS</td>
<td>SLA</td>
<td>SLACOMMITMENTS</td>
</tr>
<tr>
<td>SLAKPI</td>
<td>SLA</td>
<td>SLAKPI</td>
</tr>
<tr>
<td>SLACONTRACT</td>
<td>SLA</td>
<td>CONTRACTRECORDS</td>
</tr>
</tbody>
</table>

Figure 8-4   The DMPLUSPSLA object structure

Figure 8-4 shows the DMPLUSPSLA object structure. The following objects that SLAs are dependent on must either be migrated separately, be transferred to the target environment, or entered manually in the new environment:

- Calendars, ClassStructures, Organizations and Sites used by the SLA object
- Escalations referenced by the SLA object
- KPIs used by object SLAKPI
- Service Groups and Services used by object PLUSPAPPLSERV
- Descriptive Names (PLUSPAPPLFLD) used by object PLUSPAPPLCOND
The SLAs in the source environment are filtered by status so that only Inactive SLAs are migrated. After migration occurs, the SLA in the target environment is always Inactive.

The following information is not included in the migration of SLAs:

- The KPIs used to measure SLA commitments of type OTHER
- The Related SLA relationship
- Additional SLA criteria
- Attached documents
- Locations
- Assets
- Configuration Items

**Response plan object structure**

The DMPLUSPRP is the object created to migrate the tables that are listed in Table 8-2.

Table 8-2  The DMPLUSPRP related objects

<table>
<thead>
<tr>
<th>Table</th>
<th>Parent Object</th>
<th>Relationship</th>
</tr>
</thead>
<tbody>
<tr>
<td>PLUSPRESPLPLAN</td>
<td>PLUSPRESPLPLAN</td>
<td>DMRPLONGDESC</td>
</tr>
<tr>
<td>LONGDESCRIPTION</td>
<td>PLUSPRESPLPLAN</td>
<td>PLUSPAPPLSERV</td>
</tr>
<tr>
<td>PLUSPAPPLSERV</td>
<td>PLUSPRESPLPLAN</td>
<td>PLUSPAPPLCOND</td>
</tr>
<tr>
<td>PLUSPAPPLCOND</td>
<td>PLUSPRESPLPLAN</td>
<td>PLUSPAPPLCOND</td>
</tr>
</tbody>
</table>
Figure 8-5 shows the DMPLUSPRP object structure.

The following objects that response plans are dependent on must either be migrated separately, be transferred to the target environment, or be entered manually in the new environment:

- Calendars, Job Plans, Ticket Templates, Person Groups, Companies, Solutions, and ClassStructures used by the object PLUSPRESPLAN
- Service Groups and Services used by object PLUSPAPPLSERV
- Descriptive Names (PLUSPAPPLFLD) used by object PLUSPAPPLCOND
- Cron Tasks used by the object ESCALATION
- Escalations, and the Actions, Action Groups, and Communications Templates used by the Escalation.
- Roles and Ticket Templates used by the object ESCNOTIFICATION

**Note:** See more details about the migration of the mentioned objects in the *Migration Manager Guide* at:


The source response plans are filtered by status so that only inactive response plans are migrated. The target response plan status must always be Inactive.
The following information is not included in the migration of response plans:

- Attached documents
- Locations
- Assets
- Configuration Items

8.6 Step-by-step implementation

In this section, we describe the steps required to implement this scenario.

8.6.1 Prerequisites

After you define the source and the target environments, make sure that all of the object records, related to each SLA and response plan that will be migrated, are already migrated/copied to the target environment. The list of the object is mentioned in the previous section.

The migration tool will consider only the SLAs and response plans that have the status Inactive in the source environment. For more details about creating and changing the status of the SLA or response plan.

8.6.2 Working in the source environment

The migration process in the source environment starts at the Migration Manager application. To access this application:

1. Select **Go To → System Configuration → Migration → Migration Manager**. In this application, you can create new Package Definitions or duplicate the existing one called PLUSPSERVICEPROVIDER, which was created during the Service Provider installation.

2. If you duplicate the existing Service Provider package definition, in the Package Definition tab you will see a table called Migration Groups with a PLUSPSERVICEPROVIDER group in it. Click **Set Where Clause** for this row to open a Set Where Clause dialog box used to define a where clause that will restrict the set of primary records to be migrated. In our case, we have the primary records SLA and response plan. You can enter the where condition in the Where Clause field or define the condition using the SQL Expression Builder. See Figure 8-6 on page 146.
3. Create the folder that will be used to store a compressed file containing all the information generated by the Migration Manager framework based on your source database. Click Manage Targets, and populate the dialog with the Target Name, “Type” = FILE and in the “Database URL or File Path” fill with the full path of the folder that will be used to store the file that will be generated. See Figure 8-7 on page 147.
Figure 8-7   The Manage Targets dialog box

4. After you have the Target created, go to the Distribution tab, click New Row in the Distributions table, and select the Target that you created. See Figure 8-8.

Figure 8-8   Migration Manager application - Distribution tab
5. Save the Package Definition, and change the status to Approved. A warning message is displayed informing that this package contains user-defined migration objects. If you previously migrated the related objects mentioned in previous sections, you can click Yes and proceed.

6. Activate the Package Definition. Go to the Select Action field, and select the option **Activate/Deactivate Package Definition**, as shown in Figure 8-9.

![Figure 8-9   The select action Activate/Deactivate Package Definition](image)

7. Create the package. From the Package menu, click **Create**. A warning message is displayed. Click Yes. The Upload Compiled Source dialog box is displayed. Because IBM Maximo for Service Providers does not use Compiled Sources for the SLA and response plan migration, click **Continue**, as shown in Figure 8-10 on page 149.
8. When the dialog closes a new processing dialog opens indicating that the package creation is being executed. After the process is finished, you will see a dialog indicating that the package was created successfully, as shown in Figure 8-11 on page 150.
9. Click **OK** in the dialog. A new row in the Packages table is displayed with the *Created package*. See Figure 8-12 on page 151.
10. Now you need to have the created package stored in the target folder that you defined earlier. Click **Distribute**, select the Target folder that you want to use to distribute your package, and click **OK**.

**Figure 8-12  The package is created**
11. When the distribution process is finished, you will see a dialog box indicating that it was distributed to the target folder successfully, as shown in Figure 8-14.

Now your job is done in the source environment. You will use the created file inside the distribute folder to migrate the containing SLA and response plan records to the target environment.
8.6.3 Working in the target environment

After you have the file generated from the source environment with the SLAs and response plans and checked that all of the pre required information was already created and migrated in the target environment, you can start the migration of the SLAs and response plans. It is necessary that you create a backup of your target database because records will be changed and created in your target environment:

1. The migration process in the target environment starts at the Migration Manager application. To access this application, click Go To → System Configuration → Migration → Migration Manager.

2. Upload the package file generated in the source environment. Click Select Action → Upload Package. It will open a dialog box where you must specify the package file that was distributed in the source environment. After you select the file, click OK. A message is displayed to confirm that the file was successfully uploaded, as shown in Figure 8-15.

![Figure 8-15](image)

3. Deploy the uploaded package. Click Select Action → Deploy Package. A dialog box opens, and you will see inside the package table that you just uploaded. After you have a backup of your database, select the Do you have a current backup? option, and click Deploy, as shown in Figure 8-16 on page 154.
4. An Electronic Signature Authentication dialog box opens. Enter the password and the reason for the change, and click **OK**.

A process dialog is displayed. After the package is deployed, you will see the summary of the process in a dialog, as shown in Figure 8-17.

5. After you click **OK**, you will see that a new Package Definition is created. In the Package tab of this Package Definition, you will find the status history of this package, and in the Messages tab you will see the messages displayed during the deployment of the package.
After it is done, you can go to the SLA and response plan applications and check the records that were created or updated. Remember that all of the migrated records have the Inactive status.
Preventive maintenance scenario

This chapter describes the implementation of a common preventive maintenance requirement, where we have a customer (REDBOOKCUS_A) that has a monthly preventive maintenance for the HVAC in the REDBOOKLOC_A location.

In this chapter, the topics we discuss are:

- 9.1, “Business requirements” on page 158
- 9.2, “Applications involved” on page 158
- 9.3, “Implementation” on page 158
- 9.4, “The work order process” on page 166
9.1 Business requirements

The customer RedBooksCus_A needs a preventive maintenance (PM) to run every month and creates work orders for HVAC maintenance. These work orders have associated job plans to specify (labors, materials, so on) and also the work must be done in a timely manner.

9.2 Applications involved

The following applications are used in this chapter:

- Preventive Maintenance
- Work order Tracking (SP)
- Service Level agreements
- Customer Agreements (SP)
- Job Plans

9.3 Implementation

In this section, we provide step-by-step procedures for implementing the preventive maintenance scenario. The first step needed is configuring the features that are used. The second step is to use the Work order (SP) application to process the PM work order.

There are multiple roles that are involved in implementing this scenario:

- Maximo Administrator: Responsible to configure the applications
- Maintenance group: Responsible to process the work order
- Planner: Responsible to create work order job plans
- Work order approver: Responsible to validate and approve WO

In the next sections, we describe how each role performs the tasks they are responsible for.

9.3.1 Implementation steps

The implementation steps to complete this scenario are:

1. Pre-configuration
2. Create service level agreement
3. Create customer agreement
4. Create job plan  
5. Create PM  
6. Work order process  
7. Validate work order plan  
8. Apply SLA and customer agreement  
9. Report actual and complete work order

### 9.3.2 Pre-configuration

Maximo Administrator must configure all of the components that are needed for the PM work order process. Configuration must occur in the following order:

1. Basic configuration (customer, asset, so on)  
2. Job plan  
3. PM (preventive maintenance)  
4. SLA and customer agreement

#### Basic configuration

A basic configuration is required to set up the features that we describe in the next sections. Follow the instructions in Chapter 3, “Initial configuration” on page 25 to configure them. Make sure all the configurations are associated with the RedBookCus-A customer and that the user that you are using to access the Start Center has access to this customer.

#### Table 9-1 Basic configuration

<table>
<thead>
<tr>
<th>Object</th>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Customer</td>
<td>REDBOOKCUS _A</td>
<td>IBM Redbooks customer A</td>
</tr>
<tr>
<td>Asset</td>
<td>RDHVAC</td>
<td>RedbookCus_A HVAC System-50 Ton Cool Cap/ 450000 Btu Heat Cap</td>
</tr>
</tbody>
</table>

#### Creating the job plan

A job plan is a detailed description of work to be performed for a work order. You can copy job plans to PM records, routes, and directly to work orders. After a job plan becomes a work plan on a work order, you can modify the work plan without affecting the job plan.

As a Planner, you can create job plans using the Job Plans application. To create the job Plan:

1. Go to **Planning → Job Plans Application**, and from the toolbar, click New Job Plan. Enter the information in Table 9-2 on page 160.
2. In the Job plan tasks section, enter the tasks in Table 9-3.

<table>
<thead>
<tr>
<th>Job task</th>
<th>Task description</th>
</tr>
</thead>
<tbody>
<tr>
<td>10</td>
<td>Check Electrical Subsystems and components</td>
</tr>
<tr>
<td>20</td>
<td>Check Motor and Mounts</td>
</tr>
<tr>
<td>30</td>
<td>Check Filtration Units</td>
</tr>
<tr>
<td>40</td>
<td>Conduct Air Quality Chemical Tests</td>
</tr>
</tbody>
</table>

3. Under the Labor sub tab, enter the crafts in Table 9-4.

<table>
<thead>
<tr>
<th>Craft</th>
<th>Skill level</th>
</tr>
</thead>
<tbody>
<tr>
<td>MECH</td>
<td>FIRSTCLASS</td>
</tr>
<tr>
<td>ELECT</td>
<td>FIRSTCLASS</td>
</tr>
</tbody>
</table>

4. Change the status to ACTIVE.

The job plan will look like Figure 9-1 on page 161.
**Setting up preventive maintenance**

Preventive Maintenance (PMs) records are templates for scheduled preventive maintenance work. They generate preventive maintenance work orders. PMs contain job plan and corresponding safety plan information that the system copies to work orders.

As a Maximo Administrator, you can create PMs and associate a job plan.

To create new preventive maintenance:

1. Select **Preventive Maintenance → Preventive Maintenance** application, and from the toolbar, click **New PM**.
2. On the main tab, enter the information from Table 9-5 on page 162.
Table 9-5 Preventive maintenance information

<table>
<thead>
<tr>
<th>Field</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Description</td>
<td>HVAC maintenance</td>
</tr>
<tr>
<td>Asset</td>
<td>RDHVAC</td>
</tr>
<tr>
<td>Job plan</td>
<td>RDJOBPLAN</td>
</tr>
<tr>
<td>Work Type</td>
<td>PM</td>
</tr>
<tr>
<td>Priority</td>
<td>3</td>
</tr>
</tbody>
</table>

3. Change the status to Active. The preventive maintenance record will look similar to Figure 9-2.

Creating a service level agreement

A service level agreement (SLA) is a written agreement between a service provider and a customer that documents the agreed-upon levels of service. A service is a set of tasks provided by the service provider that fulfills one or more needs of the customer, and a service level (known as a commitment) describes a measurable or quantifiable aspect of that service.

As a Maximo Administrator, you can create SLAs.
To create a new SLA:

1. Click **Service Level → Service Level Agreements (SP)**, from the toolbar, click **New SLA**. Use the values in Table 9-6 to create the SLA.

*Table 9-6  Service Level Agreements*

<table>
<thead>
<tr>
<th>Field</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Description</td>
<td>RedbookCus_A SLA</td>
</tr>
<tr>
<td>Applies To</td>
<td>Work order</td>
</tr>
<tr>
<td>Ranking</td>
<td>1</td>
</tr>
<tr>
<td>Response Commitments</td>
<td>1 hour</td>
</tr>
<tr>
<td>Resolution Commitments</td>
<td>4 hours</td>
</tr>
</tbody>
</table>

2. Add the RDHVAC asset as a condition on the Asset tab.
3. Change the status to Active.

The SLA will look like Figure 9-3 on page 164.
And the Asset tab will look like Figure 9-4.
Setting up a customer agreement
The Customer Agreement (CA) contains the pricing information for all types of services that the service provider can provide to its customer.

As a Maximo Administrator, you can create a customer agreement:
1. Select Service Provider → Customer Agreement (SP) application, and click New Agreement.
2. Enter the information in Table 9-7.

<table>
<thead>
<tr>
<th>Field</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Agreement</td>
<td>RedBookCus_A Customer agreement</td>
</tr>
<tr>
<td>Applies To</td>
<td>Work order</td>
</tr>
<tr>
<td>Customer</td>
<td>REDBOOKCUS-A</td>
</tr>
</tbody>
</table>

3. Click New Row in the Price Schedules section, and enter the information from Table 9-8.

<table>
<thead>
<tr>
<th>Field</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Schedule</td>
<td>PS_A</td>
</tr>
<tr>
<td>Description</td>
<td>Price Schedule A</td>
</tr>
<tr>
<td>Applies To</td>
<td>Work order</td>
</tr>
<tr>
<td>Ranking</td>
<td>1</td>
</tr>
</tbody>
</table>

4. Add the RDHVAC asset as a condition on the Asset tab.
5. Under the Pricing Rules sub tab, click the Labor tab, and enter the information in Table 9-9.

<table>
<thead>
<tr>
<th>Field</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default Internal Markup Percentage</td>
<td>5</td>
</tr>
<tr>
<td>Default External Markup Percentage</td>
<td>7</td>
</tr>
</tbody>
</table>
9.4 The work order process

First, we generate the work order from the PM:

1. Select **Preventive Maintenance** → **Preventive Maintenance application**, and open the PM that you created.

2. From the Action Menu, click the **Generate Work Order** option.

3. Make sure that the **Use frequency criteria?** option is not selected, and click **OK**. The work order message appears with the new work order number, as shown in Figure 9-5.

![Figure 9-5 Work order created](image)

4. As a work order approver, open the work order to review the plan and validate the information. The work order looks like Figure 9-6 on page 167.
The Plans tab looks like Figure 9-7 on page 168.
The approver applies the SLA and customer agreement and changes the status to APPR. The work order will look like Figure 9-8 on page 169.
Maintenance department (WO Owner Group) opens the work order and starts processing it by changing the status to INPRG.

After finishing the inspection and the maintenance, they report the actual labor hours as planned, and they change the status to complete. The actuals will look like Figure 9-9 and Figure 9-10 on page 170.
After completing the work, the work order is now ready to be included in the Bill Batch. To view the costs and prices for this work order, from the Action Menu, click **View → Costs and Prices**. See Figure 9-11 on page 171.
Figure 9-11 Costs and prices
Security groups scenario

In this chapter, we provide the restrictions and permissions that you can set within the Customers tab in the Security Groups application.

The topics that we discuss in this chapter are:

- 10.1, “Business requirements” on page 174
- 10.2, “Applications involved” on page 175
- 10.3, “Step-by-step implementation” on page 175
10.1 Business requirements

Service Providers need a simple way to establish the security access rules for granting authority to customer information.

Security access in the Tivoli Process Automation Engine is controlled through security groups. By membership in security groups, users are granted authority for applications (including read, save, new and delete access), application actions, and data. By adding the Customers tab to the application, IBM Maximo for Service Providers (SP) provides a way to improve restriction/permission rules based on customer-related field associations to records. Figure 10-1 shows the Security Groups (SP) application.

Table 10-1 lists the customer based data restrictions.

<table>
<thead>
<tr>
<th>Option</th>
<th>Restriction/Permission</th>
</tr>
</thead>
<tbody>
<tr>
<td>Authorize Group for All Customer Information</td>
<td>The user has access to all customers and customer level data for all customers.</td>
</tr>
<tr>
<td>Authorize Group only for Unrestricted Customer Level Information</td>
<td>The User has access only to unrestricted customer level information.</td>
</tr>
</tbody>
</table>
10.2 Applications involved

To show how customer restrictions/permissions work, we use the following applications inside Tivoli Process Automation Engine:

- Customers (SP)
- Assets (SP)
- Users (SP)
- People (SP)
- Customer Agreements (SP)
- Problems (SP)
- Work Order Tracking (SP)
- Locations (SP)

10.3 Step-by-step implementation

We are going to walk you through these applications to show you how the data restrictions that are described in Table 10-1 on page 174 are implemented.

<table>
<thead>
<tr>
<th>Option</th>
<th>Restriction/Permission</th>
</tr>
</thead>
<tbody>
<tr>
<td>Authorize group for Customer on User's Person record</td>
<td>The user has access to customer data for the customer referenced on the user's person record. This is the customer referenced in the field Cust/Vendor. The user has no access to unrestricted customer-level objects. There is one exception, which is that the user has access to unrestricted Classification and Attribute records.</td>
</tr>
<tr>
<td>Authorize group for Customers in User's Person Customer Access List</td>
<td>The user has access to customer-level information for customers on the person's customer access list and to all unrestricted customer-level information.</td>
</tr>
<tr>
<td>Authorize Group for Customers listed below</td>
<td>The user has access to customer-level information for customers on the Security group's customer access list and to all unrestricted customer-level information.</td>
</tr>
</tbody>
</table>
10.3.1 Authorizing groups for customers on user’s person record

Mr. Brown is an employee of the RedBooks-CustA, one of the customers of RedBooks Inc., our Service Provider. Mr. Brown’s Person record contains the value RedBooksCus01 in the Customer/Vendor field, and his user record indicates that he is a member of the Security Group01 security group. The rules for this security group provide access only to customer information for the customer that is contained in the Customer/Vendor field on their Person record. Membership in this group does not authorize access to unrestricted customer level information, for example, customer level information that is not associated with a customer.

Notwithstanding this restriction, members in this Group have access to unrestricted classifications and attributes (for example classifications and attributes that are not restricted to a customer.) Figure 10-2 shows the Authorize Group for Customer on User’s Person Record? option.

Figure 10-2 Authorize Group for Customer on User’s Person Record? option

To access this menu:

1. Select **Go To → Security → Security Groups (SP).**
2. Choose the desired security group.
3. Select **Customers → Authorize group for Customer on User’s Person record.**
Resources
The following resources are used to show how application works:

1. USER01 has this person's (PERS01) CUST/VENDOR field filled with customer=RedBooksCus01. See Figure 10-3 and Figure 10-4.

![Figure 10-3 Main tab in the People (SP) application](image1)

![Figure 10-4 Cust/Vendor field is in the Workplace Information table](image2)

2. Security group Security Group01 is created where user USER01 has unrestricted access to all other options in all tabs within the application. In the Customers tab, select the Authorize Group for Customer on User's Person record option. For more information about creating security groups, refer to 3.4, “Security Groups (SP)” on page 34. See Figure 10-5 and Figure 10-6 on page 178.

![Figure 10-5 Users tab in the Security Groups application](image3)
3. Asset ASST01 is associated with RedBooksCus01. ASST02 is associated with RedBooksCus02 and ASST03 has no customer associated with. Select Go To → Assets → Assets (SP). Search and select your asset, and go to the Primary Customer field in the Details Table. See Figure 10-7.
For more information about how to create an asset, refer to 3.8, “Assets (SP) application” on page 44.

**Implementing the option restriction**

To implement the Authorize Group for Customer on User’s Person record restriction:

1. Login into the Tivoli Process Automation Engine with user USER01 from security group Security Group01.
2. Start the Assets (SP) application by selecting Go To → Assets → Assets (SP).
3. Search and select asset ASST01. The asset is successfully retrieved, as shown in Figure 10-8.

![Figure 10-8 Asset ASST01 is successfully retrieved](image)

4. Now enter asset ASST02 into the quick search field, and click Search to search for the record. An error message is displayed telling you that the record cannot be found, as shown in Figure 10-9 on page 180.
Although the ASST02 record exists in the system, due to the customer restrictions configured previously in the Security Groups (SP) application, the user has no access to it.

This time, try to search for asset ASST03. The same error message is displayed telling you that the record cannot be found. Although record exists in the system, it has no customer associated to it, due to customer restrictions set in the Security Group (SP) application. The user has only access to the records associated with the customer from CUST/VENDOR field in the People (SP) application.

**Note:** We do not go through all records inside the system to show they work all the same, but remember that the rules access patterns that are shown in this chapter are valid to all records from other applications inside the Tivoli Process Automation Engine as well.

### 10.3.2 Authorizing groups for customers in the user’s person customer access list

Joe was assigned to manage a set of customers. The access rules for this security group provide access to all customers listed in the Customer Access List on one’s person record. In addition, he has access to all customer level information that was not associated with a customer. The system manager uses the People (SP) application to input the appropriate customers on someone’s Customer Access List. Membership in this group allows the Customer Service representative to have access to their assigned customers, and to any unrestricted customer level information.

Figure 10-10 on page 181 shows the Authorize Group for Customers in user’s person customer access list.
Resources

The following resources are used to show how the application works:

- USER02 is associated to PERS02.
- PERS02 has Customers=RedBooksCus03 and RedBooksCus04 is configured in the customer access list on customer access tab.

To use the resources:

1. Select Go To → Administration → Resources → People (SP). Search for PERS02 and select it. In Customer Access tab. Select Customers, enter RedBooksCus03 and RedBooksCus04 in the Customer Access List, and save the record. See Figure 10-11 on page 182.
2. Security Group02 is created where user USER02 is associated with PERS02 and has unrestricted access to all other options in all tabs within Security Group application. Authorize group for customers by selecting the User’s Person Customer Access List option under the Customers tab. See Figure 10-12 and Figure 10-13.
Customer agreement CA03 is associated with RedBooksCus03, CA04 is associated with RedBooksCus04 and CA05 is associated with RedBooksCus05. See Figure 10-14.

For more information about how to create customer agreements, refer to 3.14, “Creating customer agreements” on page 59.
Implementing the option restriction

To implement the Authorize Group for Customers in user’s person customer access list option restriction:

1. Login to Tivoli Process Automation Engine with user USER02 from the security group Security Group02.

2. Start the Assets (SP) application by selecting Go To → Service Provider → Customer Agreements (SP).

3. Search and select customer agreements CA03 and CA04. Records are successfully retrieved. The user has access to the records associated with customers that are associated to these records. See Figure 10-15.

4. Search now for asset CA05. An error message is displayed telling you that the record cannot be found. Although the record exists in the system, due to customer restriction in the Security Group (SP) application, you have no access to it. See Figure 10-16.

Figure 10-15  Customer Agreements CA03 and CA04 are successfully retrieved

Figure 10-16  Error message informing user record cannot be found
10.3.3 The Authorizing Groups for Customers listed below option

Figure 10-17 shows the Authorize Group for Customers listed below option.

![Figure 10-17](image)

**Resources**

The following resources are used to show how the Authorize Group for Customers listed below restriction/permission works.

Users USER03 and USER04 are associated with the security group Security Group03. See Figure 10-18 and Figure 10-19 on page 186.

![Figure 10-18](image)
1. The security group selected is Security Group03. Users USER03 and USER04 have unrestricted access to all other options in all tabs within the Security Group application. The **Authorize Group for Customers listed below** option is selected in the Customers tab, and RedBooksCus06 and RedBooksCus07 are listed in the Individual Customer Authorization table. See Figure 10-20.

Location LOC06 is associated with RedBooksCus06 and RedBooksCus07. See Figure 10-21.
2. Make the following associations:
   - Associate ASST06 with RedBooksCus06 and location LOC06.
   - Associate ASST07 with RedBooksCus07 and location LOC06.
   - Associate ASST08 with RedBooksCus08 and location LOC06.
   - Associate ASST09 with RedBooksCus09 and location LOC06.

   See Figure 10-22.

![Figure 10-22](image)

**Implementing the option restriction**

To implement the Authorize Group for Customers listed below restriction:

1. Login into Tivoli Process Automation Engine with user USER03 from security group Security Group03.

2. Start the Locations (SP) application by selecting **Go To → Assets → Locations (SP)**.
3. Search and select for location LOC06. The record is successfully retrieved because the user is part of the security group where RedBooksCus06 and RedBooksCus07 are listed in the Customers tab and therefore has access to all records that are associated to those customers.

4. Change to the Assets tab. What you observe is that several of the asset records that are previously used are not displayed; however, /////////// is present in all fields, as shown in Figure 10-23.

5. Login in now with user USER04 from the same Security Group03.

6. Start the Locations (SP) application by selecting Go To → Assets → Locations (SP).

7. Search and select for location LOC06. The record is successfully retrieved because the user is part of the security group where RedBooksCus06 and RedBooksCus07 are listed in the Customers tab and therefore has access to all records associated to those customers.

8. Change to the Assets tab. What you can observe is that several of the records are not displayed, but /////////// is present in all fields, as shown in Figure 10-24 on page 189.
10.3.4 Authorizing groups for unrestricted customer level information

Joe is responsible for receiving purchased items into inventory and is in charge of inventory accounting. He has no customer responsibilities and therefore has no access to any customer information. As a member of this group, he has access to any unrestricted customer level information, for example, any customer level information that does not reference a customer. He does not have access to any customer-level information that references a customer. See Figure 10-25 on page 190.

Note: Because the users USER03 and USER04 are part of the same security group, the same restrictions/permissions apply to both.
Resources
The following resources are used to show how the Authorize Group only for Unrestricted Customer level information restriction/permission works.

User USER05 associated to security group Security Group04. See Figure 10-26 and Figure 10-27.
The security group Security Group04 is created. User USER05 has unrestricted access to all other options in all tabs within the application. The **Authorize Group only for unrestricted Customer level information** option is selected in the Customers tab.

Work order WO09 is associated with RedBooksCus09 and WO10 has no customer associated to it (Customer field is empty). See Figure 10-28.

![Image of Work Order Tracking main tab and Customer field](image)

**Figure 10-28  Work Order Tracking main tab and Customer field**

**Implementing the option restriction**

To implement the Authorize group only for unrestricted Customer level information restriction:

1. Login into Tivoli Process Automation Engine with user USER05 from security group Security Group04.
2. Start the Work Order Tracking (SP) application by selecting **Go To → Work Orders → Work Order Tracking (SP).**
3. Search and select for Work Order WO10. The record is successfully retrieved, because this record has no customer associated and the user is part of a security group that allows him access only to global records.
4. Searching now for work order WO09, you will see an error message saying the record cannot be found. Although the record exists in the system because the customer restriction from Security Group (SP) application user has no access to it. See Figure 10-29 on page 192.
10.3.5 Authorizing the group for all customer information

Joe is the Director of Operations for the Service Provider RedBooks Inc. He is responsible for all maintenance activities for all customers, so he needs access to all customer information, all customer agreements, and all transactions. Membership in this group authorizes access to all customers and to customer level information for all customers. See Figure 10-30.

![Record cannot be found message]

Figure 10-29 Record cannot be found message

Resources

The following resources are used to show how the authorize group for all customers restriction/permission works.

User USER06 is associated with security group Security Group05.

Security group Security Group05 is created, and user USER05 has unrestricted access to all other options in all tabs within this application and option. The Authorize Group for All Customers information option is selected.
Implementing the option restriction

To implement the authorize group for all customers restriction:

1. Login into Tivoli Process Automation Engine with user USER05 from security group Security Group05.

2. Start the Assets (SP) application by selecting Go To → Assets → Assets (SP).

3. Search and select assets ASST01/ASST02/ASST03. The assets are successfully retrieved for this user regardless of customer or non-customer associations because this user is part of a security group that grants him access to all records in the system.

**Note:** This option gives no special authorization inside the system. It only makes a difference if the user is part of more than one security group. In that case the less restrictive option gives him access to all records inside the system.
Service level agreement (SLA) time zone scenario

This chapter describes a scenario where an SLA must be calculated using specific calendars based on the business needs. We show you how to use the Service Provider and its applications to create the scenario and configure the SLA.

The topics that we discuss in this chapter are:

- 11.1, “Business requirements” on page 196
- 11.2, “Applications involved” on page 196
- 11.3, “Benefits” on page 197
- 11.4, “Implementation” on page 197
11.1 Business requirements

RedBooks Inc. provides IT support services to its customer RedBookCus-A. But to have these IT requests fulfilled with the duration specified in the SLA, they take into account the affected person, asset, and location involved in this repair. All these items can have their own calendars and shifts defined and this is important for calculating the SLAs.

To better explain this business requirement, let us consider a scenario. A RedBookCus-A employee has a broken USB port on his notebook and creates a service request to have it fixed using a ticket Template. Because this is not a severity-1 problem, the employee does not need it fixed right away, but it must be fixed within his working hours. In this scenario, the SLA is applied by checking the existence of an associated calendar and work shift in the following order:

1. If employee has a calendar and work shift defined, the SLA is applied using the employee’s calendar and work shift.
2. If the employee has no calendar and work shift defined, the SLA is applied using the asset’s calendar and work shift, if one is available.
3. If the asset does not have a calendar or a work shift associated with it, the location’s calendar and work shift are used.
4. If the location also does not have a calendar and work shift, the calculation calendar of the SLA is used.
5. If the calculation calendar of the SLA does not exist, Applies To Calendar of the SLA is used.
6. Finally, if the Applies To Calendar of the SLA does not exist, the SLA is calculated without a calendar.

But let us suppose that the employee needs the USB port working urgently for a critical job. In that case, this is a severity-1 issue. The SLA must be calculated only considering the Location Calendar, no matter whether the affected person or Asset Calendar has a calendar defined.

11.2 Applications involved

The following applications are used in this chapter:

- Service Level Agreement (SP)
- Service Request (SP)
- Calendars
- Assets (SP)
11.3 Benefits

By using the SLA time zone feature, you can calculate the target dates of the SLA dynamically according to the choices inside the SLA. Having the target dates calculated correctly is extremely important because these targets are often based on legal contracts between a Service Provider company and its customers.

11.4 Implementation

In this section, we provide the steps needed for creating the SLA using multiple time zones:

- Configure all the elements used by this scenario.
- Create the multiple situations in which multiple SLA calculations are done, depending on the elements used in the process.

11.4.1 Implementation steps

Execute the following steps to reproduce the scenario:

- Pre-configuration:
  - Basic configuration
  - Create and configure a SLA for non severity 1 issues
  - Create and configure a SLA for severity 1 issues

- Apply SLA to a non severity 1 service request:
  - Create a service request
  - Apply SLA
  - Change the shift of the person and re-apply SLA
  - Remove the person’s calendar and re-apply the SLA
  - Remove the asset’s calendar and re-apply the SLA

- Apply SLA to a severity 1 service request:
  - Change the service request to severity 1 and re-apply SLA
  - Change the person’s shift re-apply the SLA
11.4.2 Pre-configuration

**Note:** All of the configuration was made using the EAGLENA organization with the New England (NE) Site as the Default Insert Site.

**Basic configuration**
To create the SLA scenarios, you must have several objects already set up in your Tivoli Process Automation Engine instance. Follow the instructions in Chapter 3, “Initial configuration” on page 25, for creating these objects and associate them with the customer RedBookCus-A.

**Organizations (SP)**
To configure the Organizations (SP) application:

In the Organizations (SP) application:

1. Enter the EAGLENA record.
2. Choose **SLA Option** under the Select Action Menu.
3. In the pop-up panel, choose **NE (New England) Site**, and select the option **Allow Application of One SLA?**
4. Click **OK**, as shown in Figure 11-1.

![Figure 11-1 Organization SLA Options configuration](image)

**Calendars**
Table 11-1 on page 199 shows you the calendar configuration for this scenario.
Chapter 11. Service level agreement (SLA) time zone scenario

Table 11-1 Calendar configuration

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
<th>Start Date</th>
<th>End Date</th>
</tr>
</thead>
<tbody>
<tr>
<td>CALRB01</td>
<td>RedBook Calendar</td>
<td>6/1/10</td>
<td>7/31/10</td>
</tr>
</tbody>
</table>

**Shifts**

Table 11-2 shows you the shift configuration for this scenario.

Table 11-2 Shift configuration

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
<th>Start Day</th>
<th>Days in Pattern</th>
</tr>
</thead>
<tbody>
<tr>
<td>09X05-D</td>
<td>9 hours/day X 5 days/week (day)</td>
<td>MONDAY</td>
<td>7</td>
</tr>
<tr>
<td>12X05-D</td>
<td>12 hours/day X 5 days/week (day)</td>
<td>MONDAY</td>
<td>7</td>
</tr>
<tr>
<td>12X05-N</td>
<td>12 hours/day X 5 days/week (night)</td>
<td>MONDAY</td>
<td>7</td>
</tr>
<tr>
<td>09X06-D</td>
<td>9 hours/day X 6 days/week (day)</td>
<td>MONDAY</td>
<td>7</td>
</tr>
</tbody>
</table>

The shifts created in Table 11-2 use the patterns shown in Table 11-3.

Table 11-3 Shift patterns

<table>
<thead>
<tr>
<th>Shift</th>
<th>Start Time</th>
<th>End Time</th>
<th>Days in Pattern</th>
</tr>
</thead>
<tbody>
<tr>
<td>09X05-D</td>
<td>09:00</td>
<td>18:00</td>
<td>001 to 005</td>
</tr>
<tr>
<td>12X05-D</td>
<td>08:00</td>
<td>20:00</td>
<td>001 to 005</td>
</tr>
<tr>
<td>12X05-N</td>
<td>20:00</td>
<td>08:00</td>
<td>001 to 005</td>
</tr>
<tr>
<td>09X06-D</td>
<td>08:00</td>
<td>17:00</td>
<td>001 to 006</td>
</tr>
</tbody>
</table>

After creating the shifts and defining their patterns, select them and apply to the entire calendar.

**People (SP)**

Table 11-4 on page 200 shows you the location configuration for this scenario.
Table 11-4  Person configuration

<table>
<thead>
<tr>
<th>Person</th>
<th>Primary Calendar</th>
<th>Primary Shift</th>
<th>Display Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>EMPLOYEE01</td>
<td>CALRB01</td>
<td>09X05-D</td>
<td>RedBookCus-A Employee</td>
</tr>
</tbody>
</table>

**Locations (SP)**
Table 11-5 shows you the shift configuration for this scenario.

Table 11-5  Location configuration

<table>
<thead>
<tr>
<th>Name</th>
<th>Type</th>
<th>Calendar</th>
<th>Shift</th>
<th>Primary Customer</th>
</tr>
</thead>
<tbody>
<tr>
<td>LOCRB01</td>
<td>OPERATING</td>
<td>CALRB01</td>
<td>12X05-N</td>
<td>REDBOOKCUS-A</td>
</tr>
</tbody>
</table>

**Assets (SP)**
Table 11-6 shows you the asset configuration for this scenario.

Table 11-6  Asset configuration

<table>
<thead>
<tr>
<th>Name</th>
<th>Location</th>
<th>Primary Customer</th>
<th>Calendar</th>
<th>Shift</th>
</tr>
</thead>
<tbody>
<tr>
<td>ASSETRB01</td>
<td>LOCRB01</td>
<td>REDBOOKCUS-A</td>
<td>CALRB01</td>
<td>12X05-D</td>
</tr>
</tbody>
</table>

**Tip:** Add the EMPLOYEE01 record as User and Custodian of the ASSETRB01 asset to make it easier when creating the service requests.

After creating these objects in Tivoli Process Automation Engine, activate them all.

**Creating and configuring a SLA for non severity 1 issues**
Now we are going to create the first SLA, which covers non severity-1 issues that are calculated taking into account the person, asset or location, calendar, and shift information related with the issue.

**Non severity-1 SLA**
Table 11-7 on page 201 and Table 11-8 on page 201 shows you the configuration required for non severity-1 SLA.
Chapter 11. Service level agreement (SLA) time zone scenario

Table 11-7  Non severity-1 SLA configuration: Part 1

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
<th>Applies To</th>
<th>Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>SLARB01</td>
<td>RedBook SLA for non severity 1 issue</td>
<td>SR</td>
<td>CUSTOMER</td>
</tr>
</tbody>
</table>

Table 11-8  Non severity 1 SLA configuration: Part 2

<table>
<thead>
<tr>
<th>Ranking</th>
<th>Start Date</th>
<th>End Date</th>
<th>Calc Calendar</th>
</tr>
</thead>
<tbody>
<tr>
<td>100</td>
<td>6/1/10</td>
<td>7/31/10</td>
<td>CALRB01</td>
</tr>
</tbody>
</table>

Add the following commitments, as shown in Table 11-9.

Table 11-9  SLA commitments configuration

<table>
<thead>
<tr>
<th>Commitment</th>
<th>Description</th>
<th>Type</th>
<th>Value</th>
<th>Unit of Measure</th>
</tr>
</thead>
<tbody>
<tr>
<td>Accept default</td>
<td>Contact in 24 hours</td>
<td>CONTACT</td>
<td>24.00</td>
<td>HOURS</td>
</tr>
<tr>
<td>Accept default</td>
<td>Respond in 48 hours</td>
<td>RESPONSE</td>
<td>48.00</td>
<td>HOURS</td>
</tr>
<tr>
<td>Accept default</td>
<td>Resolve in 72 hours</td>
<td>RESOLUTION</td>
<td>72.00</td>
<td>HOURS</td>
</tr>
</tbody>
</table>

After defining the basic configurations, we must choose in which order this SLA configuration is going to check the calendars (for example Person Calendar, Asset Calendar, and so on) to use in the calculation of the SLA. Fill in the calendars, as shown in Table 11-10, and activate the SLA.

Table 11-10  Non severity-1 issue SLA Calendar choice

<table>
<thead>
<tr>
<th>First Choice</th>
<th>Second Choice</th>
<th>Third Choice</th>
</tr>
</thead>
<tbody>
<tr>
<td>Person Calendar</td>
<td>Asset Calendar</td>
<td>Location Calendar</td>
</tr>
</tbody>
</table>

The Selection of Calculation Calendar section of your SLA will look like Figure 11-2.

Figure 11-2  Non severity 1 SLA Selection of Calculation Calendar section

Note: This kind of SLA is called an Unconditional SLA and normally has a high ranking because it has no conditions. It applies to all objects that it defined in the Applies To field.
Creating and configuring an SLA for severity-1 issues

Now we are going to create an SLA for specific severity-1 issues, where the calculation must be made without using a Calculation Calendar.

Severity-1 SLA
Table 11-11 and Table 11-12 show you the configuration required for severity-1 SLA. Table 11-13 shows the Commitments configuration.

Table 11-11 Severity 1 SLA configuration: Part 1

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
<th>Applies To</th>
<th>Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>SLARB02</td>
<td>RedBook SLA for severity 1 issue</td>
<td>SR</td>
<td>CUSTOMER</td>
</tr>
</tbody>
</table>

Table 11-12 Severity-1 SLA configuration: Part 2

<table>
<thead>
<tr>
<th>Ranking</th>
<th>Start Date</th>
<th>End Date</th>
</tr>
</thead>
<tbody>
<tr>
<td>10</td>
<td>6/1/10</td>
<td>7/31/10</td>
</tr>
</tbody>
</table>

Table 11-13 SLA Commitments configuration

<table>
<thead>
<tr>
<th>Commitment</th>
<th>Description</th>
<th>Type</th>
<th>Value</th>
<th>Unit of Measure</th>
</tr>
</thead>
<tbody>
<tr>
<td>Accept default</td>
<td>Contact in 4 hours</td>
<td>CONTACT</td>
<td>4.00</td>
<td>HOURS</td>
</tr>
<tr>
<td>Accept default</td>
<td>Respond in 6 hours</td>
<td>RESPONSE</td>
<td>8.00</td>
<td>HOURS</td>
</tr>
<tr>
<td>Accept default</td>
<td>Resolve in 10 hours</td>
<td>RESOLUTION</td>
<td>10.00</td>
<td>HOURS</td>
</tr>
</tbody>
</table>

Because this SLA will not be calculated with any a shift or calendar, no calendar is associated with it; instead, we are going to create a rule specifying this SLA to Internal Priority 1 service requests, as the configuration shown in Table 11-14.

Conditions Tab, SLA Criteria section of the SLA
Table 11-14 shows the value entered in the SLA Criteria section of the SLA.

Table 11-14 SLA Criteria configuration

<table>
<thead>
<tr>
<th>Internal Priority</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>EQUALS</td>
<td>1</td>
</tr>
</tbody>
</table>

After entering this information in your SLA configuration, save and activate it. The Condition Tab, SLA Criteria section of your SLA will look like Figure 11-3 on page 203.
11.4.3 Applying SLA to a non severity-1 service request

At this point, all of the configuration needed is set up for the tests to begin, so we are going to demonstrate a non severity-1 service request. To do that, navigate to the Service Request (SP) application, and create a new service request.

Creating a service request
Table 11-15 shows the service request details.

**Service Request (SP)**

<table>
<thead>
<tr>
<th>Service Request</th>
<th>Site</th>
<th>Reported Date</th>
<th>Affected Date</th>
</tr>
</thead>
<tbody>
<tr>
<td>SRRB01</td>
<td>NE</td>
<td>6/23/10 08:00:00</td>
<td>6/23/10 08:00:00</td>
</tr>
</tbody>
</table>

After creating the initial service request, associate the EMPLOYEE01 person with the Reported By and Affected Person fields, as shown in Figure 11-4 and Figure 11-5 on page 204.
Associate also asset ASSETRB01 with the service request. It automatically populates the Location, Asset Site, and Customer fields, as shown in Figure 11-6.

**Applying the SLA**

With all these fields populated, select **Apply SLA** under the Select Action menu. You will see a message saying that SLARB01 was applied.

As you can see in Figure 11-7, the SLA was applied calculating its target dates using the CALRB01 calendar and 09X05-D shift, which is the Person Calendar chosen as the first choice calendar for this type of SLA.
**Change the shift of the person and re-apply the SLA**

Now we are going to change the Person Shift, in this case the EMPLOYEE01 record and re-apply the SLA to check if the SLA will be recalculated. To do so, go to the **People (SP)** application, enter the EMPLOYEE01 record, change its shift to 09X06-D and save it. The record will look like Figure 11-8.

![Person with 09X06-D shift applied](image)

*Figure 11-8  Person with 09X06-D shift applied*

Now go back to the SRRB01 Record under the Service Request (SP) application and Apply SLA again from the Select Action menu. You will get a System Message warning that any target date already calculated is lost, as shown in Figure 11-9. Click **OK** to continue.

![Re-apply SLA system message](image)

*Figure 11-9  Re-apply SLA system message*

Because the EMPLOYEE01’s shift now also applies for Saturday, recalculate the target dates, as shown in Figure 11-10 on page 206.
Implementing IBM Maximo for Service Providers

Figure 11-10   Target dates after applying SLA for calendar CALRB01 and shift 09X06-D

Removing the person’s calendar and re-applying the SLA
After changing the person’s shift, we are going to remove this person’s calendar, so that the second choice of the SLA is used, in this case the Asset Calendar and shift. Go to the People (SP) application, enter EMPLOYEE01 record, remove the associated calendar and shift, and save it. The record will look like Figure 11-11.

Tip: Use the Detail menu of the Reported By in the service request, and go to the Person (SP) record and use the “Return with Value” function.

Now go back to the SRRB01 record under the Service Request (SP) application, and select Apply SLA again from the Select Action menu. Because EMPLOYEE01 does not have a calendar and shift associated, the Asset Calendar is used by the SLA to calculate the target dates, as shown in Figure 11-12 on page 207.
Removing the asset's calendar and re-applying the SLA

After applying the SLA using the First and Second Choices, we are going to remove the asset's calendar to force the SLA to use the Third Choice, which in this case is the location's calendar and shift, to calculate the target dates. Go to the Assets (SP) application, enter the ASSETRB01 record, remove the Calendar and Shift, and save it. The record will look like Figure 11-13.

Tip: Use the Detail menu of the asset in the service request, go to the asset's record, and use the Return with Value function.

Now go back to the SRRB01 Record under Service Request (SP) application, and select Apply SLA from the Select Action menu. Because ASSETRB01 does not have a calendar and shift associated, the Location Calendar is used for the calculation of target dates, as shown in Figure 11-14 on page 208.
Applying SLA to a severity 1 service request

After applying the SLA using multiple calendars, we are going to apply the SLA to a severity 1 service request to show that, even if we have an SLA with multiple choices of Calculation Calendars, we can still have a separate SLA for special occasions, such as a severity-1 issue.

Changing the service request to severity-1 and re-apply the SLA

In this example, we use the same SRRB01, but we change its internal priority to 1, as shown in Figure 11-15.

Now we are going to re-apply the SLA, so SLARB02 is applied this time, as shown in Figure 11-16.

Now, notice that the SLA was calculated without a calendar, so it will be calculated using the commitment values, as shown in Figure 11-17 on page 209.
Changing the person’s shift and re-applying the SLA

To change the person’s shift and reapply the SLA:

1. Go to the **People (SP)** application, enter the EMPLOYEE01 record, fill in calendar CALRB01 and shift 09X05-D, and save it.

2. Return to the **Service Request (SP)** application, enter the SRRB01 record, and select **Apply SLA** from the Select Action menu. Notice that the target dates will not be changed, because SLARB02 was applied again because it has a lower ranking than SLARB01.
Pricing scenario

This scenario demonstrates the use of the Maximo for Service Providers pricing rules functionality to create flexible pricing schemes, which you can adjust to meet your business needs. In this scenario, RedBooks Inc. is a Service Provider company that manages the IT assets of CustomerA.

In this scenario, we simulate three real life pricing cases selected among a wide number of possibilities and demonstrated how to implement them in Maximo for Service Providers. Obviously every organization has specific pricing needs for charging its customers for the goods and services provided. Service Provider companies usually combine multiple pricing rules to create more complex pricing schemes.

The topics that we discuss in this chapter are:

- 12.1, “Business needs” on page 212
- 12.2, “Use case” on page 213
- 12.3, “Implementation of pricing rules” on page 213
12.1 Business needs

RedBooks Inc. Service Provider company is a computer maintenance service company that provides services, such as PC installation, maintenance, virus removal, network cabling, printer repair, and so forth.

CustomerA is a business company that is headquartered in Seattle, WA, and has branch offices in Boston, MA, and New York, NY.

CustomerA has an agreement with RedBooks Inc. for maintenance of its desktop and mobile PC and printer equipment in the headquarters and branch offices. Table 12-1 shows the number of devices that are included in the service agreement.

<table>
<thead>
<tr>
<th>Location</th>
<th>Desktop PCs</th>
<th>Mobile PCs</th>
<th>Laser printers</th>
<th>Other printers</th>
</tr>
</thead>
<tbody>
<tr>
<td>Seattle</td>
<td>120</td>
<td>240</td>
<td>20</td>
<td>15</td>
</tr>
<tr>
<td>New York</td>
<td>500</td>
<td>100</td>
<td>15</td>
<td>20</td>
</tr>
<tr>
<td>Boston</td>
<td>250</td>
<td>45</td>
<td>5</td>
<td>12</td>
</tr>
<tr>
<td>Total</td>
<td>870</td>
<td>395</td>
<td>40</td>
<td>47</td>
</tr>
</tbody>
</table>

RedBooks Inc. has various pricing methods for charging its services:

▶ The installation, repair, and maintenance of a desktop PC is a volume-based pricing scheme. The unit price for servicing up to 60 desktop PCs is $100 USD. The unit price for servicing from 61 desktop PCs up to 120 desktop PCs is $70.

▶ The repair and maintenance of ink jet and dot matrix printers are charged at a flat rate: $50 per item, regardless of the number of items.

▶ The repair and maintenance of laser printers is priced by the number of cumulative printouts. Because the cost to repair or maintain a laser printer increases with its use, Service Provider implemented a meter to calculate printer usage in terms of cumulative number of printed pages at the time of service request.

Printers that are used to print up to 30,000 printouts are priced at $40 per unit. After this limit, the price of maintenance increases by $10 for every 10,000 printouts. For more than 40,000 printouts, the price is fixed. Table 12-2 on page 213 shows the printer maintenance prices.
### 12.2 Use case

RedBooks Inc. agreed with CustomerA on a new price scheme. A sales representative created a customer agreement and entered the price scheme in the Maximo for Service Providers, Customer Agreement application. The RedBooks Inc. manager approves this agreement and it becomes effective.

CustomerA orders maintenance service for desktop PCs and printers.

Sales orders matching the terms of the agreement are priced specially, for example, desktop PC service will be charged at a discounted amount for CustomerA instead of at the catalog price.

### 12.3 Implementation of pricing rules

We implement this scenario using Maximo for Service Providers applications:

- Customer (SP)
- Customer Agreements (SP)
- Meters
- Locations (SP)
- Assets (SP)
- Classifications (SP)
- Sales Orders (SP)

**Customer and customer agreement**

See 3.14, “Creating customer agreements” on page 59 to create a Customer named CustomerA and a customer agreement for that Customer.

---

### Table 12-2 Price schedule for laser printer maintenance

<table>
<thead>
<tr>
<th>Printout quantity breaks</th>
<th>Unit maintenance price in USD</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 - 10,000</td>
<td>$40</td>
</tr>
<tr>
<td>10,001 - 20,000</td>
<td>$50</td>
</tr>
<tr>
<td>20,001 - 30,000</td>
<td>$60</td>
</tr>
<tr>
<td>30,001 - 40,000</td>
<td>$70</td>
</tr>
<tr>
<td>40,000+</td>
<td>$80</td>
</tr>
</tbody>
</table>
Meters
Meters represent meter readings found on each printer, either as a software or hardware counter. Use the Meters application to create a printouts meter to track the number of printed pages of the laser printers:

1. Open the Meters application by selecting Go To → assets → Meters).
2. Create a new meter using this information:

<table>
<thead>
<tr>
<th>Meter</th>
<th>PRINTOUTS</th>
</tr>
</thead>
<tbody>
<tr>
<td>Meter Type</td>
<td>CONTINUOUS</td>
</tr>
<tr>
<td>Reading Type</td>
<td>ACTUAL</td>
</tr>
</tbody>
</table>

   See Figure 12-1.

   ![Figure 12-1 Meters](image)

3. Save the meter.

**Types of meters you can define:** An asset or location can have multiple meters associated with it.

You can define the following three types of meters:

*Continuous Meters* are cumulative and tend to measure consumption or accumulation. They include meters that track such things as miles, hours, engine starts, pieces produced, or fuel consumed.

*Gauge Meters* show a range of values, such as fuel levels, temperature, pressure, noise level, and so forth. Gauge meters can be used to perform condition monitoring on assets or Locations.

*Characteristic Meters* are observational in nature and have a list of possible values. They track things, such as noise level, vibration level, clarity, or color. Characteristic meters can be used to perform condition monitoring on assets or Locations.

Locations (SP)
Use the Locations (SP) application to create Seattle, New York, and Boston locations for Customer CustomerA, as shown in Figure 12-2 on page 215.
Assets (SP)

Use the Assets (SP) application to create assets and associate them with Customer and meters:

1. Open assets application (Go to → assets → Assets (SP))
2. Create a new asset using this information:
   - Asset: LP1
   - Description: Laser Printer

See Figure 4 on page 216.

3. Click the Meters tab.
4. Click **New Row**.

Complete the fields using this information:

<table>
<thead>
<tr>
<th>Sequence</th>
<th>1</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Meter</strong></td>
<td>PRINTOUTS</td>
</tr>
<tr>
<td><strong>Meter Type</strong></td>
<td>CONTINUOS</td>
</tr>
</tbody>
</table>

See Figure 12-4.

![Asset Meters](image.png)

**Figure 12-4  Asset Meters**

5. Save the asset.

6. Change asset status to OPERATING.

**Classifications (SP)**

Use the Classifications (SP) application to make classifications usable by the Sales Order (SP) application:

1. Click **Go To → Administration → Classifications (SP)**.
2. Find IT Issue classification. See Figure 12-5 on page 217.
Figure 12-5  Classifications List

3. Open IT Issue classification, as shown in Figure 12-6 on page 218.
4. In the Use With section, click **New Row**.

5. In the Use With Object field, type PLUSPGBTRANS, as shown in Figure 12-7.

6. Click **New Row** button again.

7. In the Use With field, type PLUSPSALESORDER. See Figure 12-8 on page 219.
8. Save the classification, and click the **List** tab.

9. Repeat steps 2-9 for the following classifications to add PLUSPGBTRANS and PLUSPSALESORDER:
   - IT Issue \ Hardware
   - IT Issue \ Hardware \ Desktop
   - IT Issue \ Hardware \ Mobile Computer
   - IT Issue \ Hardware \ Printer

**Defining price schedules**

Each customer agreement contains one or more price schedules for services you provide. Price schedules define your agreed pricing rules and the conditions under which you apply those rules. Each price schedule can contain different rules for calculating prices for services, for example, you can create a price schedule that adds a markup percentage to reported labor costs. You can specify various markups for internal and external labor and separate markups for multiple vendors.

You also can specify various IT asset management fees that you include in every billing cycle, for example, you can create a price schedule that calculates a price based on the number of assets that you manage or that calculates a price based on the use or performance of an asset.

In this scenario, we define three price schedules to reflect the pricing terms agreed between ServiceProvider and CustomerA, as shown in Table 12-3.

**Table 12-3  Price schedules**

<table>
<thead>
<tr>
<th>Price schedule</th>
<th>asset Classification</th>
<th>Pricing rule</th>
</tr>
</thead>
<tbody>
<tr>
<td>S1</td>
<td>Desktop PC</td>
<td>Number of assets</td>
</tr>
<tr>
<td>S2</td>
<td>Ink jet printers</td>
<td>Flat rate</td>
</tr>
<tr>
<td>S3</td>
<td>Laser printers</td>
<td>Usage</td>
</tr>
</tbody>
</table>
To define the three price schedules to reflect the pricing terms agreed between Service Provider and Customer A:

1. Click Go to → Service Provider (SP) → Customer Agreements (SP).
2. Find customer agreement for customer Customer A, which we show in Figure 12-9.

![Figure 12-9 Customer agreement](image)

3. Select Action → Revise Agreement, as shown in Figure 12-10.

![Figure 12-10 Revise Agreement](image)

4. Complete the Comments field in the Revise Agreement Dialog box.
5. Enter the Revise Price Schedule, as shown in Figure 12-11 on page 221.
6. Click the **Price Schedules** tab, shown in Figure 12-12.

7. Under the Price Schedules section, click **New Row**.

8. Enter these values:

   - **Price Schedule**: S1
   - **Description**: Manage Desktop / Notebook PC
   - **Applies To**: PLUSPSALESORDER
   - **Ranking**: 100

See Figure 12-13 on page 222.
9. Click the **Conditions** sub tab.

10. Click the arrow next to the Classification field, and select **Classify**.

11. Select **IT Issue \ Hardware Issue \ Desktop Hardware Issue** from the classification tree, as shown in Figure 12-14.

12. Click the **Pricing Rules** sub tab.

13. Under the Asset Management sub tab, click **New Row**.

14. Select **IT \ Computer_Equipment \ Computer \ Desktop**, as shown in Figure 12-15 on page 223.
15. Populate the fields using this information, as shown in Figure 12-16:

- **Range From**: 1
- **Range To**: 60
- **Unit Price**: 100

16. Click **New Row**, and select the **IT \ Computer_Equipment \ Computer \ Desktop** classification.

17. Populate the fields with the following values, as shown in Figure 12-17 on page 224.

- **Range From**: 61
- **Range To**: 120
- **Unit Price**: 70
18. Save the customer agreement.

We just defined our first price schedule.

**Defining the price schedule for other types of assets**

Now we define the price schedule for other types of assets:

1. Under the Price Schedules section, click **New Row**.

2. Populate the fields using this information, as shown in Figure 12-18:

   - **Schedule**: S2
   - **Description**: Price Schedule for ink jet and Dot Matrix Printers
   - **Applies To**: PLUSPSALESORDER
   - **Ranking**: 100

3. Save the customer agreement record.

   **S2 price schedule**: After saving the record, focus is moved to the S1 price schedule. To continue working with the S2 price schedule, click the small arrow button next to S2.
4. Click the **Conditions** sub tab.

5. Enter **IT Issue \ Hardware Issue \ Printer Hardware Issue** in the classification field, as shown in Figure 12-19.

![Figure 12-19 IT Issue \ Hardware Issue \ Printer Hardware Issue](image)

6. Click the **Pricing Rules** sub tab.

7. Select **IT \ Computer_Equipment \ Printer** for classification. See Figure 12-20.

![Figure 12-20 IT \ Computer Equipment \ Printer](image)
8. Populate the fields using this information, as shown in Figure 12-21:

<table>
<thead>
<tr>
<th>Field</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Range From</td>
<td>1</td>
</tr>
<tr>
<td>Range To</td>
<td>100000 (Enter a big number)</td>
</tr>
<tr>
<td>Unit Price</td>
<td>50</td>
</tr>
</tbody>
</table>

![Figure 12-21 Printer Unit Price](image)

9. Save the customer agreement, and in the Price Schedules section, click **New Row**.

10. Populate the fields using this information:

<table>
<thead>
<tr>
<th>Field</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Price Schedule</td>
<td>S3</td>
</tr>
<tr>
<td>Description</td>
<td>Manage Laser Printers</td>
</tr>
<tr>
<td>Applies To</td>
<td>PLUSPSALESORDER</td>
</tr>
<tr>
<td>Ranking</td>
<td>50</td>
</tr>
</tbody>
</table>

11. Click the **Conditions** sub tab, click the arrow next to Classification field, and select **Classify**.

12. From the classification tree, select **IT Issue \Hardware Issue \Printer Hardware Issue**.
13. Click these subtabs: **Pricing Rules → IT asset → asset Usage**.

14. Under the asset Usage section, click **New Row**.

15. Use this information to populate the fields in the form, as shown in Figure 12-23 on page 228.

<table>
<thead>
<tr>
<th>Meter Name</th>
<th>PRINTOUTS</th>
</tr>
</thead>
<tbody>
<tr>
<td>Range From</td>
<td>1</td>
</tr>
<tr>
<td>Range To</td>
<td>10000</td>
</tr>
<tr>
<td>Unit Price</td>
<td>40</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Meter Name</th>
<th>PRINTOUTS</th>
</tr>
</thead>
<tbody>
<tr>
<td>Range From</td>
<td>10001</td>
</tr>
<tr>
<td>Range To</td>
<td>20000</td>
</tr>
<tr>
<td>Unit Price</td>
<td>50</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Meter Name</th>
<th>PRINTOUTS</th>
</tr>
</thead>
<tbody>
<tr>
<td>Range From</td>
<td>20001</td>
</tr>
<tr>
<td>Range To</td>
<td>30000</td>
</tr>
<tr>
<td>Unit Price</td>
<td>60</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Meter Name</th>
<th>PRINTOUTS</th>
</tr>
</thead>
<tbody>
<tr>
<td>Range From</td>
<td>30001</td>
</tr>
<tr>
<td>Range To</td>
<td>40000</td>
</tr>
<tr>
<td>Meter Name</td>
<td>Unit Price</td>
</tr>
<tr>
<td>------------</td>
<td>------------</td>
</tr>
<tr>
<td>PRINTOUTS</td>
<td>70</td>
</tr>
<tr>
<td>PRINTOUTS</td>
<td>80</td>
</tr>
<tr>
<td>PRINTOUTS</td>
<td>80</td>
</tr>
</tbody>
</table>

**Figure 12-23  Printouts**

16. Save the customer agreement.
17. Click **Change Status**.
18. In the Change Status dialog box, populate the fields using this information:

   **New Status**  Approved
   **Memo**  Approve Price Schedules

19. Click **OK** button.

**Sales Orders (SP)**

Use sales orders to bill for services that are not related to work orders or tickets, for example, you bill monthly management fees, trip charges, and several types of IT asset management fees with sales orders.

You associate a customer with the sales order, and then apply a customer agreement and price schedule to the sales order. The price schedule can apply fixed fees.
You can specify additional fees and charges on the sales order. If you create a sales order to bill for IT asset maintenance, you specify certain information about the assets, apply the agreement and price schedule, and let the system calculate billing prices.

In this scenario, we apply customer agreement and price schedules to calculate billing prices for the services provided to CustomerA:

1. Select Go To → Service Provider (SP) → Sales Orders (SP).
2. Click New Sales Order.
3. Select SEATTLE as the Location.
4. Select IT Issues \ Hardware Issue \ Desktop Hardware Issue, as shown in Figure 12-24.

5. Select Action → Apply Customer Agreement, as shown in Figure 12-25 on page 230.
6. Click **OK** to close System Message Dialog box, as shown in Figure 12-26.

![System Message](image)

*Figure 12-26  System Message*

7. Under the Fees and Charges section, click **New Row**.

8. Use this information to populate the fields:

   - **Type**: MANAGEMENT
   - **Calculation**: COUNT
   - **Classification**: IT \ Computer_Equipment \ Computer \ Desktop
   - **Total asset Count**: 120 (*This means Customer has 120 asset items in total*)
   - **asset Count for Sales Order**: 10 (*This means 10 items are subject to sales order*)

   Price is calculated automatically as $700. See Figure 12-27 on page 231.
This is $70 per unit. By selecting **COUNT** as calculation type, you charged the customer at a lower price ($70) instead of $100 per item.

9. Try reducing the total amount to 60 items. The unit price will change to $100 for this amount.

10. Save the sales order, and change the Order Status to APPROVED.

11. Click **New Sales Order**, and populate the fields with following the values:
   
   **Location**  
   BOSTON

   **Classification**  
   IT Issue \ Hardware Issue \ Printer Hardware Issue

12. Select **Action → Apply Customer Agreement**. Price schedule S3 is applied to the sales order.

13. Click **New Row** under the Fees and Charges section.

14. Populate the fields using this information:
   
   **Type**  
   MANAGEMENT

   **Calculation**  
   USAGE

   **Meter**  
   PRINTOUTS

   **Total Usage**  
   20000

   **Reading**  
   1

   Line Price is calculated as $50. This is the price range calculated for a range of 10.001 to 20.000 total printouts. Change the number to 20.001 to see Line Price changing to $60. See Figure 12-28 on page 232.
15. Click **Go to → Service Provider (SP) → Sales Orders (SP).**

16. Create a new sales order, and type the following information:

   **Location**
   
   **Classification**  
   IT Issue \ Hardware \ Printer

17. Save the sales order, and select **Action → Select Deselect Price Schedule,** as shown in Figure 12-29.

18. In the Select Deselect Price Schedule dialog box, click **New Row,** as shown in Figure 12-30 on page 233.
19. In the Price Schedule dialog box, select the **Show filtered Agreement Price Schedules for this Customer** option (default option).

20. Under the Price Schedules table, select **Price Schedule (S2)**.

21. Click **OK** to close the dialog.

22. In the Fees and Charges section, click **New Row**.

23. Populate the fields with this information:

<table>
<thead>
<tr>
<th>Type</th>
<th>Management</th>
</tr>
</thead>
<tbody>
<tr>
<td>Calculation</td>
<td>Count</td>
</tr>
<tr>
<td>Classification</td>
<td>IT \ Computer_Equipment \ Printer</td>
</tr>
<tr>
<td>Total asset Count</td>
<td>1 <em>(Any number greater than zero)</em></td>
</tr>
<tr>
<td>asset Count for Sales order</td>
<td>10</td>
</tr>
</tbody>
</table>

Line price is calculated as $50 per item. This is the flat rate for dot matrix printers.
Chapter 13. Service Desk tickets and solutions restricted by Service Provider customers scenario

In this chapter, we show you how a company that provides Service Desk services for multiple companies can manage tickets in the same Service Request Manager server and keep the information safe providing special access for separate users for multiple companies.

In this chapter, the topics that we discuss are:

- 13.1, “Business requirement” on page 236
- 13.2, “Integrating IBM Tivoli Service Request Manager with IBM Maximo for Service Providers” on page 236
13.1 Business requirement

RedBook Inc. is providing Service Desk service for customer SDA and customer SDB. RedBook Inc. has Service Desk users dedicated for customer SDA and customer SDB and Support users who work for both companies. RedBook Inc. must create Incidents for each company and restrict access of the Service Desk only to the Incidents and Solutions for which they have authorization.

13.2 Integrating IBM Tivoli Service Request Manager with IBM Maximo for Service Providers

Tivoli Service Request Manager provides a full portfolio of application for Service Desk, such as incidents, problems, service requests, and solutions. It also provides powerful mechanisms to search for a ticket or solution.

IBM Maximo for Service Providers focuses on how customers must receive the services defined by the contract terms.

Combining these products together creates a powerful solution for Service Provider companies that provide Service Desk services to multiple customers.

13.2.1 Scenario and products involved in the integration

To implement this scenario, you must have the following products installed in your environment:

- IBM Tivoli Service Request Manager 7.2
- IBM Maximo for Service Providers

13.2.2 Benefits of this integration

The benefits of integrating the IBM Tivoli Service Request Manager and IBM Maximo for Service Providers is that you can create tickets in Service Request Manager for Service Provider customers, which allows secure access to tickets and solutions created for a specific customer.
13.2.3 Installing IBM Maximo for Service Providers on top of IBM Tivoli Service Request Manager

To install IBM Maximo for Service Providers on top of IBM Tivoli Service Request Manager:

1. Run `launchpad.exe` inside your SRM 7.2 installation folder. See Figure 13-1.

```
<table>
<thead>
<tr>
<th>Name</th>
<th>Size</th>
<th>Type</th>
<th>Date Modified</th>
</tr>
</thead>
<tbody>
<tr>
<td>Install</td>
<td></td>
<td>File Folder</td>
<td>11/12/2009 6:53 PM</td>
</tr>
<tr>
<td>launchpad</td>
<td></td>
<td>File Folder</td>
<td>11/12/2009 6:53 PM</td>
</tr>
<tr>
<td>autorun.inf</td>
<td>1 KB</td>
<td>Setup Information</td>
<td>11/12/2009 6:52 PM</td>
</tr>
<tr>
<td>launchpad.exe</td>
<td>180 KB</td>
<td>Application</td>
<td>11/12/2009 6:52 PM</td>
</tr>
<tr>
<td>launchpad.ini</td>
<td>2 KB</td>
<td>Configuration Settings</td>
<td>11/12/2009 6:52 PM</td>
</tr>
<tr>
<td>launchpad.sh</td>
<td>6 KB</td>
<td>SH File</td>
<td>11/12/2009 6:52 PM</td>
</tr>
<tr>
<td>SRM72Internal-1112D.tar</td>
<td>4,441,880 KB</td>
<td>TAR File</td>
<td>11/12/2009 10:39 PM</td>
</tr>
<tr>
<td>SRM72Managed-1112D.tar</td>
<td>4,441,920 KB</td>
<td>TAR File</td>
<td>11/12/2009 10:42 PM</td>
</tr>
<tr>
<td>SRM72TDI-1112D.tar</td>
<td>1,752,300 KB</td>
<td>TAR File</td>
<td>11/13/2009 12:04 AM</td>
</tr>
<tr>
<td>SRM72Vanilla-1112D.tar</td>
<td>4,315,910 KB</td>
<td>TAR File</td>
<td>11/12/2009 11:09 PM</td>
</tr>
</tbody>
</table>
```

*Figure 13-1  Installation folder*

2. Click **Service Provider**, as shown in Figure 13-2.

*Figure 13-2  Installing IBM Maximo for Service Providers from the Tivoli Service Request Manager installer*

3. Click **Install Service Provider Common Components for Service Request Manager**, as shown in Figure 13-3 on page 238
4. After this process is finished, click **Install Service Provider Support for Service Request Manager**, shown in Figure 13-2 on page 237.

5. When the redeployment completes, IBM Maximo for Service Providers will be integrated with Tivoli Service Request Manager.

### 13.3 Step-by-step implementation

In this scenario, we create a set of Incidents for two customers for three different users.

#### 13.3.1 Initial customization for this scenario

In this section, we describe the initial customization steps:

**Enabling SP security**

To enable IBM Maximo for Service Providers security:

1. Login at the system using the administrator user.
2. Select **Security → Customer Objects (SP)**.
3. Select **Select Action → Create Default Conditions**.

4. The message “Additional Customers Objects and Conditions were added after the original setup” will appear. Click **Yes**, and Figure 13-5 is displayed.

![Figure 13-5](image)

**Figure 13-5**  The list with 42 objects

**Creating customers**

To create the customers:

1. Select **Service Provider (SP) → Customers (SP)**.
2. Create a new customer named CUSTOMERSDA.
3. Change the status to **Active**.
4. Create a new customer named CUSTOMERSDB.
5. Change status to **Active**, as shown in Figure 13-6 on page 240.
Creating security groups

To create the security groups:

2. Create group CustomerSDU.
3. Move to the Customer tab and enable the flag Authorize Group for Customers on User's Person Record, as shown in Figure 13-8 on page 241.
4. Click the **Applications** tab.

5. Filter the application by Solution. Three applications will appear, as shown in Figure 13-9.

   ![Figure 13-9 Solution](image)

   In Figure 13-9, you can see the word Solution in the filter text box and the three applications listed: Search Solution, Solutions, and Solution (SP).

6. Click **Grant Listed Applications → All Above**. Click **Yes → Save**, as shown in Figure 13-10 on page 242 and Figure 13-11 on page 242.
7. Filter applications using the Global Search.

8. Click **Grant Listed Applications → All Above**, and click **Yes**.

9. Click **Grant Listed Options for this Application**, and click **Save**. See Figure 13-12 on page 243.

   Grant Listed Options for this application grant access for all actions for the options access granted.
10. Create group SupportSDU.

11. Click the Customer tab, and select the Authorize Group for Customers in User's Person Customer Access List option, as shown in Figure 13-13.

Here we create a security group for the support user. This group determines to which customers the user has access.

As in the previous security group, the following steps provide access for the same applications and functions.

12. Click the Applications tab.

13. Filter the application by Solution. Three applications are displayed.

14. Click Grant Listed Applications → All Above, and click Yes.
15. Filter applications by Global Search.

16. Click **Grant Listed Applications → All Above → Yes → Grant Listed Options for this Application → Save.**

**Creating users**
To create the users:

1. Go to → **Security Groups → Users.**
2. Create **USERSDA** and active it. See Figure 13-14.

![Figure 13-14 Activate the user](image)

3. From the Person application Detail Menu, select **Select Value → People (SP).**
4. Associate **USERSDA** with **CUSTOMERSDA** by setting the Cust/Vendor field with **CUSTOMERSDA**, as shown in Figure 13-15 on page 245.
5. Using the Detail Menu for person you open the People(SP) application and associate the Person with Cust/Vendor field.
6. Return to the Users application, move to the **Groups** tab, and add a customer, for example CustomerSDU, as shown in Figure 13-16.

*Figure 13-16  Users (SP) application*
7. Click **Security Groups → Users**.
8. Create the user USERSDB, and active it.
9. From Person Detail Menu icon, select **Select Value → People (SP)**.
10. Associate USERSDB with CUSTOMERSDB by setting the Cust/Vendor field with CUSTOMERSDB.

**Note:** So far we created two users that are associated with different customers (USERSDA → CUSTOMERSDA; USERSDB → CUSTOMERSDB).

11. Select **Security Groups → Users**.
12. Create the security group SUPPORTSA, and activate it.
13. From the Person application Detail Menu, select **Select Value → People (SP)**.
14. Click the **Customer Access** tab, add a new row, and call it CUSTOMERSDA, as shown in Figure 13-17.

![Figure 13-17  Associate a customer to a user](image)

15. Return to the Users application, select the **Groups** tab, add a new row, and call the group SupportSDU.
Note: For the Support user, we use the second security group we created (SupportSDU). Each group restricts the user access to a list of customers. In this case, we created a list of one user.

17. Create the user SUPPORTSDAB and active it.
18. From the Person application Detail Menu, select Select Value → People (SP).
19. Click the Customer Access tab, and add a new row called CUSTOMERSDA.
20. Click the Customer Access tab, and add a new row called CUSTOMERSDB, as shown in Figure 13-18.

![Figure 13-18 Create a support user that will have access to the two customers](image)

21. Return to the Users application, click the Groups tab, and add a new row called SupportSDU.

Setting a cron task to index tickets and solutions for Global Search

To set a cron task to index tickets and solutions for Global Search:

2. Search and open PmObjSearchCron.
3. Set PmObjSearchInstance to 5m, as shown in Figure 13-19.
4. Select the **Active** option, and save the record.

5. Select **Select Action** → **Reload Request**.
6. Select **PmObjSearchInstance**, and click **OK**, as shown as Figure 13-20.

**Tip:** Reload the cron task before the changes become activate.

13.3.2 Operating the system

Perform the following to create incidents and solutions:

1. Login as administrator at the system.
2. Go to **Service Desk** → **Incident**.
3. Click **New**.

4. In the Summary field, type **IncidentA - CustomerSDA associated**.

5. In the Details field, type **That is the first Incident applied to Customer SDA only**.

6. In the Customer field, enter **CUSTOMERSDA**, and save it, as shown in Figure 13-21.

![Figure 13-21](image)

7. Click **New Incident**.

8. In the Summary field, enter **IncidentB - Customer SDB associated**.

9. In the Details field, enter **This is the first Incident applied to Customer A only**.

10. In the Customer field, enter **CUSTOMERSDB**.

11. Save the record, as shown in Figure 13-22 on page 250.
12. Go to the **Solution Details** tab.
13. Click **Detail Menu** for Solution, and go to the Solution applications.
14. Populate the Description field with **Solution for IncidentB**.
15. Select the **Self-Service Access?** option.
16. Populate the Customer field with **CustomerSDB**.
17. Change the status to **Active**, and save, as shown in Figure 18 on page 251.
18. Click **Return with Value**. You will see that the incident has a solution already applied, as shown in Figure 13-24.

Now let us perform a Global Search for UserSDA and UserSDB:

1. Login as UserSDA.
2. Select **Service Desk → Global Search**.
3. In the search field, type **Incident**, and press Enter.
4. In the search field, type **Solution**, and press Enter. No record will be found because of the user security restriction. The user has access to tickets and solution only for the Customer SDB.

5. Login as UserSDB.

6. Select **Service Desk → Global Search**.

7. In the search field, type **Incident**, and press Enter, as shown in Figure 13-26 on page 253.
8. In the search field, type Solution, and press Enter, as shown in Figure 13-27 on page 254.
9. Login as SupportSDA.
10. Select **Service Desk → Global Search**.
11. In the search field, type **Incident**, and press Enter. As seen in Figure 13-28 on page 255, no solution is shown because the restriction applies to Customer SDA, and we created the solution for Customer SDB.
SupportSDA user is not authorized for tickets/solutions for CustomerSDA, so no rows are displayed.

12. Login as SupportSDAB.

13. Select **Service Desk → Global Search**.

14. In the search field, type *Incident*, and press Enter, as shown in Figure 13-29 on page 256.
15. In the search field, type Solution, and press Enter, as shown in Figure 13-30.

![Figure 13-30](image)

Note: You can use the Solutions application to search for that solution. The result is same as searching the solution with Global Search: only users associated with CustomerSDB can see the solution 1001.

Also in the security group, you can give access to any other application for tickets (service requests, problems, incidents). The restrictions for customer are applied to those too.
Related publications

The publications listed in this section are considered particularly suitable for a more detailed discussion of the topics covered in this book.

IBM Redbooks

For information about ordering these publications, see “How to get Redbooks” on page 258. Note that some of the documents referenced here may be available in softcopy only:

- Certification Study Guide Series: IBM Maximo Asset Management V7.1, SG247761

Online resources

These Web sites are also relevant as further information sources:

- Maximo information center:

- Priority Matrix application information:

- Migration Manager user guide:

- IBM Maximo Asset Management information center:
How to get Redbooks

You can search for, view, or download Redbooks, Redpapers, Technotes, draft publications and Additional materials, as well as order hardcopy Redbooks publications, at this Web site:

ibm.com/redbooks

Help from IBM

IBM Support and downloads

ibm.com/support

IBM Global Services

ibm.com/services
Index

A
Agreement Price Schedules application, overview 14
applications
    Assets 44
    Bill Batch 119
    Bill Review 120
    Bulletin Board 72
    Customer 29
    Customer Agreement 110
    Customer Billing 134
    Customer Objects 32
    Domains 36
    Locations 39
    Meters 214
    Migration Groups 141
    Migration Manager 140
    Object Structures 141
    Organization 26
    People 181
    Preventive Maintenance 161
    Response Plan 115
    Security Groups, using 34
    Service Address 41
    Service Item 54
    Service Level Agreement 55
    Service Request 116
    Work Order Tracking 129
applications, list of extended 12
applications, list of new 12
Assets application 44
    adding an asset 178
    associating a classification for an asset 47
    creating a new asset 45, 101, 215
    overview of new features 21
    searching for an asset 179, 193

B
Bill Batch application
    creating customer billing 119
Billing Review application
    overview 17
    reviewing 135
    viewing billing details 120
Bulletin Board application 72
    creating a new bulletin board 72
Bulletin Boards application, overview of new features 23

C
Classification application
    associate a classification with a CI 53
    creating a new classification 50
    making classifications usable 216
    types 50
Classifications and Attributes application, overview of new features 22
Configuration Item application
    creating Configuration Items 48
Configuration Item application, overview of new features 21
creating a new customer agreement 60
Customer Agreement application 59–60
    applying a customer agreement 133
    associating with customers 183
    conditions 113, 126
    creating a customer agreement 124
    creating a customer agreement with a price schedule 110
    creating a new agreement 165
    creating a price schedule 60
    creating labor pricing rules 62
    creating markups 62
    creating materials pricing rules 64
    creating tools pricing rules 65
    overview 13
    price schedule details 112
    pricing rules 127
    revising a customer agreement 220
    searching for assets 184
    searching for customer agreements 184
    values 111
Customer application 29
    creating a new customer 29, 110, 239
    overview 13
Customer Billing application
creating customer billing 133–134
overview 16
Customer Objects application 32
creating conditions 238
overview 19

D
Deployed Assets application, overview of new features 21
DMPLUSPRP object structure 143
DMPLUSPSLA object structure 142
Domains application 36
overview of new features 22
values 36

E
escalations
creating 70
service desk escalations 87
extended applications 20

I
Incidents application
overview of new features 20
Item Master application, overview of new features 23

L
labor pricing rules, creating 62
Locations application 39
creating a new location 40, 101, 214
searching for locations 187
Locations application, overview of new features 21

M
markups, creating 62
materials pricing rules, creating 64
Meters application
creating a new meter 214
Migration Groups application
creating migration groups 141
Migration Manager application
components 140
creating package definitions 140, 145
deploying a package 153
managing targets 146
menu 139

P
package definitions 140, 145
activating 148
displaying 150
distributing 151
saving 148
package files
deploying 153
uploading 153
People application
searching for people 181
PMs (preventive maintenance records) 161
Preventive Maintenance application
creating PM records 161
generating a work order 166
price schedules
conditions 126
creating price schedules 60, 219
revising a price schedule 220
using in a customer agreement 124
pricing rules
materials 127
services 127
Problems application
overview of new features 20

uploading a package 153
migration objects 141
Move Modify Assets application
select the location 104

N
New applications 13
new customer
creating 29

O
Object Structures application
manipulating migration objects 141
Response plan 143
SLA 142
Organization application 26
Billing options 28
Service options 27
SLA options 26
SLA options configuration 198
Work Order options 26

260  Implementing IBM Maximo for Service Providers
R
Reconciliation application, overview of new features 21
Redbooks Web site 258
Response Plan application
   associating a response plan with a customer 115
   changing the status 115
   creating a new response plan 66, 115
   ranking values 116
Response Plan application, overview 18

S
Sales Order application
   creating a sales order 228
   overview 17
Security Groups application 34
   adding users 182
   associating users 191
   creating security groups 240
   creating security privileges 34, 176
   data restrictions 174
   overview of new features 22
Service Address application 41
   creating a service address 42
Service Address application, overview 15
   service desk escalations 87
Service Items application 54
   overview of new features 23
Service Level Agreement application 55
   applying a non severity 1 SLA service request 203
   applying a severity 1 SLA service request 208
   build conditions 58
   creating a new SLA 56, 162
   creating a non severity 1 SLA 200
   creating a severity 1 SLA 202
   overview of new features 23
Service Request application
   applying a response plan 118
   creating a new service request 116
   overview of new features 20
   submitting 90
   validating 94
   viewing updates 92
   working and resolving 96
SLA options 26

T
targets, managing 146
tools pricing rules, creating 65

W
Work Order Tracking application
   creating a work order 129
   searching for work orders 191
Work Orders
   options 26
Implementing IBM Maximo for Service Providers

Learn best practices for implementing IBM Maximo for Service Providers

The IBM Maximo for Service Providers product is designed to support Service as a business. It helps lower total cost-of-ownership and increase profitability and customer satisfaction by managing clients’ assets either through third-party outsourcing or internally shared services model.

Experiment with real life scenarios

This IBM Redbooks publication introduces IBM Maximo for Service Providers product and its components. We took a practical approach in this book, and presented the features and functions of the IBM Maximo for Service Providers product in the context of a number of real-life scenarios or usage patterns. These scenarios are commonly used at IBM customer sites to satisfy specific business requirements. For each scenario, we establish the business reason, benefits, and how to implement the scenario. There is also a section on initial product configuration that touches on several configuration points, such as creating the customers, security groups, and response plans.

Understand the product components

This book is a reference guide for IT Specialists and IT Architects implementing IBM Maximo for Service Providers.